Subject: Re: Help with wu-ftpd 2.4 and Solaris 2.4

From: [email-masked]
Date: Tue, 24 Jan 1995 11:14:30 -0800 (pst)

Sounds like you did not create the special files needed in your dev 
     directory under your anonymous ftp directory. In your Solaris manpage 
     for ftpd it lists 4 files that should be created: tcp, ticotsord, udp, 
     zero. I know you will have to at least create tcp and zero to fix your 
     error.
     
     Use mknod to create the files with the following numbers:
     
               tcp        11,42
               ticotsord  105,1
               udp        11,41
               zero       13,12
     
     Steven Nemetz

______________________________ Reply Separator _________________________________
Subject: Help with wu-ftpd 2.4 and Solaris 2.4
Author:  [email-masked] at internet-mail
Date:    1/24/95 10:53 AM

I've been trying to install wu-ftpd anew on a SPARCcenter 1000 running 
Solaris 2.4.  It's unhappy about creating sockets... the compilation 
proceeds normally and I can connect to the daemon, but any commands 
result in:
425 Can't create data socket (0.0.0.0,20): Bad file number.
     
I traced this back in the source... made sure all the headers were in
the places expected and the appropriate libraries were on the compilation 
line (-lsocket -lnsl).  I'm using gcc 2.5.6 and everything else 'as 
packaged'.
     
Any help would is appreciated.
     
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 
Michael A. Rice                        [email-masked] 
   University of Houston               [email-masked]
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        "Sometimes I think that the surest sign that 
         intellegent life exists elsewhere in the universe 
         is that none of it has tried to contact us."          -Calvin
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: Michael Rice <[email-masked]>
Date: Tue, 24 Jan 1995 16:51:05 -0600 (CST)

Thank you for your reply regarding wu-ftpd and Solaris 2.4.

-Michael Rice
 [email-masked]

---

From: Rafhael Cedeno <[email-masked]>
Date: Tue, 24 Jan 1995 23:19:27 -0500

I installed a minimally modified ftpaccess.heavy (diffs included)
The ftpconversions is the example file and the
ftpusers and ftpgroups are empty files.

when I ftp (as cedeno) to the Linux machine, I can get directories
using .tar.gz  but when I try an anonymous ftp, .tar.gz  (or any 
conversions) dont work; without extensions work fine.  

It will say something like:

ftp> get bin.tar.gz
200 PORT command successful.
150 Opening BINARY mode data connection for /bin/tar.
226 Transfer complete.

without sending any data.  I get a new file with no content.
Has anyone seen this before?  Thanks for any help.

Rafhael Cedeno
[email-masked]

---

From: Alexander Haiut <[email-masked]>
Date: Wed, 25 Jan 1995 16:53:53 -0200 (GMT-0200)

> using .tar.gzbut when I try an anonymous ftp, .tar.gz  (or any

	In ftpaccess.heavy you have the following two lines:

	compress        yes             local remote
	tar             yes             local remote

	This means, that using tar and compress features is enables
	only for users in class *local* and *remote*. Add the word
	*anonymous* or *all* instead *local remote* in this file.

	That's all.		--alex.

  Alexander L. Haiut
  Dept. of Computer Science		 	
  Ben-Gurion University, Israel
 _______________________________________
  www    : http://www.cs.bgu.ac.il/~alx
  e-mail : [email-masked]
  voice  : +972-7-461658

---

From: Rafhael Cedeno <[email-masked]>
Date: Wed, 25 Jan 1995 15:48:14 -0500

>	*anonymous* or *all* instead *local remote* in this file.

my ftpaccess:
class   local   real,guest,anonymous *.cs.buffalo.edu 0.0.0.0
class   remote  real,guest,anonymous *
...
compress        yes             local remote anonymous
tar             yes             local remote anonymous

still dont work. :-)  "anonymous" isn't a class, so it doesn't seem like
it should be there.  anyway, when the class isn't listed, and the ftp
user is in that class, I get : "file not found" or something simliar,
not a "transfer complete".  I didn't send the diffs in my last posting, so 
here there are.  Recall that I installed a minimally modified 
ftpaccess.heavy (diffs included) 
The ftpconversions is the example file and the ftpusers and ftpgroups 
are empty files.  When I try to get a file, I get a 0 length file,
but it says its successful.

*** ftpaccess	Wed Jan 25 15:11:42 1995
--- ftpaccess.heavy	Fri Apr  1 14:03:24 1994
***************
*** 1,21 ****
  loginfails 2
  
! class   local   real,guest,anonymous *.cs.buffalo.edu 0.0.0.0
  class   remote  real,guest,anonymous *
  
! limit   local   20  Any                 /var/spool/ftpd/msgs/msg.toomany
! limit   remote  100 SaSu|Any1800-0600   /var/spool/ftpd/msgs/msg.toomany
! limit   remote  60  Any                 /var/spool/ftpd/msgs/msg.toomany
  
  readme  README*    login
  readme  README*    cwd=*
  
! message /var/spool/ftpd/msgs/mirrors.msg   cwd=/mirrors
! message /var/spool/ftpd/msgs/welcome.msg   login
  message .message                cwd=*
  
! compress        yes             local remote anonymous
! tar             yes             local remote anonymous
  
  # allow use of private file for SITE GROUP and SITE GPASS?
  private         yes
--- 1,20 ----
  loginfails 2
  
! class   local   real,guest,anonymous *.domain 0.0.0.0
  class   remote  real,guest,anonymous *
  
! limit   local   20  Any                 /etc/msgs/msg.toomany
! limit   remote  100 SaSu|Any1800-0600   /etc/msgs/msg.toomany
! limit   remote  60  Any                 /etc/msgs/msg.toomany
  
  readme  README*    login
  readme  README*    cwd=*
  
! message /welcome.msg            login
  message .message                cwd=*
  
! compress        yes             local remote
! tar             yes             local remote
  
  # allow use of private file for SITE GROUP and SITE GPASS?
  private         yes
***************
*** 25,31 ****
  
  log commands real
  log transfers anonymous,real inbound,outbound
! shutdown /etc/shutdownftp
  
  # all the following default to "yes" for everybody
  delete          no      guest,anonymous         # delete permission?
--- 24,30 ----
  
  log commands real
  log transfers anonymous,real inbound,outbound
! shutdown /etc/shutmsg
  
  # all the following default to "yes" for everybody
  delete          no      guest,anonymous         # delete permission?
***************
*** 55,58 ****
  # specify which group of users will be treated as "guests".
  guestgroup ftponly
  
! email cedeno
--- 54,57 ----
  # specify which group of users will be treated as "guests".
  guestgroup ftponly
  
! email user@hostname

---

From: Stephen Dorsett <[email-masked]>
Date: Wed, 25 Jan 1995 18:06:42 -0500 (EST)

I have just spent about 4 hours of my short life trying to pave the forest
(read: build gcc) so I can start building wu-ftpd. I have now officially 
exceeded my frustration and tolerance threshold.

Would some kind person let me snag a copy of the built daemon 
for SunOS 4.1.3 from them ? If this is not the correct forum for a
request like this, please (gracefully) advise.

Thanks, Steve
 
========================================================================
Stephen Dorsett                            [email-masked]  
Wide Area Network Manager, GIEx Corp.      1-800-514-5NET   
========================================================================

---

From: Anto Daryanto <[email-masked]>
Date: Thu, 26 Jan 1995 07:24:46 +0700 (WIB)

unsubscribe wu-ftpd

---

From: [email-masked] (Wang Quan)
Date: Thu, 26 Jan 1995 10:42:06 +0800 (CST)

> unsubscribe wu-ftpd

If you want to unsubscribe wu-ftpd,  please send a mail to 
 [email-masked]

with following line

unsubscribe wu-ftpd.

---

From: Alexander Haiut <[email-masked]>
Date: Thu, 26 Jan 1995 14:57:37 -0200 (GMT-0200)

Hi,

> still dont work. :-)"anonymous" isn't a class, so it doesn't seem like
> it should be there.

	Oops.. Please, exuse me my mistake...
	My ftpaccess file has the lines:

	compress        yes             all local remote
	tar             yes             all local remote

	It works.. My mistake (in the message I sent you) was that I
	erroniously supposed that putting *anonymous* in place of *all*
	in these lines will give the same result..
	
	I missed that *anonymous* is not a class. I appologize for this
	mistake. Please, try with *all* keyword (as I do), I had the same
	problem and got it working.

	Please, let me know the results.

		Thanks!				-alex.

  Alexander L. Haiut

---

From: Tianlin Wang <[email-masked]>
Date: Thu, 26 Jan 1995 10:18:47 -0600

>> tar           yes             local remote anonymous

I am running wu-ftpd on Solaris2.3, and I have the same problem.
when I type
   get foo.tar
I get an empty (zero-size) foo.tar.

If someone can give me any hints, I will appreciate.

My setting is as follows:

------------------------------------------------------------------------
/export/ftp/bin ls
compress*  ftp-exec/  gzip*      ls*
egrep*     gunzip*    head*      tar*

------------------------------------------------------------------------
/usr/local/etc more ftpconversions
 :.Z:  :  :/bin/compress -d -c %s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
 :   : :.Z:/bin/compress -c %s:T_REG:O_COMPRESS:COMPRESS
 :.gz: :  :/bin/gzip -cd %s:T_REG|T_ASCII:O_UNCOMPRESS:GUNZIP
 :   : :.gz:/bin/gzip -9 -c %s:T_REG:O_COMPRESS:GZIP
 :   : :.tar:/bin/tar -c -f - %s:T_REG|T_DIR:O_TAR:TAR
 :   : :.tar.Z:/bin/tar -c -Z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+COMPRESS
 :   : :.tar.gz:/bin/tar -c -z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+GZIP

------------------------------------------------------------------------
/usr/local/etc more ftpaccess
class   all   real,guest,anonymous  *
 
limit   all   30   Any              /etc/msgs/msg.dead
 
readme  README*    login
readme  README*    cwd=*
 
message /etc/msgs/welcome.msg    login
message .message                cwd=*

log commands real
 
# shutdown /etc/msgs/shutmsg
 
email [email-masked]

-----------------
Best Regards
Tianlin Wang (217-244-6006, [email-masked])