Subject: ls -l probs

From: [email-masked] (Philip Sauer)
Date: Wed, 18 Jan 1995 08:28:33 +0200

If anyone has some advice on getting ls -l to produce any
output on wu-ftpd2.4 I'd be very greatful. Normal ls works fine. I
copied my local ls to ftp/bin and the libs that are neccessary to
ftp/lib. Also in ftpaccess I have lslong  /bin/ls -lgR
lsshort /bin/ls -l
lsreal  /usr/local/bin/ls -l. Is there anything else that I should
do ?

Tanx

Philip Sauer

---

From: Ric Anderson <[email-masked]>
Date: Wed, 18 Jan 1995 09:01:23 -0700 (MST)

> lsreal  /usr/local/bin/ls -l. Is there anything else that I should

Try
	chroot ~ftp /bin/ls
which will run ~ftp/bin/ls while the file system is rooted at
the "~ftp" directory.  This is roughly what anonymous ftp does
with "ls".  I suspect you'll get some error at that point which
will give you a clue as to what is wrong (like maybe you need
a ~ftp/dev/zero or something of that ilk).

Cheers,
Ric (<[email-masked]> "Ric Anderson", speaking for himself)