Subject: Having problems with wu-ftpd-2.4

From: [email-masked] (Phillip Krokidis)
Date: Tue, 24 Jan 1995 17:41:17 +1100

I am trying to set up directories to which users may use FTP to leave 
and collect files from. I want users to use passwords to access these
directories. Like anonymous FTP I dont want them to be able to go 
higher in the directory tree. I have created a test user in the passwd file
and included the user in the group file. The entry in the passwd looks
like this,
   company1:*:3000:3000:FTP Real user Company:/var/spool/ftplockers/company1:

The entry in the group file,
    company1:*:3000:

The problem is that the ftp user can move higher in the directory tree and
access directories I do not want to be seen. 

I have tried it with and without an ftpaccess file (ie with the -a or -A
option in inetd.conf). Do I need to enable the ftpaccess file?

Here is a copy of my ftpaccess file.
------------------------------------------------------------------------------
loginfails 2

autogroup ftp remote
autogroup company1 local

class   local   guest *
class   remote  real,anonymous *

limit   local   20  Any                 /etc/msgs/msg.toomany
limit   remote  100 SaSu|Any1800-0600   /etc/msgs/msg.toomany
limit   remote  60  Any                 /etc/msgs/msg.toomany

readme  README*    login
readme  README*    cwd=*

message /welcome.msg            login
message .message                cwd=*

compress        yes             local remote
tar             yes             local remote

# allow use of private file for SITE GROUP and SITE GPASS?
private         yes

# passwd-check  <none|trivial|rfc822>  [<enforce|warn>]
passwd-check    rfc822  warn

log commands real,guest
log transfers anonymous,guest,real inbound,outbound
shutdown /etc/shutmsg

# all the following default to "yes" for everybody
delete          no      guest,anonymous         # delete permission?
overwrite       no      guest,anonymous         # overwrite permission?
rename                  no              guest,anonymous                 # rename permission?
chmod           no      anonymous               # chmod permission?
umask           no      anonymous               # umask permission?

# specify the upload directory information
upload  /var/spool/ftp  *             no
upload  /var/spool/ftp  /incoming     yes     root    daemon  0600 dirs
upload  /var/spool/ftp  /bin          no
upload  /var/spool/ftp  /etc          no
upload  /var/spool/ftplockers/company1  yes   company1 company1 0600 dirs

# directory aliases...  [note, the ":" is not required]
alias   inc:    /incoming

# cdpath
cdpath  /incoming
cdpath  /pub
cdpath  /

# path-filter...
path-filter  anonymous  /etc/pathmsg  ^[-A-Za-z0-9_\.]*$  ^\.  ^-
path-filter  guest      /etc/pathmsg  ^[-A-Za-z0-9_\.]*$  ^\.  ^-

# specify which group of users will be treated as "guests".
guestgroup company1

email [email-masked]

------------------------------------------------------------------------------

Also, xferlog is not recording any file transfers.
I have tried the following in inetd.conf: 
ftp     stream  tcp     nowait  root    /usr/libexec/ftpd       ftpd -l -o -i -A

aswell as:
ftp     stream  tcp     nowait  root    /usr/libexec/ftpd       ftpd -l -a

Do I need an entry syslog.conf?

Your help would be greatly appreciated!

Thanks,

___________________________________________________________________________
Phillip Krokidis
(Network Manager)

Internet Access Australia Pty Ltd.
769 Centre Rd                          Tel: +61 3 5764222
East Bentleigh, 3165                   Fax: +61 3 5637854
Victoria, Australia                 e-mail: [email-masked]

---

From: [email-masked] (Phillip Krokidis)
Date: Tue, 24 Jan 1995 16:53:29 +1100

Why did you send this back to me?

>Do I need an entry in syslog.conf?
>
>

---

From: Peter Drier <[email-masked]>
Date: Thu, 26 Jan 1995 13:54:23 -0500

> The entry in the group file,
good and ok..  you might want to make the group name something like ftponly.

> option in inetd.conf). Do I need to enable the ftpaccess file?

YES

> autogroup ftp remote

I dont' think you need this.. ?

> autogroup company1 local

Here's your mistake..  make that: 

guestgroup company1

( or ftponly like I said above)

> log transfers anonymous,guest,real inbound,outbound

here's where transfers are logged..  anyone who is a guest should be
logged.

> upload  /var/spool/ftplockers/company1  yes   company1 company1 0600 dirs

you need a / in the last line.. right here^  with another space before the yes.

> Also, xferlog is not recording any file transfers.

It should if guest groups are set up right..

> Do I need an entry syslog.conf?

YES... Of course..  

Did this help?

Peter Drier

---

From: [email-masked] (Phillip Krokidis)
Date: Mon, 30 Jan 1995 00:16:21 +1100

I got it working finally. The problem was in the file pathnames.h
in which the previous Unix administrator had not included a path 
to the ftpaccess file.
Hence I needed to recompile the code with the path included. 

Thanks for your help Peter Drier and Marty Hoff.

----------------------------------------------------------------------------
Phillip Krokidis

Internet Access Australia Pty Ltd.    
769 Centre Rd                          Tel: +61 3 576 4222
East Bentleigh, 3165                   Fax: +61 3 563 7854
Victoria, Australia                    e-mail: [email-masked]
----------------------------------------------------------------------------

---

From: "The best things in life ... are fantasy." <[email-masked]>
Date: Tue, 31 Jan 1995 11:24:41 -0500 (EST)

Hi Phil,

I see your misunderstanding. In pathnames.h you should have listed where
you want xferlog to be placed. This file will hold information about transfers
*only*. The daemon.info -- which is the file specified in syslog.conf -- will
hold all information from the ftpd (and possibly others) daemon. This file
should be initially created by touch, unless I remember wrong. At any rate,
these are two seperate files. With two seperate entry types.

Good Luck,

PCVS