Subject: uploads to wu-ftpd 2.4 on DEC OSF/1 1.3 [1095]

From: Guy Helmer <[email-masked]>
Date: Wed, 11 Jan 1995 10:56:16 -0600 (CST)

I've just tried implementing an anonymous uploading scheme on my site's
main FTP server, a DEC Alpha running OSF/1 1.3 running wu-ftpd 2.4. 

I've created an uploading directory, ~ftp/pub/departments/incoming/cs,
owned by root with permissions "rwxrwx-wx" and it has an entry in 
ftpaccess like this:
upload  /var/ftp  /pub/departments/incoming/cs  yes root cs  0660 nodirs

But, when I try to upload (put) any file into this directory, the client
says "fchown: not owner" and the file in the upload directory has a length
of 0 bytes and is still owned by "ftp". 

Might anyone have any suggestions?

Guy Helmer, Dakota State University Computing Services - [email-masked]

---

From: Alexander Haiut <[email-masked]>
Date: Sun, 15 Jan 1995 13:44:42 +0200 (GMT+0200)

Hi,

> of 0 bytes and is still owned by "ftp".

	Check, with which UID runs your ftpd. Only ftpd running as root
	can create files specified UID (non-root users cannot run CHOWN).

		Thanks.		--alex.
 
  Alexander L. Haiut
  Dept. of Computer Science		 	
  Ben-Gurion University, Israel
 _______________________________________
  www    : http://www.cs.bgu.ac.il/~alx
  e-mail : [email-masked]           
  voice  : +972-7-461658