Subject: FTP log time off (GMT?), how do I fix it?

From: [email-masked] (Brian D. Schieber)
Date: Mon, 23 Jan 1995 11:29:34 -0500 (EST)

Hi,
 My SYSLOG is now reporting GMT time (well, its 5 hours off)
after I just installed WU-FTP.  How do I get WU-FTP to report
local time?  

Also, /etc/issue no longer issues.  What/where do I do this
initial message with WU-FTP?  I see .message works in subdirs
but doesn't do it for initial logins.

Thanks,
--Brian

| Brian D. Schieber 
| SeaDAS/SeaWiFS Projects 
| Laboratory for Hydrospheric Processes 
| NASA/Goddard Space Flight Center 
| Code 971/GSC, Greenbelt, MD 20771
| [email-masked] 
| http://shark.gsfc.nasa.gov/~schieb/home_page.html/

---

From: Anthony D'Atri <[email-masked]>
Date: Mon, 23 Jan 1995 10:51:05 -0800 (PST)

>after I just installed WU-FTP.

Are you running SunOS 5?  I've seen this sort of thing happen there
with, eg., nntplink.

---

From: Scott Blachowicz <[email-masked]>
Date: Mon, 23 Jan 1995 13:49:09 -0800

> Are you running SunOS 5?  I've seen this sort of thing happen there

Maybe it (either ftpd or your syslogd?) just needs to inherit an appropriate
$TZ setting?  I use this trick in our csh login to get the right setting into
csh logins:

        setenv TZ `sh -c '. /etc/TIMEZONE; echo $TZ'`

I grabbed that from somewhere - the point being that for SunOS 5, it appears
that an appropriate thing to do to get the time zone setup properly is to
source that /etc/TIMEZONE file.

Scott Blachowicz    Ph: 206/283-8802x240    StatSci, a div of MathSoft, Inc.
                                            1700 Westlake Ave N #500
[email-masked]                           Seattle, WA USA   98109
[email-masked]

---

From: [email-masked] (Brian D. Schieber)
Date: Mon, 23 Jan 1995 17:56:43 -0500 (EST)

> Are you running SunOS 5?  I've seen this sort of thing happen there
No. IRIX5.2

Thanks,
--Brian

| Brian D. Schieber

---

From: Alexander Haiut <[email-masked]>
Date: Tue, 24 Jan 1995 13:24:27 -0200 (GMT-0200)

Hi!

 	Heh.. Cannot help you with the GMT problem.. :)

> Also, /etc/issue no longer issues.What/where do I do this
> initial message with WU-FTP?I see .message works in subdirs

	Try to read carefully /etc/ftpaccess file (or whenever
	you put it -- **ftpaccess** -- main config file ).
	There should be lines like:

	message /.welcome                login
	message .message                cwd=*

	This means, that after login the /.welcome file will be
	displayed, and .message (from current directory) will be
	displayed in after each CWD (change working dir.) command.

	You're free to change these filenames.	That's all.

		Thanks!		--alex.

  Alexander L. Haiut
  Dept. of Computer Science		 	
  Ben-Gurion University, Israel
 _______________________________________
  www    : http://www.cs.bgu.ac.il/~alx
  e-mail : [email-masked]
  voice  : +972-7-461658

---

From: [email-masked] (Winfried Magerl)
Date: Tue, 24 Jan 1995 13:03:54 +0100 (MET)

> > Are you running SunOS 5?  I've seen this sort of thing happen there

Look in your config-file in src/config and check if you have:
#undef  SETPROCTITLE

With SETPROCTITLE defined, $TZ (set in /etc/TIMEZONE) get lost
and you have GMT.

regards

	winfried

-- 
Winfried Magerl - Internet Administration
Siemens Nixdorf AG, GP QM/S IF, 81739 Munich, Germany
Internet-Mail: [email-masked]

---

From: Stephen Dorsett <[email-masked]>
Date: Tue, 24 Jan 1995 09:32:16 -0500 (EST)

OK, I admit it. I have _NOT_ read the entire book on wu-ftpd yet.

Would someone please save me much time and answer a couple of 
quick questions about wu-ftpd applications ?

I am looking for a tool to restrict ftp access to our site. The goal is 
to allow users with valid usernames to log in and have access only to
certain areas (home dir and some public files, /pub would work nicely).

I do not need (or want) to provide anonymous access.

Is wu-ftpd the tool for me ? If not, can you suggest one ?

========================================================================
Stephen Dorsett                            [email-masked]  
Wide Area Network Manager, GIEx Corp.      1-800-514-5NET   
========================================================================

---

From: Stephen Dorsett <[email-masked]>
Date: Tue, 24 Jan 1995 15:00:09 -0500 (EST)

I was one of the first folks to pay homage to O'Reilly and buy their book
"Managing Internet Information Services". Had my order placed a month 
before printing.... Are you duly impressed ? :-)

They have a whole _chapter_ on wu_ftpd....

Steve

On Tue, 24 Jan 1995, Brian D. Schieber wrote:

> Where is this book anyway?  I didn't get one with my TAR.
> 
> > 
> Yes, it is.  As far as I can tell (also a newbie).  I've seen lots of 
> files refering to user access limitations.  The more export users could
> tell you more...
> 
> BTW, I had a couple minor snags getting it going but its running real
> sweet now.  And I love the access reporting.
> 
> >

---

From: [email-masked] (Brian D. Schieber)
Date: Tue, 24 Jan 1995 13:25:57 -0500 (EST)

Thanks,
--Brian

| Brian D. Schieber

---

From: Alexander Haiut <[email-masked]>
Date: Wed, 25 Jan 1995 15:56:12 -0200 (GMT-0200)

> Where is this book anyway?I didn't get one with my TAR.

 The book is: Managing Internet Information Services
              Edited by Adrian Nye, w/ Liu, Peek, Jone & Buus

		Enjoy.		--alex.

  Alexander L. Haiut