Subject: Re: uploads to wu-ftpd 2.4 on DEC OSF/1 1.3 [1095] [1107] [1119]

From: Guy Helmer <[email-masked]>
Date: Thu, 12 Jan 1995 08:56:04 -0600 (CST)

On Thu, 12 Jan 1995, Sze-Yao Ni wrote:

> > But, when I try to upload (put) any file into this directory, the client
> > says "fchown: not owner" and the file in the upload directory has a length
> > of 0 bytes and is still owned by "ftp".
> > Guy Helmer, Dakota State University Computing Services - [email-masked]
>  
> I traced the problem before, I found the error message comes from src/ftpd.c:
>         if ((fchown(fdout, uid, gid)) < 0) {
>             (void) seteuid(oldid);
>             perror_reply(550, "fchown");
>             return;
>         }
> , then I try to use lchown:
>         if ((lchown(name, uid, gid)) < 0) {
>             (void) seteuid(oldid);
>             perror_reply(550, "lchown");
>             return;
>         }
> and it works! Maybe it is a bug in OSF/1 V1.3.

It does work!  Thanks!

Is there a reason for using lchown(2) instead of chown(2)?

> ::  Sze-Yao Ni  (Sze4-Yao2 Ni2)

Guy Helmer, Dakota State University Computing Services - [email-masked]

---

From: [email-masked] (Paul Blair)
Date: Thu, 12 Jan 1995 15:18:55 -0800 (PST)

I have had this same symptom on SunOS 4.1.3U1...  Still no
solution though. :/

		Paul