Subject: What is /etc/ftponly?

From: Richard Harris <[email-masked]>
Date: Thu, 19 Jan 1995 14:39:19 -0500

I have installed wu-ftpd-2.4 on our SunOS 4.1.3 system.
I want to set up a "guestgroup" as described in the man page
for ftpaccess.  The information on "guestgroup" shows an entry
in /etc/passwd that has a shell file of "/etc/ftponly".
My system has no such file, and I would like to know how
to make this file.

Thank you,

Richard Harris

---

From: Kris Allan Kahn <[email-masked]>
Date: Thu, 19 Jan 1995 12:34:42 -0800 (PST)

There are a number of different ways to do this, here's mine:

Create (or add to) /etc/shells with the contents:
	/bin/sh
	/bin/csh
	/bin/ksh
	/etc/ftponly

	(I know that at least Suns need an /etc/shells file)

Create a bogus shell not usable for login purposes, but valid in /etc/shells:

	ln -s /bin/false /etc/ftponly

	(you actually don't need the link if you feel secure that /etc/ftponly
	 will never exist. 8)

If someone has another or better way, please let us know.

##/* In regards to the letter from Richard Harris: */##
## 
## I have installed wu-ftpd-2.4 on our SunOS 4.1.3 system.
## I want to set up a "guestgroup" as described in the man page
## for ftpaccess.  The information on "guestgroup" shows an entry
## in /etc/passwd that has a shell file of "/etc/ftponly".
## My system has no such file, and I would like to know how
## to make this file.
## 
## Thank you,
## 
## Richard Harris

-- 
  _____  _  _______ ____________  WHO: Kris Allan Kahn - [email-masked]  _____
 /__  / /.\ | . \ |_| / __ \ __ \ WHAT: Network Engineer - 415.472.1600  \  __\
   / /_/ _ \| __/  _  \ \/ / |/ / WHERE: North Bay Network - !SLIP/PPP! __\ \
  /_____/ \___| |_| |_|\__/|___/  WHYNOT: Every exit is also an entrance\____\
  Hackers, good.  Crackers, bad.  ADDRESS: 4000 Civic Center Dr, 4th fl.
             Got it?                       San Rafael, CA 94903

---

From: [email-masked] (Patrick Salsbury)
Date: Thu, 19 Jan 1995 13:02:07 -0800 (PST)

-Errors-To: [email-masked]
-Date: Thu, 19 Jan 1995 14:39:19 -0500
-From: Richard Harris <[email-masked]>
-Errors-To: [email-masked]
-Reply-To: [email-masked]
-Content-Transfer-Encoding: 7BIT
-
-I have installed wu-ftpd-2.4 on our SunOS 4.1.3 system.
-I want to set up a "guestgroup" as described in the man page
-for ftpaccess.  The information on "guestgroup" shows an entry
-in /etc/passwd that has a shell file of "/etc/ftponly".
-My system has no such file, and I would like to know how
-to make this file.
-
-Thank you,
-
-Richard Harris
-
	Just create an entry for it in /etc/shells. Alternatively, if you want
to be extra safe, change /etc/ftponly to /bin/false. That will deny them a
login as well. (I think you have to then add /bin/false to /etc/shells.)

Pat
-------------------------------------------------------------------------------
	  Patrick Salsbury 	                  Visionware           
	Sys Admin/Webmaster             4500 Bohannon Dr., Suite #280  
	Voice: 415/325-2113	             Menlo Park, CA 94025      
	 FAX: 415/325-8710	      X/UNIX/PC Integration Specialists