Subject: Re: Having problems with wu-ftpd-2.4

From: [email-masked] (Phillip Krokidis)
Date: Sat, 28 Jan 1995 20:25:28 +1100

Peter,

Thanks for responding. Your suggestions sound good.
I tried what you said but It didnt seem to work. The guest user can still
move higher in the directory tree. The CHROOT doesnt seem to work.
Also I couldnt get any transfers logged in the xferlog file.
ARGH! hehe

Hey do I need a dummy shell for the user?  You'll notice I didnt
include one in the passdw file.

Here are some of the changes I made:

>> like this,
>>    company1:*:3000:3000:FTP Real user Company:/var/spool/ftplockers/company1:
>>
>> The entry in the group file,
>>     company1:*:3000:
>>
>good and ok..  you might want to make the group name something like ftponly.
>

Ok I now have the following line in my group file:

ftponly:*:3000:company1

>> I have tried it with and without an ftpaccess file (ie with the -a or -A
>> option in inetd.conf). Do I need to enable the ftpaccess file?
>
>YES
>

Ok I now have the following line in my inetd.conf:

ftp     stream  tcp     nowait  root    /usr/libexec/ftpd       ftpd -l -a 

>> autogroup ftp remote
>
>I dont' think you need this.. ?

Ok I deleted it
>
>> autogroup company1 local
>
>Here's your mistake..  make that: 
>
>guestgroup company1

I now have the line:

guestgroup ftponly

>
>( or ftponly like I said above)
>
>> log commands real,guest
>> log transfers anonymous,guest,real inbound,outbound
>> shutdown /etc/shutmsg
>
>here's where transfers are logged..  anyone who is a guest should be
>logged.
>
>> # specify the upload directory information
>> upload  /var/spool/ftp  *             no
>> upload  /var/spool/ftp  /incoming     yes     root    daemon  0600 dirs
>> upload  /var/spool/ftp  /bin          no
>> upload  /var/spool/ftp  /etc          no
>> upload  /var/spool/ftplockers/company1  yes   company1 company1 0600 dirs
>
>you need a / in the last line.. right here^  with another space before the yes.
>

Ok done that ^

>> Also, xferlog is not recording any file transfers.
>
>It should if guest groups are set up right..
>
>> Do I need an entry syslog.conf?
>
>YES... Of course..  
>
>

I do?

Anyway I put the following line in syslog.conf:

daemon.*                        /var/log/xferlog

Is that the right line to add?

>Did this help?
>Peter Drier

Do you have any other suggestions?

Thanks,

Phil

----------------------------------------------------------------------------
Phillip Krokidis

Internet Access Australia Pty Ltd.    
769 Centre Rd                          Tel: +61 3 576 4222
East Bentleigh, 3165                   Fax: +61 3 563 7854
Victoria, Australia                    e-mail: [email-masked]
----------------------------------------------------------------------------

---

From: Marty Hoff <[email-masked]>
Date: Sat, 28 Jan 1995 11:11:09 -0600 (CST)

I think you do need a dummy shell.  Also, you need to make sure that you
have setup the home directory correctly.  It should look something like:

company1:*:3000:3000:FTP Real User
Company:/var/spool/ftplockers/./company1:/bin/ftponly (or whatever
bogus shell you want - I use /bin/true.)

Marty Hoff