Subject: RE: What is /etc/ftponly?

From: "The best things in life ... are fantasy." <[email-masked]>
Date: Thu, 19 Jan 1995 16:22:34 -0500 (EST)

You don't want it to exist except as an entry in /etc/shells. It is a phoney
shell. This is one of the security measures. You could also use /bin/false
for example.

PCVS

---

From: [email-masked] (Rand S. Huntzinger)
Date: Thu, 19 Jan 1995 15:54:13 -0500

> From [email-masked] Thu Jan 19 15:35 EST 1995
> Date: Thu, 19 Jan 1995 14:39:19 -0500
> From: Richard Harris <[email-masked]>
> Subject: What is /etc/ftponly?
> To: [email-masked]
> Content-Transfer-Encoding: 7BIT
> 
> I have installed wu-ftpd-2.4 on our SunOS 4.1.3 system.
> I want to set up a "guestgroup" as described in the man page
> for ftpaccess.  The information on "guestgroup" shows an entry
> in /etc/passwd that has a shell file of "/etc/ftponly".
> My system has no such file, and I would like to know how
> to make this file.
> 
> Thank you,
> 
> Richard Harris
> 

   It is OK for /etc/ftponly not to exist.  You put it in the passwd
entry where you don't want anybody to login other than via ftp.  Since
/etc/ftponly isn't a valid shell, attempts to login to that account other
than via ftp will fail.  I suppose you could create an executable which
prints a message to standard out saying no logins are permitted on this
account if you like.

					Randy