Subject: delet privs (again!) [1118]

From: Bruce Macdonald <[email-masked]>
Date: Thu, 12 Jan 1995 20:22:29 +0000 (GMT)

I've recently made wuftpd-2.4 on an HP9000/s700 running HPUX-9.03

Is the following behaviour considered normal?

If I have two members of the same guest-group and I allow delete
commands for guest-groups, I notice that although a file is owned 
by one member with mode 744 rwxr--r--   the other member of the
group can delete this file although he/she does not have write permission 
on the file - 

Just wondering if this is a result of the guest-group privleges or
a bug...

Bruce

---

From: Thomas Leavitt <[email-masked]>
Date: Fri, 13 Jan 1995 20:38:09 -0800 (PST)

> Just wondering if this is a result of the guest-group privleges or

Awgh. Gave me a heart attack for a moment. I checked this out on my
system, and this definitely was not the case. Something must be
buggy somewhere in your set up.

I run wu-ftpd on an 827 with 9.04, BTW.

--
Web Communications (sm)            Thomas [email-masked]
Voice: (408) 457-9671 x101         Lead Systems & Network Admin./Tech Suppt.
 
<a href="http://www.webcom.com/">Web Communications Home Page</a>

---

From: Alexander Haiut <[email-masked]>
Date: Sun, 15 Jan 1995 14:59:05 +0200 (GMT+0200)

> group can delete this file although he/she does not have write permission

	To delete file I don't need write permission to it, I need 
	permission to write in the directory.

	Check permissions on directory where the files located.

		Thanks!			--alex.

  Alexander L. Haiut
  Dept. of Computer Science		 	
  Ben-Gurion University, Israel
 _______________________________________
  www    : http://www.cs.bgu.ac.il/~alx
  e-mail : [email-masked]           
  voice  : +972-7-461658

---

From: Luke Duncan <[email-masked]>
Date: Sun, 15 Jan 1995 13:18:43 -0500 (EST)

Hi,

I'm having problems getting wu-ftpd to switch over to passive mode when 
it's requested.  The main problem this causes is people using NCSA Mosaic 
trying to connect.  The machine is a Sparc 10 Clone running Solaris 2.3.  
I've tried everything I can think of to get this to work with no luck, 
has anyone else experienced a problem like this or know of a fix for it?

Thanks,
Luke Duncan

---

From: Bruce Macdonald <[email-masked]>
Date: Mon, 16 Jan 1995 20:36:37 +0000 (GMT)

> I run wu-ftpd on an 827 with 9.04, BTW.

Nope - not a mis-config - but I did leave out a detail - and it
was pointed out to me that it is the parent directory of the file
that determines the ability to delete the file - it's a unix trait 
that I was not reallyaware of - live and learn.

Bruce