Subject: Help configuring classes?

From: Roger Bolton <[email-masked]>
Date: Fri, 20 Jan 1995 14:56:03 -0500

I'm sure this question has been ansered many times before, but I can't
find a FAQ for the ftpd so:

I want to restrict access to my ftp server to stop those from outside
Australia downloading, since the whole archive is a mirror of US content.
I also want to limit anonymous users within Australia to 25 simultaneously,
and allow unlimted local users whether anonymous or real users.

Here's my attempt at the ftpaccess file:
-----------------------------------------------------------------------

class user      real            *
class next      real,anonymous  *.next.com.au 203.8.88.*
class aust      anonymous       *.au
class world     anonymous       *
limit next      200     Any     /usr/local/etc/msgs/msg.toomany
limit aust      25      Any     /usr/local/etc/msgs/msg.toomany
limit world     0       Any     /usr/local/etc/msgs/msg.world

deny !nameserved /usr/local/etc/msgs/msg.noname

readme  README*    login
readme  README*    cwd=*

message /welcome.msg            login
message .message                cwd=*

passwd-check    rfc822  warn

compress        yes             local remote
tar             yes             local remote

log commands real
log transfers anonymous,real inbound,outbound

shutdown /etc/shutmsg

email [email-masked]
------------------------------------------------------------------

The daemon always refuses access and claims I'm in the world class with this
config, can someone please tell me what I'm doing wrong?

-- 
Roger Bolton,			Email: 	[email-masked]
Network Type Stuff,		PH:	+61 2 310-1433
Next Online Pty Ltd.		FAX:	+61 2 310-1315
Internet Service Provider,	Modems: +61 2 310-2911
Sydney, Australia.		WWW:	http://www.next.com.au/

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 19 Jan 1995 21:40:10 -0800

------ Roger Bolton, <[email-masked]> writes: 

    class user      real            *
    
    The daemon always refuses access and claims I'm in the world class with thi
    s config, can someone please tell me what I'm doing wrong?

the class configs don't deal well with these kind of situations - i
struggled with thistoo. 

i think in the file parsing code, it takes the last one which works -
did you try reversing the two anonymous class entries?

tim