Subject: [734] Anonymous-ftp problems

From: Linda L Willett <[email-masked]>
Date: Thu, 17 Nov 1994 09:39:31 -0800 (PST)

Hi

I have just compiled and installed wu-ftpd on a Sequent running ptx
v2.1.2 

Everything works OK when I log in as a real user. The problems starts
with anonymous/ftp login. I get the following error message:

   Can't create data socket( 0.0.0.0,20 ): Bad file number

Any idea on what the problem is???

Any help would be appreciated....

				Thanks
				Linda Willett
				State of Oregon - DCBS
                                [email-masked]

---

From: [email-masked] (Yoshiharu Araki - Nihon SunService S/W Support)
Date: Fri, 18 Nov 1994 10:07:22 +0900

Hi Linda,

I think Bart is right, because this problem come from library.
If you have a command like a "ldd" of Solaris("ldd - list  dynamic  
dependencies  of  executable  files  or shared objects"), you can
see what you need the library.

Example
	For Solaris2
	# ldd ftpd
	libsocket.so.1 =>	/usr/lib/libsocket.so.1
	libnsl.so.1 =>	 /usr/lib/libnsl.so.1
	libc.so.1 =>	 /usr/lib/libc.so.1
	libdl.so.1 =>	 /usr/lib/libdl.so.1
	libintl.so.1 =>	 /usr/lib/libintl.so.1
	libw.so.1 =>	 /usr/lib/libw.so.1

	For Solaris1
	# ldd ftpd
	-lc.1 => /usr/lib/libc.so.1.9
	-ldl.1 => /usr/lib/libdl.so.1.0

--Yoshiharu Araki
[email-masked]
SunService Software Support Engineer
Nihon Sun Microsystems K.K.

> From [email-masked] Fri Nov 18 06:24 JST 1994
> 
> Hi Linda,
> 
> I don't whether this is the solution since I am working on Solaris 1 SUN station
> but it might be that you are missing in the home directory of the FTP-site,
> for example .../ftp-site/ you need to have the directory :
> ../ftp-site/usr/lib with the following files ..
> 
> ld.so*         libc.so.1.9*   libdl.so.1.0*
> 
> 
> Perhaps you have already done this,
> but of course I can't see from here..
> 
> Ciao
> 	Bart
> ________________________________________________________________________________
> Bart Hendriks                      |\/\/\/|   [email-masked]
> trainee at ESA-ESRIN               |      |   tel:++39-6-94180 540/348
> European Space Agency              | (o)(o)   
> Via Galileo Gali                   C      _)  
> Casella Postale                     | ,___|   
> I-00044 Frascati                    |   /    
> ___________________________oOOo____/____\_____oOOo________________ Cheer up! ___
>