Subject: [700] compiling under Irix 5.2

From: [email-masked] (Robert Hooper)
Date: Mon, 14 Nov 1994 10:32:28 -0500 (EST)

Hi,
     I'm unable to compile wu-ftpd under Irix 5.2, using the SGI Irix 4.0.5a
defaults or from the generic forms. Has anyone done this? if so What should
I change in the *.sgi files?
             Robert

-- 
------------------------------------------------------------------------------
Robert Hooper                   | "The Hitchhiker's Guide to the Galaxy"-
University of Pennsylvania      |
4010 Locust Street              | "We'll be saying a big hello to all 
Philadelphia, PA 19104          |  intelligent life forms everywhere..."   
phone: (215) 898-4402           | "and to everyone else out there,
fax:   (215) 898-3695           |  the secret is to bang the rocks together, 
[email-masked] |  guys."
------------------------------------------------------------------------------

---

From: [email-masked] (Duc Duong)
Date: Mon, 14 Nov 1994 11:34:12 -0500 (EST)

> I change in the *.sgi files?

yes.. I have.. I've made quite a few change for it and it works
beautifully.. do you want a copy??

dduc

---

From: [email-masked] (Mischa Reinhardt)
Date: Mon, 14 Nov 1994 17:41:53 +0100 (MEZ)

>From [email-masked]  Mon Nov 14 17:23:47 1994
>Received: from wunet.wustl.edu by deep-thought.biologie.uni-freiburg.de via SMTP (931110.SGI/920502.SGI.AUTO)
>	for mischa id AA24450; Mon, 14 Nov 94 17:23:47 +0100
>Return-Path: [email-masked]
>Received: from reprocess.wunet.wustl.edu by wunet.wustl.edu
> (PMDF V4.3-10 #8766) id <[email-masked]>; Mon,
> 14 Nov 1994 09:32:28 -0500 (CDT)
>Received: from noc4.dccs.upenn.edu by wunet.wustl.edu (PMDF V4.3-10 #8766)
> id <[email-masked]>; Mon, 14 Nov 1994 09:32:09 -0500 (CDT)
>Received: from BIOCHEM.DENTAL.UPENN.EDU by noc4.dccs.upenn.edu id AA22067; Mon,
> 14 Nov 94 10:31:26 -0500
>Received: by biochem.dental.upenn.edu (931110.SGI/930416.SGI.AUTO)
> for @NOC4.DCCS.UPENN.EDU:[email-masked] id AA15648; Mon,
> 14 Nov 94 10:32:28 -0500
>Date: Mon, 14 Nov 1994 10:32:28 -0500 (EST)
>From: [email-masked] (Robert Hooper)
>Subject: [700] compiling under Irix 5.2
>To: [email-masked]
>Errors-To: [email-masked]
>Reply-To: [email-masked]
>Message-Id: <[email-masked]>
>X-Mailer: ELM [version 2.4 PL23-upenn2.9]
>Content-Type: text
>Content-Transfer-Encoding: 7BIT
>Content-Length: 811
>
>Hi,
 I have compiled wu-ftpd under IRIX 5.02 without any bigger problem.
Some modifications i don't remember them all. You can have my binary if you
like.

Bye Mischa 

-- 
+=====================================================================+
|   Mischa Reinhardt                     Institut f. Biologie II      |
|   tel.  0049-761/203/2831              AG Fukshansky                |
|          <[email-masked]>             |
+---------------------------------------------------------------------+

---

From: Matthias Sylvester <[email-masked]>
Date: Tue, 15 Nov 1994 09:39:49 +0100

> I change in the *.sgi files?

Hi

I had the same problem but I solved it.

The variable NCARGS is not defined in 5.x !
I defined it in ~/src/config/config.sgi :

#ifndef NCARGS
#define NCARGS  10240
#endif

I took that from IRIX 4.05 /usr/include/sys/param.h, but I think that
is no good way. We have to contact the SGI Newsgroups to solve that
problem of the missing variable!

The makefiles were changed - concerning the IRIX Network-Programming-Guide -
in the following order:

CFLAGS   = -O -cckr -DDEBUG ${IFLAGS} ${LFLAGS}

LIBC     = /usr/lib/libc_s.a

that's all!

Mat

-- 
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
=      Matthias Sylvester                    Computer Center      =
-                                        University of Wuppertal  -
=  SGI-IRIX, Linux, CAE, Programming             Germany          =
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
= http://www.uni-wuppertal.de/hrz/daten/adressen/m.sylvester.html =
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

---

From: [email-masked] (Robert Hooper)
Date: Tue, 15 Nov 1994 10:11:07 -0500 (EST)

> CFLAGS   = -O -cckr -DDEBUG ${IFLAGS} ${LFLAGS}
   thanks I had seen the veriable problem, and tried -cckr but
hadn't tried them together, also I completely missed the seeing
anything on the libc seting. Thanks again
             Robert