Subject: [728] Re: [724] wu-ftpd complle problem

From: [email-masked] (MBartC Eval. expires 31/12/94)
Date: Thu, 17 Nov 1994 07:29:57 +0000 (GMT)

Sorry this is in the INSTALL, instructuctions, you have to replace a headerfile
in a certain directory, I quote : INSTALL

 If cc complains about strunames, typenames, modenames, ... being undefined
    you need to install support/ftp.h as /usr/include/arpa/ftp.h (always make
    a backup of the old ftp.h just in case!) and do the build again.  The new
    ftp.h should be a compatible superset of your existing ftp.h, so you
    shouldn't have problems with this replacement.

Ciao
	Bart
________________________________________________________________________________
Bart Hendriks                      |\/\/\/|   [email-masked]
trainee at ESA-ESRIN               |      |   tel:++39-6-94180 540/348
European Space Agency              | (o)(o)   
Via Galileo Gali                   C      _)  
Casella Postale                     | ,___|   
I-00044 Frascati                    |   /    
___________________________oOOo____/____\_____oOOo________________ Cheer up! ___

---

From: Michael Brennen <[email-masked]>
Date: Thu, 17 Nov 1994 09:07:58 -0800 (PST)

These names are defined in <arpa/ftp.h>, which in my 2.4 source is 
unconditionally included by ftpd.c.  In my arpa/ftp.h there must be a
#define FTP_NAMES
before the various names are defined, but that is also done in ftpd.c just
above the #include <arpa/ftp.h>.

The vers.o thing sounds like a Makefile problem; make sure the Makefile for 
your machine properly includes vers.c and vers.o in the dependencies.

If you have any more trouble, feel free to let me know and I will help what I 
can.  Please indicate the machine you are building for also.

---------------
Michael Brennen                    Intecom, Inc.
[email-masked]               5057 Keller Springs
(214) 447-8074                     Dallas,  TX  75248

>Please accept my apologies if this is a FAQ. I am trying to 
>compile wu-ftpd 2.4 and got the following messages. I'll 
>appreciate any pointer to this problem. 
> 
>
>Making ftpd.
>gcc -g -DDEBUG -I.. -I../support -L../support   -c ftpd.c -o 
>ftpd.o
>ftpd.c: In function `statcmd':
>ftpd.c:1972: `typenames' undeclared (first use this 
>function)
>ftpd.c:1972: (Each undeclared identifier is reported only 
>once
>ftpd.c:1972: for each function it appears in.)
>ftpd.c:1974: `formnames' undeclared (first use this 
>function)
>ftpd.c:1982: `strunames' undeclared (first use this 
>function)
>ftpd.c:1982: `modenames' undeclared (first use this 
>function)
>make: *** [ftpd.o] Error 1
>
>Making ftpcount.
>gcc -g -DDEBUG -I.. -I../support -L../support -o ftpcount 
>ftpcount.c vers.o -lsu
>pport
>gcc: vers.o: No such file or directory
>make: *** [ftpcount] Error 1
>
> 
>========================================================
>Ken Lui               | Voice:  (403) 496-6176
>City of Edmonton      | Fax:    (403) 496-6104
>E-mail: [email-masked]
>========================================================

---

From: Ken Lui <[email-masked]>
Date: Thu, 17 Nov 1994 09:48:17 -0700 (MST)

On Thu, 17 Nov 1994 11:48:50 +0100 (MEZ) Mischa Reinhardt wrote:

> Do you use a normal unix environment ?
> -- 
Yes, Sparc 10 with SunOS 4.1.3. with gcc ver 2.5.8.

---

From: Ken Lui <[email-masked]>
Date: Thu, 17 Nov 1994 15:33:16 -0700 (MST)

My apologies, I should have read the INSTALL more carefully. Beside 
the ftp.h, I also include -ldl in compile flag to make it work.

Many thanks.