Subject: [617] Re: [615] Re: [610] ls and ls -l woes

From: [email-masked] (Chris Eakin)
Date: Tue, 01 Nov 1994 08:45:30 -0800

On Monday Sal Collora wrote:

>I am having trouble getting ls -l to work.  LS works just fine, but
>how did you get ls -l going?

>I have a Solaris 2.3 system.  Please let me know.  I am going nuts!

>..Sal

Ron Hall returned:

>> I can't thank enough those who send their replies (thanks )/ It was Rik
>> from Artisoft who showed me the error of my ways :)
>> 
>> Doing chroot ~ftp /bin/ls -l
>> yielded command not found
>> 
>> I thought this strange ls  revealed that the bin directory was there,
>> ls -l revealed that the bin directory looked like this
>> 
>> 	lrwxrwxrwx	root	1	bin -> /archive/ftp/bin
>> 
>> This is particularly useful since /archive/ftp is ~ftp  <WHACK WHACK>
>> 
>> Once again thanks and I'll try and take a step back to see the trees in
>> the forest instead of nice book shelves :)
>> 

But now I have a question!

I have the same problem with ftp, I can't get ls -l to work on my Solaris 2 installation.
I have a new GNU ls, but I can't seem to get it to compile with the -static option. Plus, I don't understand what Ron Hall's solution is above. If I do an ls -l on the bin directory, I don't have a link like he does (i.e. bin -> /archive/ftp/bin).
So, do I just need to get ls to compile, or is that not the solution...

Any direction from here would be a big help!!!1

Chris Eakin
Asst. Sys. Admin.
SAIC
[email-masked]

---

From: Ron Hall <[email-masked]>
Date: Wed, 02 Nov 1994 10:23:21 -0500 (EST)

> >I have a Solaris 2.3 system.  Please let me know.  I am going nuts!

	The link below is bogus it point back to itself effectively
	making bin a nothing directory....

	The solution was to ln all the .so.* directories in /usr/lib into 
	/lib under ~ftp.

	I suppose you are using the GNU C compiler to compile the object
	check the man pages to verify if there is indeed a -Bstatic
	option and add it to the LDFLAGS and CFLAGS

	If you still have problems try and "talk" to me.

       Ron Hall       | DISCLAIMER:  For Those who   | "If there is a light at
       Analyst        | thought the last disclaimer  | the end of the tunnel,
 <[email-masked]> | was too scary, then this     | then it is time to order
   +1 514 398 3718    | should be a much easier ride.| more tunnel !"