Subject: [659] informational capabilities

From: baron <[email-masked]>
Date: Wed, 09 Nov 1994 11:05:30 -1000

warning: newbie alert :-)

I am trying to configure our ftpaccess file for our site, but am having
trouble getting messages to work.  I've used the sample ftpaccess file as
a template, but I am not sure what's wrong (perhaps class definition, 
permissions, or paths?).    The suspect ftpaccess entries are:

#---
class   anon      anonymous               *
class   ours      real                    *
class   local     real,guest,anonymous    *.lava.net 0.0.0.0
class   remote    real,guest,anonymous    *

message /etc/msgs/anon-login.msg          login   anon
message /etc/msgs/ours-login.msg          login   ours
#---

I assume the paths for the messages above are relative to ~ftp.  The
permissions for the files and directories in the above paths are:

/home/ftp:	dr-xr-xr-x   6 root  nogroup  512 Nov  8 21:10 ./
/home/ftp/etc:	dr--r--r--   3 root  nogroup  512 Nov  8 20:25 etc/

and for /home/ftp/etc/msgs and its contents:

dr-xr-xr-x  2 root  nogroup  512 Nov  8 21:15 ./
-r--r--r--  1 root  nogroup  186 Nov  8 20:51 anon-login.msg
-r--r--r--  1 root  nogroup  154 Nov  8 20:49 ours-login.msg

The problem, in a nutshell, is that neither message is displayed on login.
I haven't been able to get messages to display on cwd either.  Can anyone
tell me what I'm doing wrong?

--
Internet:    [email-masked]              -   Make beans into peas!
ICBM:        21 19 N     157 52 W          -       -- Benson, Time Bandits
Keywords:    V-Ball B5 RZ350               -
Disclaimer:  Objects in mirror may be closer than they appear.

---

From: [email-masked] (Michelle Butler)
Date: Wed, 09 Nov 1994 16:57:34 -0600 (CST)

If I am reading this correct.... 

your /home/ftp/etc must have execution privileges. 

for a user to get into the next level of directory structure, you 
must give them execute privileges. I have set the ftp/etc and ftp/bin 
with 555, and make the programs in bin with 111 and the messages in etc 
with 444.  Don't forget about the etc/msgs directory also needs to be 
set up like that. 

Michelle 

---------  Received message begins Here  ---------

 !! From [email-masked] Wed Nov  9 16:49:49 1994
 !! Received: from argus.cso.uiuc.edu by newton.ncsa.uiuc.edu with SMTP id AA05481
 !!   (5.65a/IDA-1.4.2 for mbutler); Wed, 9 Nov 94 16:49:48 -0600
 !! Received: from wunet.wustl.edu by argus.cso.uiuc.edu with SMTP id AA34884
 !!   (5.67b/IDA-1.5 for <[email-masked]>); Wed, 9 Nov 1994 16:23:29 -0600
 !! Received: from reprocess.wunet.wustl.edu by wunet.wustl.edu
 !!  (PMDF V4.3-10 #8766) id <[email-masked]>; Wed,
 !!  09 Nov 1994 15:20:19 -0500 (CDT)
 !! Received: from relay1.Hawaii.Edu by wunet.wustl.edu (PMDF V4.3-10 #8766)
 !!  id <[email-masked]>; Wed, 09 Nov 1994 15:07:24 -0500 (CDT)
 !! Received: from uhunix.uhcc.Hawaii.Edu ([128.171.44.54])
 !!  by relay1.Hawaii.Edu with SMTP id <11468>; Wed, 9 Nov 1994 11:06:12 -1000
 !! Received: by uhunix.uhcc.Hawaii.Edu (4.1/Sun690) id AA10981; Wed,
 !!  9 Nov 94 11:05:31 HST
 !! Date: Wed, 09 Nov 1994 11:05:30 -1000
 !! From: baron <[email-masked]>
 !! Subject: [659] informational capabilities
 !! To: [email-masked]
 !! Errors-To: [email-masked]
 !! Reply-To: [email-masked]
 !! Message-Id: <[email-masked]>
 !! Content-Transfer-Encoding: 7BIT
 !! Status: R
 !! 
 !! warning: newbie alert :-)
 !! 
 !! I am trying to configure our ftpaccess file for our site, but am having
 !! trouble getting messages to work.  I've used the sample ftpaccess file as
 !! a template, but I am not sure what's wrong (perhaps class definition, 
 !! permissions, or paths?).    The suspect ftpaccess entries are:
 !! 
 !! #---
 !! class   anon      anonymous               *
 !! class   ours      real                    *
 !! class   local     real,guest,anonymous    *.lava.net 0.0.0.0
 !! class   remote    real,guest,anonymous    *
 !! 
 !! message /etc/msgs/anon-login.msg          login   anon
 !! message /etc/msgs/ours-login.msg          login   ours
 !! #---
 !! 
 !! I assume the paths for the messages above are relative to ~ftp.  The
 !! permissions for the files and directories in the above paths are:
 !! 
 !! /home/ftp:	dr-xr-xr-x   6 root  nogroup  512 Nov  8 21:10 ./
 !! /home/ftp/etc:	dr--r--r--   3 root  nogroup  512 Nov  8 20:25 etc/
 !! 
 !! and for /home/ftp/etc/msgs and its contents:
 !! 
 !! dr-xr-xr-x  2 root  nogroup  512 Nov  8 21:15 ./
 !! -r--r--r--  1 root  nogroup  186 Nov  8 20:51 anon-login.msg
 !! -r--r--r--  1 root  nogroup  154 Nov  8 20:49 ours-login.msg
 !! 
 !! The problem, in a nutshell, is that neither message is displayed on login.
 !! I haven't been able to get messages to display on cwd either.  Can anyone
 !! tell me what I'm doing wrong?
 !! 
 !! --
 !! Internet:    [email-masked]              -   Make beans into peas!
 !! ICBM:        21 19 N     157 52 W          -       -- Benson, Time Bandits
 !! Keywords:    V-Ball B5 RZ350               -
 !! Disclaimer:  Objects in mirror may be closer than they appear.
 !! 

Michelle Butler 
National Center for Supercomputing Applications 
AFS & Mass Storage 
email: [email-masked]

---

From: baron <[email-masked]>
Date: Wed, 09 Nov 1994 14:48:53 -1000

>  !! tell me what I'm doing wrong?

That was it!  I forgot the execute bits.  Thanks, Michelle!

-baron