Subject: [794] Re: [784] Re: [777] Re: [776] Anonymous FTP on Solaris 2.3

From: "Randolph J. Herber" <[email-masked]>
Date: Mon, 28 Nov 1994 12:08:49 -0600

|Date: Mon, 28 Nov 1994 14:45:05 +0200 (METDST)
|From: Maarten Boekhold <[email-masked]>
|Subject: [784] Re: [777] Re: [776] Anonymous FTP on Solaris 2.3

|On Sun, 27 Nov 1994, Dennis E. Miyoshi wrote:

|> Noel,

|> you need to add the shared libraries to your ~ftp/lib directory

|There were more of these replies. I *have* the share libs copied to  
|~/ftp/lib (which is a sym-link to ~ftp/usr/lib), as stated in the 
|man-page of the Solaris ftpd (in.ftpd).

|So, what's up? did I miss a share lib? (ie. did SUN miss a shared lib?)

|Maarten

|_____________________________________________________________________________
||    Maarten Boekhold, Faculty of Electronical Engineering TU Delft,  NL    |
||        [email-masked]      [email-masked]         |
||          <a href="http://morra.et.tudelft.nl/~boekhold">me</a>            | 

Did you add the correct symbolic links?  The symbolic links must be correct
for the chroot(2) environment.  If you used absolute links, then it is quite
likely that they are incorrect.

I find the best way to make a symbolic link for a chroot environment and
have them be correct for both the normal environment and for the chrooted
environment is to change directory to the destination directory and do
the symbolic link from there:

	cd ~ftp/lib
	ln -s ../usr/lib/liblib.xxx .

Remember that ~ftp is a _absolute_ reference that changes its meaning when
the chroot is done.

Randolph J. Herber, [email-masked], +1 708 840 2966, CD/HQ
(Speaking for myself and not for US, US DOE, FNAL nor URA.)
(Product, trade, or service marks herein belong to their respective owners.)

---

From: [email-masked] (David L. Leach)
Date: Mon, 28 Nov 1994 10:07:42 -0700

>On Nov 28,  2:45pm, Maarten Boekhold wrote:
>> Subject: [784] Re: [777] Re: [776] Anonymous FTP on Solaris 2.3
>> On Sun, 27 Nov 1994, Dennis E. Miyoshi wrote:
>>
>> > Noel,
>> >
>> > you need to add the shared libraries to your ~ftp/lib directory
>> >
>>
>> There were more of these replies. I *have* the share libs copied to
>> ~/ftp/lib (which is a sym-link to ~ftp/usr/lib), as stated in the
>> man-page of the Solaris ftpd (in.ftpd).
>>
>> So, what's up? did I miss a share lib? (ie. did SUN miss a shared lib?)
>>
>> Maarten

I apologize if I am answering a question that has already been answered.  I
am new to the list, but have just finished setting up WU-FTPd on a Sparc20
under Solaris 2.3 also.

In addition to taking care of the shared library stuff, there is a note in
one of the help documents about creating the ~ftp/dev/tcp and ~ftp/dev/zero
device files.  This is necessary.

If you do not create these device files within the ftp filespace, a regular
ls will work, but other types of ls (like ls -l) will not.  You will get
the "Can't create data socket (0.0.0.0,20) : Bad file number" error
message.

Hope this helps.

David

--
David L. Leach
Internet Services Coordinator
Micron Internet Services
(208) 368-5336
http://www.micron.net/personal/dleach.html

---

From: [email-masked] (Tianlin Wang)
Date: Mon, 28 Nov 1994 11:09:39 -0600

> Has anyone successfully configured anonymous ftp using WU-FTPD 2.4 on 
> Solaris 2.3?
   Yes, I did. And it works fine.

---

From: [email-masked] (Laurent Schmutz)
Date: Tue, 29 Nov 1994 08:42:35 +0100

Hi,
> I can't get 'ls' to work in anonymous ftp. It keeps returning "Can't 
> create data socket (0.0.0.0,20) : Bad file number"

> Has anyone had this problem?

I have had the same problem last week. You must create the two devices 'tcp' and 'zero' in ~ftp/dev (don't make symbolic links to the still existing one in /dev) using the mknod to have:

	drwx------   2 ftp      ftponly      512 Nov 23 14:41 .
	drwx------   7 ftp      ftponly      512 Nov 23 16:06 ..
	crw-rw-rw-   1 ftp      ftponly   11, 42 Nov 23 14:40 tcp
	cr--r--r--   1 ftp      ftponly   13, 12 Nov 23 14:41 zero

But now, 'ls' is running but I can't get the 'ls -la' or 'dir' request. Any suggestions?
Thanks for your help.

						Laurent

---

From: [email-masked] (Laurent Schmutz)
Date: Tue, 29 Nov 1994 09:19:24 +0100

Hi,
Excuse-me. I've just wrote
> request. Any suggestions?
Not true. 'ls -la' and 'dir' are running well. I want just correct that with
	~ftp/usr/lib and ~ftp/dev correctly create, it's OK.
Laurent