Subject: [740] wu-ftpd on Solaris again

From: Stefan Rensing <[email-masked]>
Date: Fri, 18 Nov 1994 14:41:31 +0100 (MET)

Sorry to annoy you with another configuration problem on Solaris.
I have compiled wu-ftpd 2.4 with gcc on Solaris 2.3.
I have put the libraries ls requires into ~ftp/usr/lib.
I have created the nodes zero, null, tcp, tty according to what was
mentioned for Solaris in ~ftp/dev.
I have put all the configuration files into a single directory and
ckconfig runs well.
Yes, I have a ~ftp/passwd and group without encrypted entries for root 
and ftp.
And of course I changed /etc/inetd.conf to point to the new demon.
I even created /etc/shells.

So I was pretty sure it would work this time.

This is what happens when ftping from the same system:
421 Service not available, remote server has closed connection
Login failed.
(after you enter the login name)
And this happens when ftping from another machine:
221 Server shutting down.  Goodbye.
(after you enter the login name)
In both cases this happens regardless of the login name (I tested ftp,
root and my own user-id).

Any idea ?
Any help will be appreciated, cuz this is the third time I try to set up
the server with hints from different people (thanks).

- Stefan.

-- 
Stefan A. Rensing             Institute of Biology II/III - Schaenzlestr. 1
The SysOp Biologist           D-79104 Germany, phone: +49 761 2676 / FAX: 2675
e-mail: [email-masked]  MUD: port 4242 on that <- host
http://www.biologie.uni-freiburg.de/data/people/lije.html IRC:Lije MUD:Aragorn
                                                      "I love you !" "I know."

---

From: [email-masked] (Joe Hentzel)
Date: Fri, 18 Nov 1994 08:06:03 -0600 (CST)

> root and my own user-id).

I had the same problem on an SGI runninx IRIX 4.0.5. I figured out (eventually)
that I had put some silly text message in /etc/shutmsg, that was confusing the
ftp daemon. May not be related, but check that (and other similar files) to
see if you are inadvertantly telling it to exit.

--
Joe Hentzel                     | God made the Idiot for practice, and then
System Security                 | He made the School Board.
[email-masked]     |  -- Mark Twain

---

From: [email-masked] (Dan Pritchett)
Date: Fri, 18 Nov 1994 06:35:37 -0800 (PST)

The method I used to get wu-ftp going was to first set up the standard
Solaris ftp as according to the in.ftpd man page. Near the end of the
man page they have a script that sets Solaris up for anonymous
ftp. Why they just didn't provide the silly script in a usable form is
anybody's guess.

Once that was working, I installed wu-ftp and it worked just fine
(except for my anonymous login message and hanging daemon problems).

Hope this helps
Dan

---

From: Ron Hall <[email-masked]>
Date: Fri, 18 Nov 1994 09:35:20 -0500 (EST)

> I even created /etc/shells.

	and all the shells that are valid are listed?
> root and my own user-id).

	Did you try running the ftpd daemon in debug mode to see
	what it was trying to do?

       Ron Hall       | DISCLAIMER:  For Those who   | "If there is a light at
       Analyst        | thought the last disclaimer  | the end of the tunnel,
 <[email-masked]> | was too scary, then this     | then it is time to order
   +1 514 398 3718    | should be a much easier ride.| more tunnel !"