Subject: [711] Conversion in version 2.4

From: Wai Wong <[email-masked]>
Date: Tue, 15 Nov 1994 08:54:51 -0800

I am currently working on getting 2.4 running. The problem I seem to
be haveing is with the ftpconversion file. I am currently using the
example conversion file. but it does not seem to work for me.

I have got to the point that I verified the ftpconversions file
is being accessed by ftpd but it does not seem to be doing the
acutal conversions. If anyone can help me with this that will
be great

wai...

-- 
 -----------------------------------------------------------------------
|Wai K. Wong			Voice Mail:	(408) 496-3831		|
|Senior System Administrator	Fax:		(408) 496-3971		|
|				Email:		[email-masked]	|
 -----------------------------------------------------------------------
|			Rational Software Corporation			|
|	2800 San Tomas Expressway 	Santa Clara, CA 95051-0951	|
 -----------------------------------------------------------------------

---

From: Thomas Leavitt <[email-masked]>
Date: Tue, 15 Nov 1994 14:43:40 -0800 (PST)

Maybe y'all can figure this out:

"Service not available, remote server has closed connection"

Is the message I get after being able to successfully log on as
a guestgrouped or anonymous user, after placing a
message shut in ftp/etc/msgs/ and creating a symlink from 
/etc/msgs/msg.shut to it.

The appropriate line in ftpaccess is
/etc/msgs/msg.shut

Shutdown file:

1994 10 19 04 01 0010 0005
This is a test. Please ignore.

The WebCom FTP Server will be taken off-line on
%s. 
All further connections will be denied on
%r. 
All existing connections will be dropped on 
%s.

Thank you,

%E

---------

This message did, momentarily, work. The exact same super simple
script and command line messages produced the scary message above.

Anyone know what gives?
--
Web Communications (sm)            Thomas [email-masked]
Voice: (408) 457-9671              Lead Systems & Network Admin./Tech Suppt.
 
<a href="http://www.webcom.com/">Web Communications Home Page</a>

---

From: Thomas Leavitt <[email-masked]>
Date: Tue, 15 Nov 1994 13:16:12 -0800 (PST)

> acutal conversions. If anyone can help me with this that will

Wai,

 Check to see that there are no spaces between the suffixes and the colons.

 Here is my file. Note that a space after the first .Z, such as ":.Z :" 
 will cause this type of problem.

 :.Z: :  :/bin/compress -d -c %s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
 :   : :.Z:/bin/compress -c %s:T_REG:O_COMPRESS:COMPRESS
 :.gz: :  :/bin/gzip -cd %s:T_REG|T_ASCII:O_UNCOMPRESS:GUNZIP
 :   : :.gz:/bin/gzip -9 -c %s:T_REG:O_COMPRESS:GZIP
 :   : :.tar:/bin/tar -c -f - %s:T_REG|T_DIR:O_TAR:TAR
 :   : :.tar.Z:/bin/tar -c -Z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+COMPRESS
 :   : :.tgZ:/bin/tar -c -Z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+COMPRESS
 :   : :.tar.gz:/bin/tar -c -z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+GZIP
 :   : :.tgz:/bin/tar -c -z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+GZIP

---

From: JARLE MARTINSEN +41 22 730 5949 <[email-masked]>
Date: Wed, 16 Nov 1994 09:13:47 +0100 (CET)

Hi,

I have a slightly different problem with the
conversion 
functionality.  For compress and tar I get a 0
bytes file
as a result.  gzip works fine.  
This is on a DEC Alpha, OSF/1 v2.0

compress, tar and gzip resides in the same
directory (/bin)
with same protection.

-rwxr-xr-x   1 root     ties       32768 Nov 16
08:27 compress*
-rwxr-xr-x   1 root     ties      249736 Nov 16
08:39 gzip*
-rwxr-xr-x   1 root     ties      385024 Nov 16
08:40 tar*

ftp>get test.Z
200 PORT command successful.
150 Opening BINARY mode data connection for
/bin/compress.
226 Transfer complete.
..
>ls -lF test.Z
-rw-r--r--   1 jarle    ties           0 Nov 16
10:05 test.Z

ftp> get fest.tar
200 PORT command successful.
150 Opening BINARY mode data connection for
/bin/tar.
226 Transfer complete.

>ls -lF fest.tar
-rw-r--r--   1 jarle    ties           0 Nov 16
10:07 fest.tar

</usr/local/etc/ftpconversions>

 :.Z:  :  :/bin/compress -d -c
%s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
 :   : :.Z:/bin/compress -c
%s:T_REG:O_COMPRESS:COMPRESS
 :.gz: :  :/bin/gzip -cd
%s:T_REG|T_ASCII:O_UNCOMPRESS:GUNZIP
 :   : :.gz:/bin/gzip -9 -c
%s:T_REG:O_COMPRESS:GZIP
 :   : :.tar:/bin/tar -c -f -
%s:T_REG|T_DIR:O_TAR:TAR
 :   : :.tar.Z:/bin/tar -c -Z -f -
%s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+COMPRESS
 :   : :.tar.gz:/bin/tar -c -z -f -
%s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+GZIP

Any clue...?

Thanks.

Regards,
/jarle

Jarle Martinsen
International Telecomunnication Union (ITU)
Place des nations
CH-1211 Geneva 20
Switzerland

Internet: [email-masked]
X.400:    S=martinsen; P=itu; A=arcom; C=ch
Voice:    +41 22 730 5949
Fax:      +41 22 730 5337

---

From: Thomas Leavitt <[email-masked]>
Date: Wed, 16 Nov 1994 00:40:01 -0800 (PST)

> Anyone know what gives?

Sigh. I figured it out. For some inexplicable reasons, a link created
while in the /etc/msgs directory does in fact create a link to the
~ftp/etc/msgs/msg.shut file, while doing the exact same command, even
with absolute pathnames in the ln command, creates a link to itself.

Bizzare.

---

From: [email-masked] (Weyden Wedderburn)
Date: Mon, 21 Nov 1994 09:12:38 -0400 (EDT)

PLEASE UNSUBSCRIBE ME FROM THIS LIST

---

From: Charlie Fineberg <[email-masked]>
Date: Mon, 21 Nov 1994 09:03:50 -0600 (CST)

> PLEASE UNSUBSCRIBE ME FROM THIS LIST

  As your welcome message stated, you can unsubscribe from
[email-masked] by sending the command "unsub wu-ftpd" to
[email-masked].  Remember to save future welcome messages so
that you can always remove yourself from lists.
	Charlie

-- 
Charles M. Fineberg        URL: http://firesign.wustl.edu/~fineberg/index.html
Office of the Network Coordinator   email: [email-masked]
Washington University, Campus Box 1048    Phone: (314)935-4865
One Brookings Drive, St. Louis, MO 63130    Fax: (314)935-7142