Subject: [575] Re: [574] Cannot create socket...

From: Steve Maybo <[email-masked]>
Date: Tue, 25 Oct 1994 10:07:51 -0800 (PST)

> From:          Sal Collora <[email-masked]>

> 425 Can't create data socket (0.0.0.0,20): Bad file number.
>
> ftp/dev:
> total 0
> crw-r--r--   1 root     other      3, 12 Oct 17 09:28 zero

You are missing tcp socket file in your /dev.  I had the exact same 
problem on Solaris (not sure if your also on Solaris)..

Here's what I did to create "tcp" (and "zero" which is 13,12 instead of 
3,12....I'm not sure what the difference is)

root# cd ~ftp/dev
root# mknod tcp c 11 42
root# chmod 666 tcp
root# mknod zero c 13 12
root# chmod 644 zero

Good Luck,

Steve Maybo
Network Systems Analyst
RESEARCH INFORMATION SYSTEMS

---

From: "Dave Taylor." <[email-masked]>
Date: Wed, 26 Oct 1994 09:42:06 GMT+1200

> Date sent:      Tue, 25 Oct 1994 09:44:16 -0700
> Subject:        [574] Cannot create socket...
> To:             [email-masked]
> Send reply to:  [email-masked]

> Hello all,
> 
> I have finally reached the boiling point.  I am trying to configure
> 2.4 to use anonymous ftp.  I am getting the following message:
> 
> ftp> ls
> 200 PORT command successful.
> ftp> 
> I get in just fine.  I can even cd to pub.
> 
> I have ls in the ~ftp/bin directory.
> 
> Here's the tree:
> 
> lrwxrwxrwx   1 root     other         21 Oct 25 02:11 bin -> /usr/home/ftp/usr/bin/
> dr-xr-xr-x   2 root     other        512 Oct 17 09:28 dev/
> dr-xr-xr-x   2 root     other        512 Oct 25 09:20 etc/
> drwxrwxrwx   2 ftp      ftpuser      512 Oct 20 00:51 pub/
> dr-xr-xr-x   4 root     other        512 Oct 25 02:10 usr/
> 
> ftp/dev:
> total 0
> ftp/etc:
> total 4
> -rw-r--r--   1 root     other         16 Oct 25 09:20 group
> -rw-r--r--   1 root     other         54 Oct 25 09:19 passwd
> 
> ftp/pub:
> total 1216
> -rw-------   1 root     other     610720 Oct 20 00:51 root.received
> 
> ftp/usr:
> total 4
> d--x--x--x   2 root     other        512 Oct 25 09:18 bin/
> dr-xr-xr-x   2 root     other        512 Oct 25 09:04 lib/
> 
> ftp/usr/bin:
> total 208
> ---x--x--x   1 root     other      19916 Oct 25 02:10 ls*
> -r-xr-xr-x   1 root     other      85900 Oct 25 09:18 sh*
> 
> ftp/usr/lib:
> total 2398
> -r-xr-xr-x   1 root     other      24576 Oct 17 09:26 ld.so*
> -r-xr-xr-x   1 root     other     563684 Oct 17 09:26 libc.so*
> -rwxr-xr-x   1 root     other       3296 Oct 25 09:03 libdl.so*
> -rwxr-xr-x   1 root     other      12764 Oct 25 09:03 libintl.so*
> -rwxr-xr-x   1 root     other     482980 Oct 25 09:03 libnsl.so*
> -rwxr-xr-x   1 root     other      76088 Oct 25 02:09 libsocket.so*
> -rwxr-xr-x   1 root     other      33052 Oct 25 09:03 libw.so*
> -rwxr-xr-x   1 root     other       9264 Oct 25 09:04 straddr.so*
> 
> I am at the point of utter frustration..Please help..
> 
> ..Sal

The FTPD is unable to open a TCP connection to your client. It 
appears that it is attempting to open a TCP connection to an IP of 
0.0.0.0 which is not on. The FTPD has apparently not found the IP 
address of the client FTP. Your compilation of the daemon for your 
host would appear suspect.

Best Regards,

    David G Taylor  Email : [email-masked]
    Software Officer Electrotechnology Dept.
    Auckland Institute of Technology. Ph (09) 307 9999 X 8086.

"Some men see things as they are and ask why? I dream of things that 
never were and ask why not?"
                         ---- **** ----