Subject: [574] Cannot create socket...

From: Sal Collora <[email-masked]>
Date: Tue, 25 Oct 1994 09:44:16 -0700

Hello all,

I have finally reached the boiling point.  I am trying to configure
2.4 to use anonymous ftp.  I am getting the following message:

ftp> ls
200 PORT command successful.
425 Can't create data socket (0.0.0.0,20): Bad file number.
ftp> 

I get in just fine.  I can even cd to pub.

I have ls in the ~ftp/bin directory.

Here's the tree:

lrwxrwxrwx   1 root     other         21 Oct 25 02:11 bin -> /usr/home/ftp/usr/bin/
dr-xr-xr-x   2 root     other        512 Oct 17 09:28 dev/
dr-xr-xr-x   2 root     other        512 Oct 25 09:20 etc/
drwxrwxrwx   2 ftp      ftpuser      512 Oct 20 00:51 pub/
dr-xr-xr-x   4 root     other        512 Oct 25 02:10 usr/

ftp/dev:
total 0
crw-r--r--   1 root     other      3, 12 Oct 17 09:28 zero

ftp/etc:
total 4
-rw-r--r--   1 root     other         16 Oct 25 09:20 group
-rw-r--r--   1 root     other         54 Oct 25 09:19 passwd

ftp/pub:
total 1216
-rw-------   1 root     other     610720 Oct 20 00:51 root.received

ftp/usr:
total 4
d--x--x--x   2 root     other        512 Oct 25 09:18 bin/
dr-xr-xr-x   2 root     other        512 Oct 25 09:04 lib/

ftp/usr/bin:
total 208
---x--x--x   1 root     other      19916 Oct 25 02:10 ls*
-r-xr-xr-x   1 root     other      85900 Oct 25 09:18 sh*

ftp/usr/lib:
total 2398
-r-xr-xr-x   1 root     other      24576 Oct 17 09:26 ld.so*
-r-xr-xr-x   1 root     other     563684 Oct 17 09:26 libc.so*
-rwxr-xr-x   1 root     other       3296 Oct 25 09:03 libdl.so*
-rwxr-xr-x   1 root     other      12764 Oct 25 09:03 libintl.so*
-rwxr-xr-x   1 root     other     482980 Oct 25 09:03 libnsl.so*
-rwxr-xr-x   1 root     other      76088 Oct 25 02:09 libsocket.so*
-rwxr-xr-x   1 root     other      33052 Oct 25 09:03 libw.so*
-rwxr-xr-x   1 root     other       9264 Oct 25 09:04 straddr.so*

I am at the point of utter frustration..Please help..

..Sal

---

From: Ron Hall <[email-masked]>
Date: Tue, 25 Oct 1994 13:45:21 -0400 (EDT)

> 2.4 to use anonymous ftp.  I am getting the following message:

	in the dev directory do the following

	mknod tcp c 11 42

	chmod 666 tcp
	chown root tcp

	This should help.

> I am at the point of utter frustration..Please help..

       Ron Hall       | DISCLAIMER:  For Those who   | "If there is a light at
       Analyst        | thought the last disclaimer  | the end of the tunnel,
 <[email-masked]> | was too scary, then this     | then it is time to order
   +1 514 398 3718    | should be a much easier ride.| more tunnel !"

---

From: Kris Lappala <[email-masked]>
Date: Tue, 25 Oct 1994 13:42:01 -0500 (CDT)

> 425 Can't create data socket (0.0.0.0,20): Bad file number.
You need to add the device tcp in ~ftp/dev.  To do this use mknod.  Now my turn,
if you get ls -al to work for wu-ftpd running on solaris 2.3, please let me
know how you did it.

-- 
Kris Lappala
[email-masked]

---

From: Leigh Hume <[email-masked]>
Date: Wed, 26 Oct 1994 09:36:14 +1000 (EST)

>From your last message :

I gave trying to do this with the SUN 4.1.3 one, perhaps me just missing
something. I have since installed the ls from the GNU file utils instead
and it works fine, doing ls -al in the ftp dir for anon users 

-- 

Leigh HUME

Voice +61 2 850 9588	    Fax +61 2 850 9551	     Email [email-masked]
Post Mail: Dr Leigh Hume, School of MPCE, Macquarie University 2109, AUSTRALIA

---

From: Howard Chu <[email-masked]>
Date: Tue, 25 Oct 1994 18:00:32 -0700

This has got to be the most frequently asked and frequently answered question
on this mailing list. Doesn't anyone know how to read a manual? The Sun ftpd
man pages fully explain what files need to be present in the anonymous ftp
tree. On SunOS 4.xx, try "man in.ftpd"; on Solaris try "man ftpd". The SunOS
4.1.3 man page is in /usr/share/man/man8/in.ftpd.8; the Solaris page is in
/usr/share/man/man1m/ftpd.1m.

If you've read that and still can't figure it out, here are complete directory
listings for working Solaris 2.3 and SunOS 4.1.3 installs. If you still can't
get things working right, drop us a line at [email-masked], we can get this
server working properly on just about any flavor of Unix you care to use.

Solaris 2.3:

 ~ftp:
total 12
lrwxrwxrwx   1 root     other          7 Aug 14 22:27 bin -> usr/bin
drwxr-xr-x   2 root     other        512 Aug 14 22:30 dev
drwxr-xr-x   2 root     other        512 Aug 14 22:29 etc
drwxrwxrwt   2 root     other        512 Sep 11 14:23 incoming
drwxrwxrwt   6 root     other        512 Oct 25 10:27 pub
drwxr-xr-x   4 root     other        512 Aug 14 22:27 usr

./dev:
total 0
crw-r--r--   1 root     other     11, 42 Aug 14 22:30 tcp
crw-r--r--   1 root     other     11,  9 Aug 14 22:30 ticotsord
crw-r--r--   1 root     other     11, 41 Aug 14 22:30 udp
crw-r--r--   1 root     other     13, 12 Aug 14 22:30 zero

./etc:
total 12
-rw-r--r--   1 root     other         20 Aug 14 22:13 ftpd.badname
-rw-r--r--   1 root     other         50 Aug 14 22:13 ftpd.toomany
-rw-r--r--   1 root     other        111 Aug 14 22:14 ftpd.welcome
-rw-r--r--   1 root     other         13 Aug 14 22:12 group
-rw-r--r--   1 root     other        643 Aug 14 22:29 netconfig
-rw-r--r--   1 root     other         39 Aug 14 22:12 passwd

./incoming:
total 2
-rw-------   1 root     daemon      1008 Sep 11 14:08 antline.gif

./pub:
total 17328
-rw-r--r--   1 root     other        187 Aug 18 16:25 README

./usr:
total 4
drwxr-xr-x   2 root     other        512 Aug 14 22:11 bin
drwxr-xr-x   2 root     other        512 Oct 25 17:26 lib

./usr/bin:
total 1076
---x--x--x   1 root     other      14428 Aug 14 22:11 compress
---x--x--x   1 root     other      71816 Aug 14 22:10 gzip
---x--x--x   1 root     other      19916 Aug 14 22:11 ls
---x--x--x   1 root     other     433116 Aug 14 22:10 tar

./usr/lib:
total 2772
-rwxr-xr-x   1 root     other      24576 Aug 14 22:34 ld.so
-rwxr-xr-x   1 root     other      90312 Aug 14 22:34 ld.so.1
lrwxrwxrwx   1 root     other          9 Aug 14 22:34 libc.so -> libc.so.1
-rwxr-xr-x   1 root     other     563684 Aug 14 22:34 libc.so.1
lrwxrwxrwx   1 root     other         10 Aug 14 22:34 libdl.so -> libdl.so.1
-rwxr-xr-x   1 root     other       3296 Aug 14 22:34 libdl.so.1
lrwxrwxrwx   1 root     other         12 Aug 14 22:34 libintl.so -> libintl.so.1
-rwxr-xr-x   1 root     other      12764 Aug 14 22:34 libintl.so.1
lrwxrwxrwx   1 root     other         11 Aug 14 22:34 libnsl.so -> libnsl.so.1
-rwxr-xr-x   1 root     other     482980 Aug 14 22:34 libnsl.so.1
lrwxrwxrwx   1 root     other         14 Aug 14 22:34 libsocket.so -> libsocket.so.1
-rwxr-xr-x   1 root     other      76088 Aug 14 22:34 libsocket.so.1
lrwxrwxrwx   1 root     other          9 Aug 14 22:34 libw.so -> libw.so.1
-rwxr-xr-x   1 root     other      33052 Aug 14 22:34 libw.so.1
-rwxr-xr-x   1 root     other      10496 Aug 14 22:33 nss_dns.so.1
-rwxr-xr-x   1 root     other      16392 Aug 14 22:33 nss_files.so.1
-rwxr-xr-x   1 root     other      25584 Aug 14 22:33 nss_nis.so.1
-rwxr-xr-x   1 root     other      28828 Aug 14 22:33 nss_nisplus.so.1
-rwxr-xr-x   1 root     other       9264 Aug 14 22:35 straddr.so
-rwxr-xr-x   1 root     other       9264 Aug 14 22:35 straddr.so.2

SunOS 4.1.3:

 ~ftp:
total 11
drwxr-xr-x   2 root     daemon        512 Sep  9 21:24 bin
drwxr-xr-x   2 root     daemon        512 Nov 12  1993 dev
drwxr-xr-x   2 root     daemon        512 Aug 22 17:36 etc
drwxrwxrwt   2 root     daemon        512 Sep 18 17:41 incoming
drwxrwxrwt   4 root     daemon        512 Sep 20 20:43 pub
drwxr-xr-x   3 root     daemon        512 Nov 12  1993 usr

bin:
total 848
---x--x--x   1 root     daemon      24576 Nov 12  1993 compress
---x--x--x   1 root     daemon      65536 Nov 12  1993 gzip
---x--x--x   1 root     daemon      98304 Nov 12  1993 ls
---x--x--x   1 root     daemon     196608 Nov 12  1993 tar

dev:
total 0
crw-r--r--   1 root     daemon     3,  12 Nov 12  1993 zero

etc:
total 5
-r--r--r--   1 root     daemon         20 Nov 12  1993 ftpd.badname
-r--r--r--   1 root     daemon         50 Nov 12  1993 ftpd.toomany
-r--r--r--   1 root     daemon        120 May 10 23:21 ftpd.welcome
-r--r--r--   1 root     daemon        107 Aug 17 17:04 group
-r--r--r--   1 root     daemon        126 Jul  6 16:44 passwd

usr:
total 1
drwxr-xr-x   2 root     daemon        512 Nov 12  1993 lib

usr/lib:
total 592
-r-xr-xr-x   1 root     daemon      40960 Nov 12  1993 ld.so
-r-xr-xr-x   1 root     daemon     532480 Nov 12  1993 libc.so.1.9.1
-r-xr-xr-x   1 root     daemon      24576 Nov 12  1993 libdl.so.1.0

Alright, that's it. Now none of you have any excuse for asking this question
for Suns ever again. (PS - we use the ls and compress supplied by the vendor,
but add GNU tar and GNU zip.)

Howard Chu, Sr. Systems Engineer               Lloyd Internetworking
[email-masked]                               3031 Alhambra Drive
(916) 676-1147 - voice                         Suite 102
(916) 676-3442 - fax                           Cameron Park, CA  95682

---

From: [email-masked] (Winfried Magerl)
Date: Wed, 26 Oct 1994 10:43:11 +0100 (MET)

> > lrwxrwxrwx   1 root     other         21 Oct 25 02:11 bin -> /usr/home/ftp/usr/bin/

That means you have no /bin after the change root. The link should be
bin -> usr/bin, because there is no /usr/home after the change
root.

regards

	winfried

-- 
Winfried Magerl, Siemens Nixdorf AG, AP 1133
81739 Muenchen, Germany
Internet-Mail: [email-masked]

---

From: Eric C Hagberg <[email-masked]>
Date: Wed, 26 Oct 1994 06:47:36 -0400

I'm currently on jury duty, and have been since Oct 13.

-- 
+-------------------------------------------------------+
Eric Hagberg                          Phone: 212-746-4622
User Services Manager                 Fax:   212-746-8322
Office of Academic Computing      Cornell Medical College

--- This message auto-generated by a gopher-created procmail script
--- There is no need to reply.