Subject: [605] anon FTP quit working

From: "Patrick L. Nolan" <[email-masked]>
Date: Fri, 28 Oct 1994 11:09:07 -0700

I installed wu-ftpd version 2.4(1) last April on a Sun with SunOS 4.1.1.
It worked fine then.  I set up anonymous FTP and verified that it
worked.  There hasn't been much call for anonymous FTP, but recently
somebody discovered that it doesn't work any more.  As far as I can
recall, the only changes I have made might be some directory protections
and ownership.  I have been tweaking those things, with no success.
The symptoms are pretty simple.  People can log in, but they can't
do anything.  After the first command, the server shuts down.  A sample
session is shown below.  You can see that it reads the welcome.msg
OK, so things are not completely hopeless.  The failure looks much
the same if the first command is 'ls' or 'cd pub'.  Any ideas?

egret1: ftp egret0
Connected to egret0.
220 egret0 FTP server (Version wu-2.4(1) Mon Apr 18 09:58:28 PDT 1994) ready.
Name (egret0:pln): anonymous
331 Guest login ok, send your complete e-mail address as password.
Password:
230-This is the Stanford University anonymous ftp server for the EGRET project.
230-Unauthorized use prohibited.
230-
230 Guest login ok, access restrictions apply.
ftp> pwd
221-
221 Server shutting down.  Goodbye.

---

From: [email-masked]
Date: Sat, 29 Oct 1994 22:57:58 +0100 (MET)

Hello,

It seems that you don't have a /dev/zero in your ~ftp directory, I remind you
that ftp anonymous works in a chrooted environement and it needs a /dev/zero
to initialise the filesystem else the ftpd barfs.

Regards,
K. Saouli

-- 
Karim Saouli					Math Department of the
System administrator				Swiss Fed. Inst. of Tech (ETHZ)
		 				Room: HG G 14.2
S-Mail: HG G 14.2				Email: [email-masked]
	ETH Zentrum				Phone: ++41-1-632-2230
	CH-8092 Zurich				FAX  : ++41-1-632-1085