Subject: [558] Hiding dot files form Fetch users

From: [email-masked] (Anne Zanotti)
Date: Fri, 14 Oct 1994 10:25:07 +0930

Hi All,

I have set up wu-ftpd, on an IBM RS6000, AIX 3.2.4, to use the guestgroup
feature to restrict users to their home directories.  Most of the users use
Fetch from their Macs to access the IBM.

I use gnu's ls from their fileutils, compiled with static links, so that
the users can see their file lists.  Unfortunately, the users can see their
"invisible" files.  The management group for whom I administer this system
see this as a security hoe, even though the users cannot alter or remove
any of the invisible files.  The users are confused by seeing files they
didn't know existed (these are naive users who have controlled access).

My query is this:

Does anyone know how I can hide the invisible files from the Fetch users?

Thanks,

Anne

--
Anne Zanotti                    email:  [email-masked]
 Information Center, n.:
        A room staffed by professional computer people whose job it is
        to tell you why you cannot have the information you require.

---

From: [email-masked]
Date: Mon, 24 Oct 1994 14:24:23 +0100 (MET)

..Stuff deleted...
> Does anyone know how I can hide the invisible files from the Fetch users?

Hi,
there are 2 ways
1. in ~wu-ftpd/src/ftpd.c: the lines with ls_long ls_short 
   remove the -a flag!
   for example: 
   instead of:  strcpy(ls_long,"/bin/ls -lgaA");
   only :       strcpy(ls_long,"/bin/ls -lgA");
2. in ftpacess:
   You may ann a line like:
   lsshort /bin/ls -l

ok?

hope this helps.

-- 
    			          ? \!/ ?
                                   (o o)
-------------------------------oOOo-(_)-oOOo----------------------------------
1stName Name  : Slobodan Gavric     ._      Organ.:Heinrich-Heine-Universitaet
Phone (Voice) : +49 211 3113916     o<o     E-Mail :
Town :40225 Duesseldorf,Germany               [email-masked]