Subject: [500] ls works, dir doesn't

From: Graham Weeks <[email-masked]>
Date: Sat, 01 Oct 1994 01:08:21 +0000 (GMT)

Can anyone help me to understand what is hapeening here.
     
     I've just installed wu-ftpd on SunOs 4.1.1 and all appears OK, except 
     as the subject states - ls works and dir doesn't, at least not for an 
     anonymous user (its ok for a real user). This is true for both the 
     standard ls and GNU ls.
     
     My guess it has something to do with shared libraries but copying the 
     whole of /lib into ~ftp/lib didn't fix the problem.
     
     Anybody any thoughts on what is going on, or any suggestions on what I 
     should do next.
     
     Thanks,
     
     Graham Weeks
     Computervision Limited

---

From: [email-masked]
Date: Fri, 30 Sep 1994 19:15:10 -0600 (MDT)

>      whole of /lib into ~ftp/lib didn't fix the problem.

	I had the same problem up until today except mine was on Solaris, but
	I guess it would be the same fix for both. The libraries that are
	required are:
				ld.so
				libc.so.*  (notice the wildcard)

	Solaris requires 2 more files, but the Sun man page only list
	these two. The problem I had was that the Solaris manual was
	asking for a dl.so.1 file which doesn't exist. It's a misspelling,
	it's supposed to be ld.so.1.

	If you still can't get it to work, try this:

		become root
		make sure ls is in ~ftp/bin
		then do a chroot: 
			%chroot ~ftp ls
		This should tell you where the problem is with ~ftp/bin/ls.
		When I did it, it told me about a library it could not find.
		After I found the library everything worked out fine.

	I hope this helps you.

	Abel Sanchez
	asanchez.cs.unm.edu
	Competer Science Dept. University of New Mexico