Subject: [488] Re: [479] help with SVR4.2

From: [email-masked] (Chris Eakin)
Date: Wed, 28 Sep 1994 08:14:49 -0700

On Sept, 27, Steve asked:

> Has anyone built wu-2.4 for System V 4.2 (at&t's version)
> for a 386/486.  I have it built but anonymous no longer works.
> Real logins can get in and ftp, anonymous seems to login
> but when I try any command (like "ls") I get:

> 425 Can't create data socket (0.0.0.0,65535): Bad file number

While I compiled and run wu-ftpd on solaris 2.3, I had the exact same error.  What I did to cure this error was create ~ftp/dev/zero and ~ftp/dev/tcp .  Now everything works great!

(These files are tricky to create, and you may need to look up what the parameters need to be set to.)

I hope this helps!

Chris Eakin
Asst. Sys. Admin.
SAIC
10260 Campus Point Drive
San Diego, CA. 92121
[email-masked]

---

From: Moses Moore <[email-masked]>
Date: Wed, 28 Sep 1994 13:14:03 -0400 (EDT)

Aha!  Someone who admits to building wuftpd for Solaris! :)

Can you help me with the problem I posted to the mailing list a few days ago?
I may need to get different include/arpa files by the looks of it...

(quoted message follows)
> The in.ftpd that comes with Solaris [2.3] works fine, and ./ckconfig doesn't
> complain, nor were there any complaints during "./build sol" and "build
> install".

More information: now that I have gcc 2.5.8, the following error messages
pop up during support library creation:
---snip
In file included from authuser.c:7:
/usr/include/arpa/inet.h:46: warning: `struct in_addr' declared inside parameter
 list
/usr/include/arpa/inet.h:46: warning: its scope is only this definition or decla
ration,
/usr/include/arpa/inet.h:46: warning: which is probably not what you want.
/usr/include/arpa/inet.h:46: warning: parameter has incomplete type
/usr/include/arpa/inet.h:49: warning: parameter has incomplete type
/usr/include/arpa/inet.h:50: warning: parameter has incomplete type
---snip

-- 
Moses Moore: Web maintainer for LARG*net, SysAdmin for johns.largnet.uwo.ca
Here is a link to the <a href="http://www.largnet.uwo.ca/">homepage</a>.
#include <disclaim.h>; #include <witty_quote.h>; #define GIRLFRIEND "Lou"