Subject: [419] wuftpd for Solaris 2.3

From: [email-masked] (Peter Ruprecht)
Date: Tue, 06 Sep 1994 20:53:13 +0000

Hello,

When compiling wu-ftpd-2.4 for Solaris 2.3 on a Sun Sparc10, I get the following
output (from the Solaris C compiler):

# ./build sol
make args are : 
make opts are : 

Linking Makefiles.
ln: makefiles/Makefile.sol and Makefile are identical
ln: config/config.sol and config.h are identical
ln: makefiles/Makefile.sol and Makefile are identical

Making support library.
rm -f libsupport.a
ar cq libsupport.a fnmatch.o strcasestr.o strsep.o authuser.o
touch libsupport.a

Making ftpd.
cc -g -DDEBUG -I.. -I../support -L../support  -c  ftpd.c
"ftpd.c", line 512: warning: semantics of ">" change in ANSI C; use explicit cast
"ftpd.c", line 532: warning: semantics of ">" change in ANSI C; use explicit cast
"ftpd.c", line 759: warning: semantics of ">" change in ANSI C; use explicit cast
"ftpd.c", line 1972: undefined symbol: typenames
"ftpd.c", line 1972: cannot dereference non-pointer type
"ftpd.c", line 1974: undefined symbol: formnames
"ftpd.c", line 1974: cannot dereference non-pointer type
"ftpd.c", line 1982: undefined symbol: strunames
"ftpd.c", line 1982: cannot dereference non-pointer type
"ftpd.c", line 1982: undefined symbol: modenames
"ftpd.c", line 1982: cannot dereference non-pointer type
cc: acomp failed for ftpd.c
*** Error code 1
make: Fatal error: Command failed for target `ftpd.o'

.
.
.

Does anyone know what the problem with "typenames", "formnames", etc. is?
Do I need to define these somehow?

Thanks,
Peter Ruprecht

---

From: [email-masked] (Chris Eakin)
Date: Tue, 06 Sep 1994 13:59:49 +0800

You need to look at the Installation instructions...

  "If cc complains about strunaames, typenames, modenames,  ... being undefined you need to install support/ftp.h as /usr/include/arpa/ftp.h (always make a backup of the old ftp.h) and do the build again."

Chris Eakin
SAIC
San Diego, CA.  92121