Subject: [429] I cannot upload a file - permission denied.

From: [email-masked] (Howard Yeung)
Date: Fri, 09 Sep 1994 14:16:44 +0500

Hi Everyone,
 
I ftp anonymous to the ftp server I have just setup.
Everything works fine except when I try to upload a
file into the upload directory.  I have the following
message:
 
------------------------capture------------------
ftp> cd incoming
250 CWD command successful.
ftp> ls
200 PORT command successful.
550 No files found.
ftp> put .login
200 PORT command successful.
553 .login: Permission denied. (Filename (deny))
ftp>
------------------------end----------------------

I look at the permission on the directory.  It is
set to 777. Strange! 
 
lrwxrwxrwx   1 root     other          7 Apr 28 08:50 bin -> usr/bin 
dr-xr-xr-x   2 root     other        512 Apr 28 08:50 dev 
dr-xr-xr-x   2 root     other        512 Aug  5 10:43 etc 
drwxrwxrwx   2 ftp      other        512 Aug 19 09:17 incoming 
drwxr-xr-x   6 ftp      other        512 Sep  7 09:57 private 
drwxrwxrwx   2 ftp      other        512 Aug 23 10:23 pub 
dr-xr-xr-x   4 root     other        512 Apr 28 08:50 usr 
 
The following is part of my ftpaccess file. 
 
------------------------capture------------------
# specify the upload directory information
# this only applies to anonymous users, so all paths are relative to ~ftp
upload  /opt/ftp *      no
upload  /opt/ftp /bin no
upload  /opt/ftp /dev no
upload  /opt/ftp /etc no
upload  /opt/ftp /faq no
upload  /opt/ftp /lib no
upload  /opt/ftp /pub no
upload  /opt/ftp /usr no
 
upload  /opt/ftp /incoming yes ftp daemon 0644 dirs
upload  /opt/ftp /incoming yes ftp daemon 0644 dirs
upload  /opt/ftp /incoming yes ftp daemon 0644 dirs
 
------------------------end----------------------
 
Any help would be really appreciated.

Howard Yeung
Unix Admin, NCHGR/NIH
Tel: 	(301)-402-2536
Email: 	[email-masked]

---

From: Howard Chu <[email-masked]>
Date: Fri, 09 Sep 1994 12:28:04 -0700

Hi Everyone,

  ------------------------capture------------------
  ftp> cd incoming
  ------------------------end----------------------

The error message "(Filename (deny))" indicates that the filename was
rejected, not that you had a directory access problem. You are probably
using the default path-filter entry, which disallows filenames that start
with a '.' . If you had tried with any other filename, it would probably
have worked.

Just as a tip, I would set the sticky bit on the incoming (and public/
outgoing) directory (mode 1777) to prevent other users on the system
from deleting each other's files...

Howard Chu, Sr. Systems Engineer               Lloyd Internetworking
[email-masked]                               3031 Alhambra Drive
(916) 676-1147 - voice                         Suite 102
(916) 676-3442 - fax                           Cameron Park, CA  95682