Subject: [443] problems with wuftp 2.4

From: [email-masked] (Mike McBride)
Date: Tue, 13 Sep 1994 14:49:43 -0700 (PDT)

I've encountered a couple of problems and have even more questions regarding setup
of v2.4 wu-ftpd.

1) I've statically linked ls, gnutar, compress, gzip and gunzip. I've placed these
   files in the ~ftp/bin directory.  How does an ftp user execute these binaries?
   The docs mention SITE EXEC, but it doesn't really explain the operation.

   In additon, I've modified the ls command to not recognize the dot files, but
   when I log in via anonymous ftp I can see the .rhosts and .forward files.
   Seems like the ls command that is in the ~ftp/bin directory isn't being used.
   Whats going on here?

2) I've followed the directions regarding permissions on the /pub/incoming directory,
   but I would like to have the ftp user see the files when an ls is executed. 
   Is there any security risk to allow the ~ftp/pub/incoming directory to be readable?

3) Does the welcome.msg/login files need to exist in the ~ftp hierachy, or should they
   be links to other file systems?  The reason I ask is I can log into other anonymous
   ftp sites that have welcome/login announcements, but when I try to find those files
   in the ftp hierachy - I don't see them! Uhh..

Thanks in advance..

Mike McBride
[email-masked]

---

From: [email-masked] (Thomas P. Morgan)
Date: Mon, 19 Sep 1994 08:16:47 -0400

>
>
>I'm having a problem with permissions, and other related issues.
>I've installed wuftp 2.4 on sunos 4.1.3. 
>
>1) Anonymous ftp users can log into the ftp server just fine, but the real 
users
>   get permission denied. The user is not in the ftpusers file and the fpthosts
>   and ftpgroup files our empty.  Whats goin on?

I had the same problem.  After creating a /etc/shells file with the full path
of each usable shell, it worked.

My /etc/shell:

/usr/local/bin/bash
/bin/sh
/bin/csh

>[email-masked]
Thomas P. Morgan, Computer Aided Engineering Division |   ____|~~|______
Naval Sea Systems Command, Code 03R6                  |   \____________/
2531 Jefferson Davis Hwy, Arlington VA, 22242-5160    |^^^^^^^^^^^^^^^^^^^^
(703) 602-2151 Ext 208 cc:Mail: MORGAN_TOM at 05_02 CAD 2: morgan_t@soapfish