Subject: [400] access denied -

From: [email-masked]
Date: Wed, 24 Aug 1994 09:13:08 -0400 (EDT)

I recently installed the server and all works fine except for one
little problem - when a 'real' user, eg one with an account on the
server system, tries to ftp they get 'access denied'. Outside users
(anonymous users) have no problem.

I've got it installed on a Risc System 6000 running AIX 3.2.5. I have
checked and the users are not listed in /etc/ftpusers, I have a class
defined in the config file, but I figure I have done something wrong or
forgotten to do something. Any ideas or suggestions?

By the way, the system does not have a file /etc/shells. I created one,
but am not sure of the format. But I figured if this was the problem
even the anonymous users would not get in.

Thanx fer any help,

Bill Detschel
[email-masked]

---

From: [email-masked] (Colin Pinkham)
Date: Wed, 24 Aug 1994 15:32:29 +0200 (SAST)

> (anonymous users) have no problem.

I've encountered a similar problem on a sun (4.1) after installing
the shadow password system and tcpd wrappers. I assume, in my case
anyway, that has something to do with it. If anyone has come across
this before and have any pointers, I would be most grateful. BTW,
it's all been working fine for a couple of months before.

Regards,
Colin Pinkham ([email-masked])
TICSA

---

From: [email-masked]
Date: Wed, 24 Aug 1994 15:31:15 +0100 (MSZ)

Hi,

I have had a similar problem with AIX. A '/etc/shells' has solved the
problem with real user access. Here is mine:
/bin/sh
/bin/bsh
/bin/csh
/bin/ksh
/bin/tsh
/usr/bin/sh
/usr/bin/bsh
/usr/bin/csh
/usr/bin/ksh
/usr/bin/tsh
/usr/mbin/sh
/usr/mbin/bsh
/usr/mbin/csh
/usr/mbin/ksh
/usr/mbin/tsh
/usr/local/bin/bash
/usr/local/bin/tcsh

Hope this helps
  Dieter

---

From: Bill Pemberton <[email-masked]>
Date: Wed, 24 Aug 1994 11:23:39 -0400 (EDT)

> even the anonymous users would not get in.

Common problem on AIX.  The lack of /etc/shells will not inhibit anonymous
logins.  You can create an /etc/shells or you can get my patch to wu-ftpd
that makes it get the valid shells the AIX way.  My patch can be found at:

tigger.itc.virginia.edu:/pub/wu-ftpd.diffs.txt.gz

-- 
Bill Pemberton                           [email-masked]
ITC/Unix Systems                         [email-masked]
University of Virginia                   uunet!virginia!wfp5p