Subject: [379] Re: [362] FTPACCESS File

From: [email-masked] (Daniel Melnechuk)
Date: Wed, 17 Aug 1994 16:29 -0400 (EDT)

> From wunet.wustl.edu!wu-ftpd-errors Mon Aug 15 23:00:36 1994
> Date: Mon, 15 Aug 1994 19:29:45 -0700
> From: Marcel Schlapfer <[email-masked]>
> Subject: [362] FTPACCESS File
> To: [email-masked]
> Cc: [email-masked]
> Content-transfer-encoding: 7BIT
> 
> At our site, we only allow real ftp access from certain machines.  Is there a
> neat way to add machines with comments rather than having a long string of IP 
> addresses?
> 
> I would like to do something like:
> 
> class 	local	real 128.102.32. ,     # our local subnet
>  	             128.102.16. ,     # Another local subnet
> 
> and so on.
> 
> Thanks,
> Marcel

The following will work. I have a number of sites in the same class.

class 	local	real 128.102.32.       # our local subnet
class 	local	real 128.102.16.       # Another local subnet

But i think you might need '*' to pattern match the last IP address part. See
info from:

	man ftpaccess

Daniel Melnechuk                                          Intex Solutions, Inc.
Systems Administrator                                     35 Highland Circle
voice: 617-449-6222                                       Needham MA 02194
fax: 617-444-2318
[email-masked]

---

From: [email-masked] (Winfried Magerl)
Date: Thu, 18 Aug 1994 10:54:08 +0200 (MDT)

> But i think you might need '*' to pattern match the last IP address part. See

You forget, that the last machine in the subnet 128.102.16.0 has the
number 128.102.31.254 if he has a netmask of 255.255.240.0 (and I think he has).
Then the example should look like this:

class	local	real	128.102.1[6-9].* 128.102.[2-3][0-9].* 128.102.4[1-7].*

I think this should include all hosts in the two local subnets
(from 128.102.16.1 to 128.102.47.254, 128.102.47.255 and 128.102.31.255
are the broadcast adresses for the networks).
If you have a netmask 255.255.255.0 (networks 128.102.16.1|2|3|...)
then the first example is right (128.102.16.* 128.102.32.*).
Don't forget the reverse mapping of the ftpd. If any of this hosts is
found in the /etc/hosts or nis or nameservices, you got the real name
which doesn't fit in the upper examples.

I hope this helps.
Sorry for my bad english :-)

regards

	winfried

-- 
Winfried Magerl, Siemens Nixdorf AG, AP 1133
81739 Muenchen, Germany
Internet-Mail: [email-masked]