Subject: [370] spec. FTP-CLIENT

From: [email-masked]
Date: Wed, 17 Aug 1994 14:39:39 +0200

please excuse my english

I' m looking for a special ftp-client, so that I can define which port-number
do the data-process use. The reason is, that I can define an filter-list
without the need, to open ports > 1023 on my router. An other goal would be to
deny the put-command. Dont' ask me why, it's just for deny "export" some un-
public infos.

that's it

Giorgio Scherl                             UBS Network Services
                                           P.O.Box
   Tel: +41/1/236 75 22                    CH-8021 Zuerich
   Fax: +41/1/236 69 30                    Switzerland
E-mail: [email-masked] 
 X.400: /S=Giorgio/G=Scherl/OU=zh004/O=ubs/PRMD=ubs/ADMD=arcom/C=CH
   GCS: d++ -p+ c++ l+ u+ e++ m++(---) s++ h- f--@ g++ t+ r+ y(@)

---

From: Dan Thorson <[email-masked]>
Date: Wed Aug 17 08:53:34 1994

There are several ftp client codes out there.  I used the ftp client
from the TIS firewall toolkit because it was the smallest, therefore I
could find what I was looking for.
 
get the toolkit from tis.com, and look in the directory:
     fwtk/tools/client/gate-ftp
When you compile, you'll need to change a line in the Makefile.  That is, make
sure PASSTHRU is undefined.  Then hack the code so that the socket opened meets
your requirements.
 
It worked for me!
--
Dan Thorson -- [email-masked]
-------------------------------------------------------------------------
Seagate Technology   -   920 Disc Drive   -   Scotts Valley, CA 95066 USA
Main Phone 408-438-6550   -   Email Problems [email-masked]
Technical Support: BBS 408-438-8771  Fax 408-438-8137  Voice 408-438-8222  
-------------------------------------------------------------------------

### OGATE Version 8 message trace and attachment information:
### MsgFileName: m:\mgate\outbound\1446.MSG
### Org Date:    08-17-94 08:50:14 AM
### From:        Dan Thorson@SEAGATE
### To:          wu-ftpd @ wunet.wustl.edu @ INTERNET
### Subject:     Re: [370] spec. FTP-CLIENT
### Attachments: none