Subject: [401] passwd-check problem

From: "Dennis E. Miyoshi" <[email-masked]>
Date: Wed, 24 Aug 1994 07:24:11 -0600

Sorry if this is an old problem, but I have just encountered it.  The situation:
 I have installed wu-ftpd 2.4 on a Sun with SunOS 4.1.3 and have set up the
ftpaccess file with the following passwd-check line:

passwd-check rfc822 enforce

When I ftp to the site, I find that I can input my login id with an @ symbol as
the password and the system allows me in.  I thought that the password would be
required to be the userid@hostname.  Have I done something wrong?

Thanks for any help in advance.

---

From: Luis Fasano <[email-masked]>
Date: Wed, 24 Aug 1994 08:57:12 -0600 (CST)

> Thanks for any help in advance.

  Well ... as far as i know... that's a shortcut for your password entry. At my site we have the same "feature" and i know of several sites which allow this action. So i don't think that you have to worry about.  

   I think that as the servers know each other who is trying to connect to it, the guys that developed the wuftpd software tried to make life for ftp-users easier making this shortcut.

   I hope this helps

Luis