Subject: [271] Re: [270] HPUX 09.03 - Compiling!

From: [email-masked]
Date: Thu, 04 Aug 1994 17:12:38 +0200 (EET)

> 
> Hi there, 
> 
>    I'm trying to get wu-ftpd to compule on a HPUX 715/55 (I believe),
> running 09.03 or some such.  It _isn't_ working.  Two requests, choose
> one:
> 
> a) if someone knows what I'm doing, point it out, 
> 
> b) alternatively if you could uuencode and mail me your binaries, and
>         make this much easier.
> 
>    The first problem was that the standard C compiler which came with
> the machine doesn't support ANSI prototyping.  Fine - get gcc.
> Installed, blah blah blah -- no yacc.  Argh!  Fine!  Get bison.  blah
> blha blah:
> 
> # build hpx
> make args are :
> make opts are :
> 
> Linking Makefiles.
> 
> Making support library.
>         gcc -D_POSIX_SOURCE -O -DDEBUG   -c fnmatch.c
>         gcc -D_POSIX_SOURCE -O -DDEBUG   -c strcasestr.c
>         gcc -D_POSIX_SOURCE -O -DDEBUG   -c strsep.c
>         rm -f libsupport.a
>         ar cq libsupport.a fnmatch.o strcasestr.o strsep.o
>         touch libsupport.a
> 
> Making ftpd.
>         gcc -Dunix -D_HPUX_SOURCE -O -DDEBUG -I.. -I../support  -L../support -c ftpd.c
>         yacc  ftpcmd.y
>         mv y.tab.c ftpcmd.c
>         gcc -Dunix -D_HPUX_SOURCE -O -DDEBUG -I.. -I../support  -L../support -c ftpcmd.c
> ftpcmd.y: In function `yyparse':
> ftpcmd.y:371: `cmdtab' undeclared (first use this function)
> ftpcmd.y:371: (Each undeclared identifier is reported only once
> ftpcmd.y:371: for each function it appears in.)
> ftpcmd.y:383: `sitetab' undeclared (first use this function)
> ftpcmd.y:383: `sitetab' undeclared (first use this function)
> ftpcmd.y: At top level:
> ftpcmd.y:885: `cmdtab' used prior to declaration
> ftpcmd.y:936: `sitetab' used prior to declaration
> ftpcmd.y:1520: warning: type mismatch with previous external decl
> ftpcmd.y:683: warning: previous external decl of `print_groups'
> ftpcmd.y:1520: warning: type mismatch with previous implicit declaration
> ftpcmd.y:683: warning: previous implicit declaration of `print_groups'
> ftpcmd.y:1520: warning: `print_groups' was previously implicitly declared to return `int'
> *** Error code 1
> 
> Stop.
> 
> Making ftpcount.
> 
>         gcc -Dunix -D_HPUX_SOURCE -O -DDEBUG -I.. -I../support  -L../support -o ftpcount ftpcount.c vers.o -lsupport -lc -lP
> W
> gcc: vers.o: No such file or directory
> *** Error code 1
> 
> Stop.
> 
> Making ftpshut.
> [ibid]
> Stop.
> 
> Making ckconfig.
>         gcc -Dunix -D_HPUX_SOURCE -O -DDEBUG -I.. -I../support  -L../support -o ckconfig ckconfig.c
> 
> Links to executables are in bin directory:
> size:  bin/ftpd:  cannot open
> size:  bin/ftpcount:  cannot open
> size:  bin/ftpshut:  cannot open
> size:  bin/ftpwho:  cannot open
> bin/ckconfig: 5861 + 508 + 32 = 6401
> Done
> 
> Thanks a lot...
> 
>      -----------------------------------------------------------------------
> +--+ |  J. Longman Computer Systems III+ Engineering Carleton University
> |oo| |  Engineering: 4 of the hardest years of your life, or 8 of the Best!
> |  | |  Email:  [email-masked] or [email-masked]
> `^^' |  Technical Specialist For Ingenia Communications Corporation
>      -----------------------------------------------------------------------
> 
> 
 I have an HP-715/75 and I have already install wu-ftpd and works well
 If you want my binaries please send a message at the address

 "[email-masked]"

 see you

---

From: Howard Chu <[email-masked]>
Date: Thu, 04 Aug 1994 11:59:50 -0700

Hi there, 

You didn't install the ftp.h header file that's provided in the support
directory, which defines all those *tab entries that the compiler is
complaining about.

The installation notes mention that you should install the provided ftp.h
file into your /usr/include/arpa directory. They also caution that you should
check out your existing ftp.h file there to make sure you won't lose any
definitions by making this replacement. This seems like a lot of worthless
hassle to me, my personal solution is to just create an arpa directory in
the support directory, and move the ftp.h file there. Since there's a
-Isupport option on the compile commandline, this lets you grab the required
definitions without mucking with your system include files. This is such a
simple solution, I'm surprised it wasn't used in the original distribution.

Howard Chu, Sr. Systems Engineer               Lloyd Internetworking
[email-masked]                               3031 Alhambra Drive
(916) 676-1147 - voice                         Suite 102
(916) 676-3442 - fax                           Cameron Park, CA  95682