Subject: [264] Re: [263] Question about ftponly

From: [email-masked] (Patrick Salsbury)
Date: Wed, 03 Aug 1994 12:24:55 -0700 (PDT)

-Errors-To: [email-masked]
-Date: Wed, 03 Aug 1994 15:33:54 -0300
-From: Dirce Richards <[email-masked]>
-Cc: [email-masked]
-Errors-To: [email-masked]
-Reply-To: [email-masked]
-Content-Transfer-Encoding: 7BIT
-
-
-I installed wu-ftp version 2.4. I am trying to use "guestgroup".
-I would like to allow members of the guestgroup only ftp access,
-and not rlogin. I would add an entry in passwd such as:
-
-	member:<passwd>:uid:gid:Guest:/home/ftp/./member:/etc/ftponly
-
-But I don't know what the file ftponly should be like. Is it an
-script? What ownership/permissions should it have? 
-
-Thanks in advance,
-
-	Dirce
-
	I had the same question when I signed up a week ago. :)

You can use /etc/ftponly, as above. Simply add a line to /etc/shells like:
/etc/ftponly

and it should work. Or, as another user suggested to me, which I have
implemented, use /bin/false and put _that_ in your /etc/shells. Then they
won't be able to get a login, either. 

	Hope this helps!

Pat
-------------------------------------------------------------------------------
	  Patrick Salsbury 				VisionWare
Technical Support/System Administration        4500 Bohannon Dr., Suite #280
	Voice: 415/325-2113		   	   Menlo Park, CA 94025
	 FAX: 415/325-8710		     X/UNIX/PC Integration Specialists

---

From: Dirce Richards <[email-masked]>
Date: Wed, 03 Aug 1994 15:33:54 -0300

I installed wu-ftp version 2.4. I am trying to use "guestgroup".
I would like to allow members of the guestgroup only ftp access,
and not rlogin. I would add an entry in passwd such as:

	member:<passwd>:uid:gid:Guest:/home/ftp/./member:/etc/ftponly

But I don't know what the file ftponly should be like. Is it an
script? What ownership/permissions should it have? 

Thanks in advance,

	Dirce

---

From: [email-masked]
Date: Fri, 05 Aug 1994 10:53:29 +0200 (MDT)

> script? What ownership/permissions should it have? 
Hi,
how about  member:<passwd>:uid:gid:Guest:/home/ftp/./member:/bin/sh
and a ~user/.profile like this: exit
It works! 
Only FTP-access.
BTW: the ~user/.profile should not be writable by the user :-).
Bye.

-- 
    			          ? \!/ ?
                                   (o o)
-------------------------------oOOo-(_)-oOOo----------------------------------
1stName Name  : Slobodan Gavric     ._      Organ.:Heinrich-Heine-Universitaet
Phone (Voice) : +49 211 3113916     o<o     E-Mail :
Town :40225 Duesseldorf,Germany               [email-masked]