Subject: [384] Problem with real users

From: [email-masked] (Michael A Leo)
Date: Thu, 18 Aug 1994 14:53:47 -0500 (CDT)

Hi,

  I just installed Version wu-2.4(1) on our firewall machine.
The anonymous stuff works really neato, but the real users can't log in.

  This annoys the real users;-}

  The machine is an DEC MIPS Ultrix 4.3 box (RISC).

  It doesn't say "530 User root access denied..." like when you try to
log into an account in ftpusers, but it allows you to type in the password
but then just complains "530 Login incorrect."  We have tried may different
accounts and have verified this works from the old FTP.

  Please help.

Cheers,

Michael Leo
ADC Telecommunications
(612) 936-8305 (voice)
[email-masked]

---

From: [email-masked] (Michael A Leo)
Date: Thu, 18 Aug 1994 17:12:40 -0500 (CDT)

>Michael A Leo writes:
>If you have enhanced security turned on (or UPGRADE), you need to build
>the ftp daemon differently:
>
>Edit the src/config/config.ult file and define the Ultrix security code:
>
>#define ULTRIX_AUTH
>
>Edit the src/Makefile, make sure you have:
>
>LAUTH    = -lauth
>
>And make sure the "ftpd" line uses it:
>
>ftpd: ${OBJS} ${LIBC}
>      ${CC} ${CFLAGS} -o $@ ${OBJS} ${LIBES} ${LAUTH}
>
>It should work, we're using it here...
>
>--
>Bill Stapleton
>     [email-masked]
>     uwmcsd4!wls
>
>

This worked perfectly!

Michael Leo
ADC Telecommunications
(612) 936-8305 (voice)
[email-masked]