Subject: [261] why do not work??

From: [email-masked] (MMDD prototype development)
Date: Wed, 03 Aug 1994 15:03:59 +0000 (GMT)

Hi,
I have some problems during the wu-ftpd installation, can anyone help me??
In the follow there are some information about my installation:

S.O.
   SunOs 4.1.3

pathnames.h
  .
  .
  #define _PATH_FTPUSERS  "/usr4_bungle/ftpd/etc/ftpusers"
  #define _PATH_FTPACCESS "/usr4_bungle/ftpd/usr/local/etc/ftpaccess"
  #define _PATH_EXECPATH  "/bin/ftp-exec"
  #define _PATH_PIDNAMES  "/usr4_bungle/ftpd/usr/local/daemon/ftpd/ftp.pids-%s"
  #define _PATH_CVT       "/usr4_bungle/ftpd/usr/local/etc/ftpconversions"
  #define _PATH_XFERLOG   "/usr4_bungle/ftpd/usr/adm/xferlog"
  #define _PATH_PRIVATE   "/usr4_bungle/ftpd/etc/ftpgroups"

  #ifndef _PATH_UTMP
  #define _PATH_UTMP      "/usr4_bungle/ftpd/etc/utmp"
  #define _PATH_WTMP      "/usr4_bungle/ftpd/usr/adm/wtmp"
  #define _PATH_LASTLOG   "/usr4_bungle/ftpd/usr/adm/lastlog"
  .
  .

inetd.conf
  .
  .
  ftp	stream	tcp	nowait	root	/usr4_bungle/ftpd/etc/ftpd
  .
  .

ftpusers
  root
  daemon
  guest
  anonymous

ftpaccess
  class   all   real,guest,anonymous  *

  limit   all   10   Any              /msgs/msg.toomany

  readme  README*    login
  readme  README*    cwd=*

  message /welcome.msg            login
  message .message                cwd=*

  compress        yes             local remote
  tar             yes             local remote

  log commands real
  log transfers anonymous,real inbound,outbound

  shutdown /etc/shutmsg

  email user@hostname

ftpgroups
  test:ENCRYPTED PASSWORD HERE:archive

ftpconversions
   :.Z:  :  :/bin/compress -d -c %s:T_REG|T_ASCII:O_UNCOMPRESS:UNCOMPRESS
   :   : :.Z:/bin/compress -c %s:T_REG:O_COMPRESS:COMPRESS
   :.gz: :  :/bin/gzip -cd %s:T_REG|T_ASCII:O_UNCOMPRESS:GUNZIP
   :   : :.gz:/bin/gzip -9 -c %s:T_REG:O_COMPRESS:GZIP
   :   : :.tar:/bin/tar -c -f - %s:T_REG|T_DIR:O_TAR:TAR
   :   : :.tar.Z:/bin/tar -c -Z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+COMPRESS
   :   : :.tar.gz:/bin/tar -c -z -f - %s:T_REG|T_DIR:O_COMPRESS|O_TAR:TAR+GZIP

ftphosts
  # Example host access file
  #
  # Everything after a '#' is treated as comment,
  # empty lines are ignored

      allow   tracy   tracy.esrin.esa.it
      deny    fred    otherhost.domain 131.211.32.*

  N.B I am trying from tracy.esrin.esa.it 

running:
  from tracy (the client)
    [mmddprot@tracy](/homep/mmddprot) ftp snoopy
    Connected to snoopy.
    220 
    Name (snoopy:mmddprot): guest
    421 Service not available, remote server has closed connection
    Login failed.
    ftp> 

  in the console of snoopy (where the ftpd is installed)
    Aug  3 14:41:01 snoopy ftpd[402]: exiting on signal 11

build install is done correctly during the installation and ckconfig give
this information:
  Checking _PATH_FTPUSERS :: /usr4_bungle/ftpd/etc/ftpusers
  ok.

  Checking _PATH_FTPACCESS :: /usr4_bungle/ftpd/usr/local/etc/ftpaccess
  ok.

  Checking _PATH_PIDNAMES :: /usr4_bungle/ftpd/usr/local/daemon/ftpd/ftp.pids-%s
  ok.

  Checking _PATH_CVT :: /usr4_bungle/ftpd/usr/local/etc/ftpconversions
  ok.

  Checking _PATH_XFERLOG :: /usr4_bungle/ftpd/usr/adm/xferlog
  I can't find it... 
  Don't worry, it will be created automatically by the
  server if you do transfer logging.

  Checking _PATH_PRIVATE :: /usr4_bungle/ftpd/etc/ftpgroups
  ok.

  Checking _PATH_FTPHOSTS :: /usr4_bungle/ftpd/usr/local/etc/ftphosts
  ok.

Any help will be greatly appreciated...

Thanx you.

Madotto Paolino (*madx)
e-mail : [email-masked]

---

From: [email-masked]
Date: Wed, 03 Aug 1994 12:47:00 -0400

/etc/ftpusers is a list of users who are to be DENIED access
                                               ======
You have
ftpusers
  root
  daemon
  guest             <------ deny access to guest
  anonymous

have a look at the man page ...

  Ftpd authenticates users according to four rules.

  1)   The user name must be in the password data base, /etc/passwd, and
       not have a null password.  In this case a password must be provided
       by the client before any file operations may be performed.

  2)   The user name must not appear in the file /etc/ftpusers.

  3)   The user must have a standard shell returned by getusershell(3).

  4)   If the user name is ``anonymous'' or ``ftp'', an anonymous ftp
       account must be present in the password file (user ``ftp'').  In
       this case the user is allowed to log in by specifying any password
       (by convention this is given as the client host's name).