Subject: [351] dir problems

From: Denise Tjong <[email-masked]>
Date: Fri, 12 Aug 1994 12:15:52 -0400

Hi,

I've installed wu-ftpd 2.4 on Sunos4.1.3 and Sunos4.1.1. The problems
that I am getting is with dir and ls -l as anonymous. It seems to work with
real users, but not with anonymous.

Any help on this would be appreciated.

Thanks in advance.

[email-masked]

---

From: [email-masked] (Chris Eakin)
Date: Fri, 12 Aug 1994 09:43:25 +0800

> real users, but not with anonymous.

Denise, I just installed wu-ftpd on SunOS 5.3 (Solaris 2) and I had a very similar problem.  real users could use ls, but anonymous users coulnd't. (I would get a data socket error)

The solution to my problem was the fact that real users use the normal system ls.  Whereas anonymous users used the ls in the ~ftp/bin directory.  Anonymous users then must have there own /dev/tcp and /dev/zero files also in the ~ftp hierarchy.

But since you don't need ~ftp/dev/tcp & ~/ftp/ftp/zero, this is not your solution.  I just wanted to show you the two types of users (anonymous & real) use different ls and/or different system files.

Hope this helps in any way!

Chris Eakin
Assistant Sys. Admin.
SAIC
San Diego, CA. 92121