Subject: [267] Re: [262] Re: [261] why do not work??

From: [email-masked] (Winfried Magerl)
Date: Thu, 04 Aug 1994 13:06:47 +0200 (MDT)

> /etc/ftpusers is a list of users who are to be DENIED access
>                                                ======
> You have
> ftpusers
>   root
>   daemon
>   guest             <------ deny access to guest
>   anonymous

But thats not the reason for the segmentation violation (signal 11).

regards

	winfried

-- 
Winfried Magerl, Siemens Nixdorf AG, AP 1133
81739 Muenchen, Germany
Internet-Mail: [email-masked]

---

From: [email-masked] (Greg Woods)
Date: Mon, 08 Aug 1994 09:47:13 -0600 (MDT)

> how about  member:<passwd>:uid:gid:Guest:/home/ftp/./member:/bin/sh
> and a ~user/.profile like this: exit
> It works! 
> Only FTP-access.
> BTW: the ~user/.profile should not be writable by the user :-).

This is not as safe as having a separate shell that does nothing but exit
that is in /etc/shells. Many shells can be interrupted while reading from
.profile, which would allow the user to obtain an interactive shell.

--Greg