Subject: [395] Anonymous "ls" problem

From: [email-masked] (Ralph J. Folz)
Date: Tue, 23 Aug 1994 11:54:56 -0400

Hi,

   I am running wu-ftp version 2.4 on a Sun Sparc
running SunOS 4.1.2.  I have set up an anonymous
ftp account and area.  Everything is working fine
except for one thing:

   -- when I ftp into the SUN as "anonymous", and
      do an "ls -l" command I get:

ftp> ls -ltr
200 PORT command successful.
150 Opening ASCII mode data connection for /bin/ls.
226 Transfer complete.
ftp> 

Nothing shows up.  When I do a normal "ls" everything is
OK:

ftp> ls
200 PORT command successful.
150 Opening ASCII mode data connection for file list.
bin
etc
pub
dev
usr
226 Transfer complete.
25 bytes received in 0.002 seconds (12 Kbytes/s)
ftp> 

This does not happen when I use accounts which are not
anonymous.  The "ls -l" works fine.  

Any ideas ??

=========================================
Ralph J. Folz
Boston University
Multimedia Communications Laboratory
[email-masked]
=========================================

---

From: "Alec H. Peterson" <[email-masked]>
Date: Tue, 23 Aug 1994 12:50:11 -0400 (EDT)

>      do an "ls -l" command I get:

Hmmmm, do you have a statically linked version of ls in ~ftp/bin?  If yes,
what ls is it?  I'd recommend using GNU ls.

Alec

-- 
Alec Peterson                           Panix Public Access UNIX and Internet
[email-masked]                       New York City, NY