Subject: [211] Re: [205] Setup a wellcome page for anonymous ftp account

From: [email-masked] (Howard Yeung)
Date: Wed, 27 Jul 1994 15:44:15 +0500

Hi everyone,

Thanks for your response.
I make a change to the ftpaccess file and copy the login.msg file to
/opt/ftp firectory.  However, the wellcome page still DOESN'T come
up during an anonymous ftp.

-------------my ftpaccess file------
message /login.msg                      LOGIN   anonymous        
message /opt/local/etc/login.msg       LOGIN    all      
message .message                        cwd=*
 
Any further hints?

Howard Yeung
UNIX Admin, NCHGR
------------message from Brad------------------
> From [email-masked] Wed Jul 27 12:13 EDT 1994
> From: Brad Burdick <[email-masked]>
> Subject: Re: [205] Setup a wellcome page for anonymous ftp account
> To: [email-masked]
> Date: Wed, 27 Jul 1994 12:16:20 -0400 (EDT)
> Mime-Version: 1.0
> Content-Transfer-Encoding: 7bit
> 
> > 
> > Hi, all!
> > 	I just finished configuring and installing wu-ftpd.  It is
> > running fine now.  However, I still have a question...
> > 
> > 	I edit the ftpaccess file and specify a wellcome for all ftp
> > users.  The wellcome page works fine for real account.  It doesn't
> > work for anonymous ftp users.  I double check the ftpaccess to make
> > sure that it has no error.  But the wellcome page for anonymous ftp
> > users just doesn't come up!
> 
> ftpd does a chroot for anonymous users, so the welcome page needs to exist
> under the ~ftp/ tree to be accessed.
> 
> -brad
> -- 
> Brad Burdick                                            [email-masked]
> UUcom/Internet Multicasting Service, NBP, Suite 1155, Washington, DC 20045

---

From: Geffers <[email-masked]>
Date: Fri, 29 Jul 1994 09:27:58 +0100 (MESZ)

Hilo!
> users just doesn't come up!
  ...
> 
> Any help will be appreciated!
> 
> Howard Yeung
> UNIX Admin, NCHGR/NIH
> 
> 

 Look into the ftpacces file and take banner item to the location of
 a banner page.
 Both real and anonymous will see it.
 To use the message item you have to know that ftpd makes a chroot
 for anonymous users and it can't look to the orign root directory.
 Try:

 message /opt/ftp/.../welcome.msg

 and have an symbolik link in /opt/ftp: ln -s . /opt/ftp

 Mit freundlichen Gruessen

 Ralf Geffers

#===================================================================#
# Ralf Geffers  Rechenzentrum        tel   0531-391-5541            #
#               TU Braunschweig      fax   0531-391-5549            #
# Gruppe        D-38092 Braunschweig email [email-masked]       #
# Anwendungen   Germany                                             #
#===================================================================#