Subject: [79] Lockout times not working!

From: Shane M Zatezalo <[email-masked]>
Date: Fri, 01 Jul 1994 12:43:34 -0400 (EDT)

I'm using wu-2.4, and am trying to lockout ALL
remote anonymous ftp logins from the hours of 9-4, m-f.

Here's my ftpaccess file. Please take a look at this, because it isn't 
working! (we're using a NeXT 3.0 '040 slab, if that matters. everything
else works a-ok!)

loginfails 2

class   local   real,guest,anonymous *.domain 0.0.0.0
class   remote  real,guest,anonymous *

limit   remote  0   Wk1600-0900         /etc/msgs/msg.hours
limit   local   2   Any                 /etc/msgs/msg.toomany
limit   remote  5   Any                 /etc/msgs/msg.toomany

#readme  README*    login
#readme  README*    cwd=*

message /etc/msgs/welcome.msg   LOGIN
message /etc/msgs/logoff.msg    LOGOFF
#message /welcome.msg            login
#message .message                cwd=*

compress        yes             local remote
tar             yes             local remote

# allow use of private file for SITE GROUP and SITE GPASS?
private         yes

# passwd-check  <none|trivial|rfc822>  [<enforce|warn>]
passwd-check    rfc822  warn

log commands real
log transfers anonymous,real inbound,outbound
shutdown /etc/shutmsg

# all the following default to "yes" for everybody
delete          no      guest,anonymous         # delete permission?
overwrite       no      guest,anonymous         # overwrite permission?
rename                  no              guest,anonymous                 # rename permission?
chmod           no      anonymous               # chmod permission?
umask           no      anonymous               # umask permission?

# specify the upload directory information
upload  /var/ftp  *             no
upload  /var/ftp  /incoming     yes     root    daemon  0600 dirs
upload  /var/ftp  /bin          no
upload  /var/ftp  /etc          no

# directory aliases...  [note, the ":" is not required]
alias   inc:    /incoming
alias   metal:  /pub/metal
alias   fv:     /pub/fv

# cdpath
cdpath  /incoming
cdpath  /pub
cdpath  /

# path-filter...
path-filter  anonymous  /etc/pathmsg  ^[-A-Za-z0-9_\.]*$  ^\.  ^-
path-filter  guest      /etc/pathmsg  ^[-A-Za-z0-9_\.]*$  ^\.  ^-

# specify which group of users will be treated as "guests".
guestgroup ftponly

email [email-masked]

--

---

From: [email-masked] (Daniel Melnechuk)
Date: Fri, 01 Jul 1994 13:49 -0400 (EDT)

> From: Shane M Zatezalo <[email-masked]>
>

I think all you have to do is reverse the hours setting for your first limit
line to:

limit   remote  0   Wk0900-1600         /etc/msgs/msg.hours

Daniel Melnechuk
Intex Solutions, Inc.
617-449-6222
[email-masked]