Subject: [197] Re: [196] Re: [195] loopback file system ?

From: [email-masked] (David Datta)
Date: Tue, 26 Jul 1994 11:06:18 -0500

} > I would appreciate to know what is a loopback file system.

} Hi , I guess you can try to export the directory you want to
} link somewhere under the chroot dir.
} Then use NFS to mount it locally!

This is horrible on system load if the NFS mounted area is used much....

--

---

From: [email-masked] (Operators account)
Date: Tue, 26 Jul 1994 12:33:53 +0500

----- Begin Included Message -----

>From [email-masked] Tue Jul 26 11:07 EDT 1994
Date: Tue, 26 Jul 1994 22:56:11 +0800 (CST)
From: [email-masked] (CQ CQ de Jason)
Subject: [196] Re: [195] loopback file system ?
To: [email-masked]
Mime-Version: 1.0
Content-Transfer-Encoding: QUOTED-PRINTABLE

>
> > >>Is there something special I must do to allow users to cd to a
> > >> symbolic link to a directory?
>
> > Use a loopback file system.
> >
> > Don Cheesman
>
> Don,
> I would appreciate to know what is a loopback file system.
> Thanks in advance.

 ----- End Included Message -----

 No, not NFS. A loopback file system is a virtual file system.
 The following is from the man page on mount:    
    
     Loopback file systems provide access to existing files using 
     alternate pathnames.  Once a virtual file  system  is  created,
     other file systems can be mounted within it without affecting
     the original file system.

 An example:
 mount -t lo -o ro /real/files /anon/ftp/files
 To check your mount: mount -p
 Then put the new info from mount -p into your /etc/fstab.

Don Cheesman
Systems Administrator
National Wetlands Inventory