Subject: [77] Re: [70] ftpd 2.4 problems

From: Jeff Blaine <[email-masked]>
Date: Fri, 01 Jul 1994 10:13:57 -0400

>You have to specify that compressed and tar files can be transferred in the
>ftp access file. The format is as shown below.
>
>compress        yes             local remote
>tar             yes             local remote
>

I already have those lines in the ftpaccess file, so that's not it :(

---

From: [email-masked] (Swarna Chigullapalli)
Date: Fri, 01 Jul 1994 10:03:00 -0500 (EDT)

> 
> 
> SPARCstation IPX running SunOS 4.1.3 3
> 
> 1. wu-ftpd 2.4 retrieved Tuesday, June 28
> 2. modified src/pathnames.h per INSTALL text file
> 3. ./build s41
> 4. compiled and built fine
> 5. make install
> 6. installed fine
> 
> looked in src/ftpd.c and found int mangleopts = 0;
> 
> ftp> get foo.Z
> [ no such file OR directory ]
> 
> changed it to = 1;
> recompiled/reinstalled
> 
> ftp> get foo.Z
> [ file transfers but is zero length on the local end ]
> 
> The ftp chroot area is /var/ftp:
> dr-xr-xr-x  2 root          512 Jun  8 10:16 bin/
> dr--r--r--  2 root          512 May  5 19:54 dev/
> drwxr-xr-x  3 root          512 Jun 28 15:35 pub/
> dr-xr-xr-x  3 root          512 May  5 19:54 usr/
> 
> The binary area (~ftp/bin):
> -rwxr-xr-x  1 root        24576 May  5 19:40 compress*
> -rwxr-xr-x  1 root        81920 May  5 19:40 gzip*
> -rwxr-xr-x  1 root       155648 Jun  3 13:50 ls*
> 
> The library area (~ftp/usr/lib):
> -r-xr-xr-x  1 root        40960 May  5 19:53 ld.so*
> -rwxr-xr-x  1 root       548864 Jun  7 10:35 libc.so.1.8.2*
> -rwxr-xr-x  1 root        24576 Jun  7 10:35 libdl.so.1.0*
> 
> The device area (~ftp/dev):
> crw-r--r--  1 root       3,  12 May  5 19:54 zero
> 
> Can anyone help?
> If I have provided insufficient setup information, please tell me what
> else you need to know if you can help.
> 

Hope it helps.
Swarna