Subject: [139] Re: your mail

From: [email-masked]
Date: Wed, 06 Jul 1994 09:30:13 -0700

Perhaps you folks can help me out with an
almost complete installation on an rs6000
runing aix 3.2.4.

I've set up an anonymous ftp site, and the
anonymous part works fine.  The problem is
that regular users who attempt to ftp to
this site, using their regular login id's,
are told: "530 User salasin access denied...
Login failed."

If you try to log in with a complete domain
name ([email-masked]) it prompts for a password,
and then tells you your login was invalid.

I suspect this may have something to do with
the shadowed password setup of aix.   Has anyone
set up an ftp site and encountered similar 
problems?  The anonymous part works fine, it's
just the regular logins who are having problems.

Thanks much in advance to all of you who reply.
I'm subscribed to this listserv, but if you'd
like to save bandwidth (I think there's a solution
at hand, although I sure can't find it) you could
email me directly at [email-masked].

Robert Salasin
[email-masked]

---

From: Bill Pemberton <[email-masked]>
Date: Wed, 06 Jul 1994 12:51:00 -0400 (EDT)

> almost complete installation on an rs6000

The problem is that wu-ftpd doesn't know how to get the valid shells for
AIX.  You can either create an /etc/shells (this is the easy way, but I HATE
this since only wu-ftpd will care), or I've got a patch that will make
wu-ftpd get the valid shell the AIX way.

My patch should be in the archives for the list.  If you can't find it, let
me know and I can send it to you.

-- 
Bill Pemberton                           [email-masked]
ITC/Unix Systems                         [email-masked]
University of Virginia                   uunet!virginia!wfp5p

---

From: [email-masked] (Rob Parry)
Date: Wed, 6 Jul 1994 13:12:23 +22294909 (EDT)

I had a similar problem when I installed wu-ftpd. The problem is that
ftpd is looking for a file /etc/shells listing valid login shells.
Since you don't have one (by default - all valid logins are stored in
/etc/security/login.cfg) there are _no_ valid shells. Here is the
contents of the etc/shells I created:

# valid shells for login. Used only by wu-ftpd
/bin/sh
/usr/bin/sh
/bin/ksh
/usr/bin/ksh
/bin/csh
/usr/bin/csh

There is also a fix availble for the source code. I'll bounce it to
you.

Good luck!

 -- Rob

     +-----------------------------------------------------------------+
     |   Rob Parry                       [email-masked]   |
     |   USDA-ARS-Hydrology Lab          Voice: (301) 504-8625         |
     |   Beltsville, MD  USA             Fax:   (301) 504-8931         |
     +-----------------------------------------------------------------+