Subject: [65] ftp connections for "normal" users

From: Tom Wright <[email-masked]>
Date: Tue, 28 Jun 1994 10:50:54 -0700

I was able to st up and use wu-ftp yesterday as an anonymous user. However,
when I try to connect as myself, I get access denied. Any ideas? I assume
it's the ftpaccess file. Mine looks like this:

class   local   real,guest,anonymous *.ov.com 0.0.0.0
class   remote  real,guest,anonymous *

limit   local   20  Any                 /etc/msgs/msg.toomany
limit   remote  20  Any                 /etc/msgs/msg.toomany

readme  README*    login
readme  README*    cwd=*

message /welcome.msg            login
message .message                cwd=*

compress        yes             local remote
tar             yes             local remote

# passwd-check  <none|trivial|rfc822>  [<enforce|warn>]
passwd-check    rfc822  enforce

log commands real
log transfers anonymous,real inbound,outbound
shutdown /etc/shutmsg

# all the following default to "yes" for everybody
delete          no      guest,anonymous         # delete permission?
overwrite       no      guest,anonymous         # overwrite permission?
rename                  no              guest,anonymous                 # rename permission?
chmod           no      anonymous               # chmod permission?
umask           no      anonymous               # umask permission?

# specify the upload directory information
upload  /var/ftp  *             no
upload  /var/ftp  /incoming     yes     root    daemon  0600 dirs
upload  /var/ftp  /bin          no
upload  /var/ftp  /etc          no

# cdpath
cdpath  /incoming
cdpath  /pub
cdpath  /

# path-filter...
path-filter  anonymous  /etc/pathmsg  ^[-A-Za-z0-9_\.]*$  ^\.  ^-
path-filter  guest      /etc/pathmsg  ^[-A-Za-z0-9_\.]*$  ^\.  ^-

  Do I need to add our network IP address after the *.ov.com??

Thanks a lot,

Tom Wright
[email-masked]

---

From: "H.-Juergen Godau" <[email-masked]>
Date: Wed, 29 Jun 1994 09:47:55 +0100 (MET)

> when I try to connect as myself, I get access denied. Any ideas? I assume

I had the same problem after installing wu-ftpd. In our case it was a
problem related to the /etc/shells file:
I use tcsh, which was twice to be found in the path! In passwd i had the
entry /usr/local/bin/tcsh, but in the /etc/shells file it was
/bin/tcsh and so wu-ftpd refused the commection (as warned in the doc's)

Hope this helps,
Juergen
---------+=====================================================+
WW  W  W | [email-masked]                      |
WW W  W  | Wirtschaftsinformatik der Produktionsgesellschaften |
WWWWWW   | an der Universitaet Gesamhochschule Essen           |
WW WW    | Hans-Juergen Godau                                  |
W  W ----+=====================================================+