Subject: [59] Welcome to WU-FTPD

From: Tom Wright <[email-masked]>
Date: Mon, 27 Jun 1994 14:02:09 -0700

Hi,

  I am having problems compiling ftpd on a SunOS 4.1.3 machine. Here
is what the command build s41 produces:

froggy-root# build s41
make args are : 
make opts are : 
 
Linking Makefiles.
ln: Makefile: File exists
ln: config.h: File exists
ln: Makefile: File exists

Making support library.
rm -f libsupport.a
ar cq libsupport.a fnmatch.o strcasestr.o strerror.o strsep.o authuser.o syslog.o
ranlib libsupport.a

Making ftpd.
gcc -g -DDEBUG -I.. -I../support -L../support  -target sun4 -c  ftpd.c
ftpd.c: In function `statcmd':
ftpd.c:1972: `typenames' undeclared (first use this function)
ftpd.c:1972: (Each undeclared identifier is reported only once
ftpd.c:1972: for each function it appears in.)
ftpd.c:1974: `formnames' undeclared (first use this function)
ftpd.c:1982: `strunames' undeclared (first use this function)
ftpd.c:1982: `modenames' undeclared (first use this function)
*** Error code 1 
make: Fatal error: Command failed for target `ftpd.o'

Making ftpcount.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpcount ftpcount.c vers.o -lsupport
gcc: vers.o: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `ftpcount'

Making ftpshut.
gcc -g -DDEBUG -I.. -I../support -L../support -o ftpshut ftpshut.c vers.o -lsupport
gcc: vers.o: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `ftpshut'

Making ckconfig.
`ckconfig' is up to date.
ln: ckconfig: File exists
 
Links to executables are in bin directory:
size: bin/ftpd not found
size: bin/ftpcount not found
size: bin/ftpshut not found
size: bin/ftpwho not found
text    data    bss     dec     hex
8192    8192    0       16384   4000    bin/ckconfig
Done

Any help is greatly appreciated!!

Tom Wright
[email-masked]

---

From: Art Freeman <[email-masked]>
Date: Mon, 27 Jun 1994 17:59:47 -0400

You must copy the file ftpd.h to /usr/include/arpa .  There is a short
discussion of this in the installation file.

Art Freeman

Department of Mathematics
The Pennsylvania State University
University Park, PA 16802
<[email-masked]> <[email-masked]>