Subject: RE: c-client is working! Thanks for the help! One more thing...

From: kmm <[email-masked]>
Date: Thu, 30 Apr 1998 16:59:53 -0400

Mark, thanks for the reply.

The hostlist is "mailhost" and "localhost".

I don't want to hard-code the name of the server that I happen to be
connecting to at this time.

Does it do the equivalent of looking for an entry in the hosts file
named 'mailhost' to get the IP address?  (i.e. create an alias for my
mail server and call it 'mailhost'?)
I can't find a hosts file, but I did find a \windows\hosts.sam.  Is this
the equivalent of the /etc/hosts file in UNIX?

Thanks for your time,

Kevin McFall

> -----Original Message-----
> From:	Mark Crispin [SMTP:[email-masked]]
> Sent:	Thursday, April 30, 1998 3:51 PM
> To:	kmm
> Cc:	[email-masked]
> Subject:	re: c-client is working!  Thanks for the help!  One more
> thing...
> 
> On Thu, 30 Apr 1998 15:42:58 -0400, kmm wrote:
> > After composing the message and sending, I get the following
> message:
> > ?Host not found (#11002):mailhost
> > ?Can't connect to igpc17.localdomain.com,25 Refused (10061)  Can't
> open
> > connection to any server.
> 
> What are you giving as the "hostlist" argument to smtp_open?  That is
> what
> specifies the SMTP server to connect to.

---

From: Mark Crispin <[email-masked]>
Date: Thu, 30 Apr 1998 14:05:13 -0700 (PDT)

> The hostlist is "mailhost" and "localhost".

Well, that's your problem.

> connecting to at this time.

What you have is a hard-coded list of "mailhost" and "localhost" as the SMTP
servers to contact.

What you need to do is to have the name of the desired SMTP server as a user
preference in your application, and set up hostlist to include that name.

> mail server and call it 'mailhost'?)

Many sites set up "mailhost" in their domain as a catch-all SMTP server.  But
you shouldn't rely upon that, except as an last-chance default.