Subject: RE: [Imap-uw] IMAP With SSHA

From: "Urciolo, Kevin" <[email-masked]>
Date: Thu, 21 Jul 2005 14:46:54 -0400

Howdy, that you help.

I tried this yesterday actually.  However, I am still having problems.
I am not sure what is going on at the moment.  I am not getting debug
from pam in the logs showing that it is being hit.  The screen shots
show the error from the client and the client configuration.

The syslog does show this:
Jul 21 18:37:58 ******** imapd[10501]: [ID 806292 mail.debug] imap
service init from ***.***.***.***
Jul 21 18:38:02 ******** imapd[10501]: [ID 985434 mail.info] Command
stream end of file, while reading line user=******** host=*******
[***.***.***.***]

The FAQ suggests this is just the client disconnecting improperly.

Here is the compiler output:

# make clean
Removing old processed sources and binaries...
sh -c 'rm -rf an ua OSTYPE SPECIALS c-client mtest imapd ipopd mailutil
mlock dmail tmail || true'
cd tools;make clean
sh -c 'rm -f *.o uahelper || true'
# make gso PASSWDTYPE=pmb
make sslnopwd
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ Building in full compliance with RFC 3501 security
+ requirements:
++ TLS/SSL encryption is supported
++ Unencrypted plaintext passwords are prohibited
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Applying an process to sources...
tools/an "ln -s" src/c-client c-client
tools/an "ln -s" src/ansilib c-client
tools/an "ln -s" src/charset c-client
tools/an "ln -s" src/osdep/unix c-client
tools/an "ln -s" src/mtest mtest
tools/an "ln -s" src/ipopd ipopd
tools/an "ln -s" src/imapd imapd
tools/an "ln -s" src/mailutil mailutil
tools/an "ln -s" src/mlock mlock
tools/an "ln -s" src/dmail dmail
tools/an "ln -s" src/tmail tmail
ln -s tools/an .
make build EXTRACFLAGS='' EXTRALDFLAGS='' EXTRADRIVERS='mbox'
EXTRAAUTHENTICATORS='' PASSWDTYPE=pmb SS
LTYPE=nopwd IP=4 EXTRASPECIALS='' BUILDTYPE=gso
Building c-client for gso...
echo `cat SPECIALS`  > c-client/SPECIALS
cd c-client;make gso EXTRACFLAGS=''\
 EXTRALDFLAGS=''\
 EXTRADRIVERS='mbox'\
 EXTRAAUTHENTICATORS=''\
 PASSWDTYPE=pmb SSLTYPE=nopwd IP=4\
  
sh -c '(strings /lib/libc.a | grep getpassphrase > /dev/null) && ln -s
os_soln.h os_sol.h || ln -s os_
solo.h os_sol.h'
make build EXTRACFLAGS='' EXTRALDFLAGS='' EXTRADRIVERS='mbox'
EXTRAAUTHENTICATORS='' PASSWDTYPE=pmb SS
LTYPE=nopwd `cat SPECIALS` OS=sol \
 SIGTYPE=psx CHECKPW=psx CRXTYPE=nfs \
 SPOOLDIR=/var/spool MAILSPOOL=/var/mail \
 ACTIVEFILE=/usr/share/news/active \
 RSHPATH=/usr/bin/rsh \
 BASECFLAGS="-g -O2" \
 BASELDFLAGS="-lsocket -lnsl -lgen" \
 RANLIB=true CC=gcc
sh -c 'rm -rf auths.c crexcl.c nfstest.c linkage.[ch] siglocal.c
osdep*.[ch] *.o ARCHIVE *FLAGS *TYPE 
c-client.a || true'
Once-only environment setup...
echo gcc > CCTYPE
echo -g -O2 '' > CFLAGS
echo -DCREATEPROTO=unixproto -DEMPTYPROTO=unixproto \
 -DMAILSPOOL=\"/var/mail\" \
 -DANONYMOUSHOME=\"/var/mail/anonymous\" \
 -DACTIVEFILE=\"/usr/share/news/active\" -DNEWSSPOOL=\"/var/spool/news\"
\
 -DRSHPATH=\"/usr/bin/rsh\" -DLOCKPGM=\"/etc/mlock\" > OSCFLAGS
echo -lsocket -lnsl -lgen  > LDFLAGS
echo "ar rc c-client.a osdep.o mail.o misc.o newsrc.o smanager.o utf8.o
siglocal.o  dummy.o pseudo.o n
etmsg.o flstring.o fdstring.o  rfc822.o nntp.o smtp.o imap4r1.o pop3.o
unix.o mbx.o mmdf.o tenex.o mt
x.o news.o phile.o mh.o mx.o;true c-client.a" > ARCHIVE
echo sol > OSTYPE
./drivers mbox imap nntp pop3 mh mx mbx tenex mtx mmdf unix news phile
dummy
./mkauths  md5 pla log
echo -DMD5ENABLE=\"/etc/cram-md5.pwd\" >> OSCFLAGS
ln -s os_sol.h osdep.h
ln -s os_sol.c osdepbas.c
ln -s log_std.c osdeplog.c
ln -s sig_psx.c siglocal.c
ln -s crx_nfs.c crexcl.c
ln -s ip4_unix.c ip_unix.c
sh -c '(test -f /usr/include/sys/statvfs.h -a sol != sc5 -a sol != sco)
&& ln -s nfstnew.c nfstest.c |
| ln -s nfstold.c nfstest.c'
Broken PAM password authentication
echo -lpam -ldl >> LDFLAGS
ln -s ckp_pmb.c osdepckp.c
Building with SSL
ln -s ssl_unix.c osdepssl.c
echo -I/usr/local/ssl/include -I/usr/local/ssl/include/openssl
-DSSL_CERT_DIRECTORY=\"/usr/local/ssl/c
erts\" -DSSL_KEY_DIRECTORY=\"/usr/local/ssl/certs\" >> OSCFLAGS
echo "  ssl_onceonlyinit ();" >> linkage.c
echo -L/usr/local/ssl/lib -lssl -lcrypto  >> LDFLAGS
Building with SSL and plaintext passwords disabled unless SSL/TLS
echo "  mail_parameters (NIL,SET_DISABLEPLAINTEXT,(void *) 2);" >>
linkage.c
cat osdepbas.c osdepckp.c osdeplog.c osdepssl.c > osdep.c
Building OS-dependent module
If you get No such file error messages for files x509.h, ssl.h,
pem.h, buffer.h, bio.h, and crypto.h, that means that OpenSSL
is not installed on your system. Either install OpenSSL first
or build with command: make sol SSLTYPE=none
`cat CCTYPE` -c `cat CFLAGS` `cat OSCFLAGS` -c osdep.c
osdep.c: In function `checkpw':
osdep.c:148: warning: assignment from incompatible pointer type
`cat CCTYPE` -c `cat CFLAGS` mail.c
`cat CCTYPE` -c `cat CFLAGS` misc.c
`cat CCTYPE` -c `cat CFLAGS` newsrc.c
`cat CCTYPE` -c `cat CFLAGS` smanager.c
`cat CCTYPE` -c `cat CFLAGS` utf8.c
`cat CCTYPE` -c `cat CFLAGS` siglocal.c
`cat CCTYPE` -c `cat CFLAGS` dummy.c
`cat CCTYPE` -c `cat CFLAGS` pseudo.c
`cat CCTYPE` -c `cat CFLAGS` netmsg.c
`cat CCTYPE` -c `cat CFLAGS` flstring.c
`cat CCTYPE` -c `cat CFLAGS` fdstring.c
`cat CCTYPE` -c `cat CFLAGS` rfc822.c
`cat CCTYPE` -c `cat CFLAGS` nntp.c
`cat CCTYPE` -c `cat CFLAGS` smtp.c
`cat CCTYPE` -c `cat CFLAGS` imap4r1.c
`cat CCTYPE` -c `cat CFLAGS` pop3.c
`cat CCTYPE` -c `cat CFLAGS` unix.c
`cat CCTYPE` -c `cat CFLAGS` mbx.c
`cat CCTYPE` -c `cat CFLAGS` mmdf.c
`cat CCTYPE` -c `cat CFLAGS` tenex.c
`cat CCTYPE` -c `cat CFLAGS` mtx.c
`cat CCTYPE` -c `cat CFLAGS` news.c
`cat CCTYPE` -c `cat CFLAGS` phile.c
`cat CCTYPE` -c `cat CFLAGS` mh.c
`cat CCTYPE` -c `cat CFLAGS` mx.c
sh -c 'rm -rf c-client.a || true'
ar rc c-client.a osdep.o mail.o misc.o newsrc.o smanager.o utf8.o
siglocal.o  dummy.o pseudo.o netmsg.
o flstring.o fdstring.o  rfc822.o nntp.o smtp.o imap4r1.o pop3.o  unix.o
mbx.o mmdf.o tenex.o mtx.o ne
ws.o phile.o mh.o mx.o;true c-client.a
echo gso > OSTYPE
touch rebuild
sh -c 'rm -rf rebuild || true'
Building bundled tools...
cd mtest;make
`cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS`  -c
mtest.c
`cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS` -o mtest
mtest.o ../c-client/c-client.
a `cat ../c-client/LDFLAGS`
cd ipopd;make
`cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS`  -c
ipop2d.c
`cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS` -o
ipop2d ipop2d.o ../c-client/c-clien
t.a `cat ../c-client/LDFLAGS`
`cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS`  -c
ipop3d.c
`cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS` -o
ipop3d ipop3d.o ../c-client/c-clien
t.a `cat ../c-client/LDFLAGS`
cd imapd;make
`cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS`
-DANOFILE=\"/etc/anonymous.newsgroup
s\"  -DALERTFILE=\"/etc/imapd.alert\" -DNNTPFILE=\"/etc/imapd.nntp\"
-DUSERALERTFILE=\".imapalert\" -
DSHUTDOWNFILE=\"/etc/nologin\"  -c  imapd.c
`cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS`
-DANOFILE=\"/etc/anonymous.newsgroup
s\"  -DALERTFILE=\"/etc/imapd.alert\" -DNNTPFILE=\"/etc/imapd.nntp\"
-DUSERALERTFILE=\".imapalert\" -
DSHUTDOWNFILE=\"/etc/nologin\" -o imapd imapd.o ../c-client/c-client.a
`cat ../c-client/LDFLAGS`
cd mailutil;make
`cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS`  -c
mailutil.c
`cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS` -o
mailutil mailutil.o ../c-client/c-c
lient.a `cat ../c-client/LDFLAGS`
cd mlock;make || true
`cat ../c-client/CCTYPE` `cat ../c-client/CFLAGS`  -c  mlock.c
`cat ../c-client/CCTYPE` `cat ../c-client/CFLAGS` -o mlock mlock.o
cd dmail;make || true
`cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS`  -c
dmail.c
`cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS` -o dmail
dmail.o ../c-client/c-client.
a `cat ../c-client/LDFLAGS`
cd tmail;make || true
`cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS`  -c
tmail.c
`cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS` -o tmail
tmail.o ../c-client/c-client.
a `cat ../c-client/LDFLAGS`

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
On Behalf Of Mark Crispin
Sent: Thursday, July 21, 2005 2:05 PM
To: Brian Thompson
Cc: Urciolo, Kevin; [email-masked]
Subject: Re: [Imap-uw] IMAP With SSHA

On Thu, 21 Jul 2005, Brian Thompson wrote:
> I think Kevin was referring to the Sun pkgadd name. Sounds like he's 
> trying to install the version of UW imapd that Sun precompiles and 
> includes on the Solaris Companion CD. For Solaris 8/Sparc that 
> corresponds to UW imapd-2000b.

If that is the case, UW imapd can be built for Solaris by adding the
option
 	PASSWDTYPE=pmb
to the make command used to build it, e.g.
 	make gso PASSWDTYPE=pmb

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.

_______________________________________________
Imap-uw mailing list
[email-masked]
https://mailman1.u.washington.edu/mailman/listinfo/imap-uw

---

From: Mark Crispin <[email-masked]>
Date: Thu, 21 Jul 2005 11:11:41 -0800

> show the error from the client and the client configuration.

Did you set up an IMAP PAM authenticator?  That is required.

On most systems, this would be /etc/pam.d/imap but I don't know for 
certain what it would be on Solaris.  On my system, I just copied 
/etc/pam.d/ftpd to /etc/pam.d/imap and /etc/pam.d/pop (the latter if you 
use ipop3d).

-- Mark --