Subject: Re: [Imap-uw] Compile Error on Red Hat

From: "Edward Duhe'" <[email-masked]>
Date: Mon, 19 Dec 2005 18:46:26 -0600

Thanks Matt,

When I check the rpms installed I so have libgcc-3.2.3-49 listed so I 
assume that it is installed.  Is there something else that I need?

Thanks,
Edward

At 04:23 PM 12/16/2005 -0500, Matt Selsky wrote:
>Do you have the gcc RPMs installed?
>
>
>--
>Matt
>
>On Fri, Dec 16, 2005 at 02:50:25PM -0600, Edward Duhe' wrote:
> > I am trying to compile the imap-2004g on a red hat installation.  I am
> > getting the errors below and cannot get any further.  Anyone have any 
> ideas
> > what might be wrong?
> >
> > Thanks,
> > Edward
> >
> > ...
> > Standard password authentication
> > ln -s ckp_psx.c osdepckp.c
> > Building with SSL
> > ln -s ssl_unix.c osdepssl.c
> > echo -I/usr/local/ssl/include -I/usr/local/ssl/include/openssl
> > -DSSL_CERT_DIRECTORY=\"/usr/local/ssl/certs\"
> > -DSSL_KEY_DIRECTORY=\"/usr/local/ssl/certs\" >> OSCFLAGS
> > echo "  ssl_onceonlyinit ();" >> linkage.c
> > echo -L/usr/local/ssl/lib -lssl -lcrypto  >> LDFLAGS
> > Building with SSL and plaintext passwords disabled unless SSL/TLS
> > echo "  mail_parameters (NIL,SET_DISABLEPLAINTEXT,(void *) 2);" >> 
> linkage.c
> > cat osdepbas.c osdepckp.c osdeplog.c osdepssl.c > osdep.c
> > Building OS-dependent module
> > If you get No such file error messages for files x509.h, ssl.h,
> > pem.h, buffer.h, bio.h, and crypto.h, that means that OpenSSL
> > is not installed on your system. Either install OpenSSL first
> > or build with command: make slx SSLTYPE=none
> > `cat CCTYPE` -c `cat CFLAGS` `cat OSCFLAGS` -c osdep.c
> > /bin/sh: line 1: cc: command not found
> > make[3]: *** [osdep.o] Error 127
> > make[3]: Leaving directory `/root/imap-2004g/c-client'
> > make[2]: *** [slx] Error 2
> > make[2]: Leaving directory `/root/imap-2004g/c-client'
> > make[1]: *** [OSTYPE] Error 2
> > make[1]: Leaving directory `/root/imap-2004g'
> > make: *** [slx] Error 2
> >
> >
> >
> >
> > _______________________________________________
> > Imap-uw mailing list
> > [email-masked]
> > https://mailman1.u.washington.edu/mailman/listinfo/imap-uw

_______________________________________________
Imap-uw mailing list
[email-masked]
https://mailman1.u.washington.edu/mailman/listinfo/imap-uw

---

From: Matt Selsky <[email-masked]>
Date: Tue, 20 Dec 2005 16:59:42 -0500

On my RHEL4 system:

$ rpm -q gcc
gcc-3.4.4-2

The libgcc RPM just gives the gcc shared libraries.  The gcc RPM 
supplies the compiler (gcc, cc) itself.

-- 
Matt

On Dec 19, 2005, at 7:46 PM, Edward Duhe' wrote:

>> > getting the errors below and cannot get any further.  Anyone have 
>> any ideas
>> > what might be wrong?
>> >
>> > Thanks,
>> > Edward
>> >
>> > ...