Subject: [Imap-uw] UW IMAP on Mac OS X 10.4

From: "Otto Maddox" <[email-masked]>
Date: Fri, 02 Dec 2005 02:04:09 +0000

I am trying to get UW IMAP 2004g working on Mac OS X 10.4 (Tiger).

So far:

$ make osx SSLTYPE=none
$ sudo cp imapd/imapd /usr/local/libexec

(I'm using "SSLTYPE=none" as a temporary measure. I still have to get
certificates, etc, sorted out and then I'll do it properly with SSL.
It's running on localhost and not accessible to anyone else anyway.)

Here's my /Library/LaunchDaemons/imapd.plist:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN"
"http://www.apple.
com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
  <key>Label</key>
  <string>edu.washington.imapd</string>
  <key>ProgramArguments</key>
  <array>
    <string>/usr/local/libexec/imapd</string>
  </array>
  <key>Sockets</key>
  <dict>
    <key>Listeners</key>
    <dict>
      <key>Bonjour</key>
      <false/>
      <key>SockServiceName</key>
      <string>imap</string>
    </dict>
  </dict>
  <key>inetdCompatibility</key>
  <dict>
    <key>Wait</key>
    <false/>
  </dict>
</dict>
</plist>

The problem is that the server won't authenticate me. Apple Mail, for
instance, keeps telling me the server rejected the password.

Anyone have any ideas?

Thanks.

-- 
http://www.fastmail.fm - I mean, what is it about a decent email service?

_______________________________________________
Imap-uw mailing list
[email-masked]
https://mailman1.u.washington.edu/mailman/listinfo/imap-uw

---

From: Mark Crispin <[email-masked]>
Date: Thu, 1 Dec 2005 18:24:35 -0800 (PST)

> instance, keeps telling me the server rejected the password.

Since you say that you are using SSLTYPE=none, we know that this is not 
the "no plaintext passwords on non-SSL/TLS sessions" issue.

You said that you used "osx".  I don't think that works with Tiger; even 
privileged processes no longer get the password via getpwnam().

Consequently, you must use "oxp", and set up a PAM rule file for IMAP. 
So, do
 	make clean
 	make oxp SSLTYPE=none
 	sudo cp imapd/imapd /usr/local/libexec
to update imapd to a PAM version.

As for a PAM rule file, I just copied the FTP rules:
 	cd /etc/pam.d
 	sudo cp ftpd imap

-- Mark --

http://panda.com/mrc
Democracy is two wolves and a sheep deciding what to eat for lunch.
Liberty is a well-armed sheep contesting the vote.
_______________________________________________
Imap-uw mailing list
[email-masked]
https://mailman1.u.washington.edu/mailman/listinfo/imap-uw

---

From: "Otto Maddox" <[email-masked]>
Date: Fri, 02 Dec 2005 02:52:55 +0000

> the "no plaintext passwords on non-SSL/TLS sessions" issue.

I hadn't come across this issue.  Do I need to be aware of it?  (For
when I get around to building SSL-enabled imapd.)

> As for a PAM rule file, I just copied the FTP rules:

It works.  Thanks very much :-)

-- 
http://www.fastmail.fm - Access all of your messages and folders
                          wherever you are

---

From: Mark Crispin <[email-masked]>
Date: Thu, 1 Dec 2005 18:58:56 -0800 (PST)

> when I get around to building SSL-enabled imapd.)

This is a requirement of the IMAP specification.  Servers are not supposed 
to allow password authentication unless the session is secured with SSL or 
TLS.

This frequently confuses novices who try to TELNET to an IMAP server to 
test it, and wonder why they can't log in.

-- Mark --

http://panda.com/mrc