Subject: Re: UW_IMAP and quotas

From: Federico Giannici <[email-masked]>
Date: Wed, 22 Sep 1999 09:49:28 +0200

Mark Crispin wrote:
> 
> On Tue, 21 Sep 1999, Federico Giannici wrote:
> > Is uw_imap supposed to correctly handle mailboxes (mbox format) with
> > quotas (standard unix filesystem quota)?
> 
> It all depends upon what you mean by "correctly handle."
> 
> If the software attempts to change the mailbox, and that change causes a
> disk quota exception, the change is undone and the mailbox is restored to
> its previous state.

The situation is the following: a mailbox has a 10MB quota and it
contains 50 little messages and a message of 9.5MB.

Now, if I try to cancel the big message, the operation is undone.

As I already said, if imapd need to create a temporary file it can do it
into the /tmp directory as there is no quota into that directory.

Thanks.

---

From: Federico Giannici <[email-masked]>
Date: Wed, 22 Sep 1999 10:08:42 +0200

Mark Crispin wrote:
> 
> Is there a quota on /var/tmp?
> 
> If so, that's your problem.  Most implementations of tmpfile() use /var/tmp.

No. Quotas are only in the /var/mail partition (the mailboxes
directory).

And all other partitions have a lot of free space.

Thanks.