Subject: smtp auth problem

From: Niklas Fondberg <[email-masked]>
Date: Wed, 15 Sep 2004 15:25:37 +0200

I'm not able to get to mm_login when I call smtp_open to a smtp server 
that needs authentification.
What am I doing wrong?
The  one entry in hostlist looks like: smtp.home.se/user=[email-masked]

Here is the debug output...
mm_log: [Trying IP address [213.214.194.102]]
220 smtp2.home.se Novonyx SMTP ready $Revision:   3.22.1.8  $
EHLO i3-dhcp190.sthlm.i3micro.se
250-smtp2.home.se Pleased to meet you
250-ETRN
250-HELP
250-EXPN
250-PIPELINING
250-8BITMIME
250-DSN
250-AUTH LOGIN
250-AUTH=LOGIN
250 SIZE 10485760
mm_log: ?SMTP authentication not available: smtp.home.se
QUIT
221 smtp2.home.se So long, and thanks for all the fish
[Can't open connection to any server]Content-Type: text/html

-- 
Niklas Fondberg
Development Manager, User Interfaces

-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Wed, 15 Sep 2004 08:56:46 -0700 (PDT)

On Wed, 15 Sep 2004, Niklas Fondberg wrote:
> I'm not able to get to mm_login when I call smtp_open to a smtp server that 
> needs authentification.

Did you
 	#include "linkage.c"
early in the main() function of your program?  This is required.

Have you made modifications to the c-client library?  If so, what?

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.

---

From: Niklas Fondberg <[email-masked]>
Date: Wed, 15 Sep 2004 19:16:05 +0200

I solved it.
auth_md5 was required....
I didn't link it before....

Mark Crispin wrote:

>> I'm not able to get to mm_login when I call smtp_open to a smtp 
>> server that needs authentification.
>
>
> Did you
>     #include "linkage.c"

---

From: Mark Crispin <[email-masked]>
Date: Wed, 15 Sep 2004 10:49:48 -0700 (PDT)

> I didn't link it before....

Please do not link things manually.  Please use linkage.c instead.

-- Mark --

---

From: Niklas Fondberg <[email-masked]>
Date: Thu, 16 Sep 2004 09:32:08 +0200

Why? I don't want everything plus I need a small memory footprint...

---

From: Mark Crispin <[email-masked]>
Date: Thu, 16 Sep 2004 09:36:28 -0700 (PDT)

The linkage.c module is where I put critically necessary initialization 
steps for c-client.  Not all of those steps are obvious.  If you link 
manually instead of using linkage.c, some things now (and in the future) 
will fail in unpredictable ways.

I have already had incidents where I wasted a lot of time debugging 
someone's problem, only to discover that a critical linkage wasn't done 
because he lunk manually in his application instead of using linkage.c.

If you want to remove some drivers, do so in the DRIVERS setting in the 
Makefile.  DO NOT LINK MANUALLY!!

-- Mark --

---

From: Niklas Fondberg <[email-masked]>
Date: Thu, 16 Sep 2004 18:38:07 +0200

Ok, thanks. I do that now.

Mark Crispin wrote:

> The linkage.c module is where I put critically necessary 
> initialization steps for c-client.  Not all of those steps are 
> obvious.  If you link manually instead of using linkage.c, some things 
> now (and in the future) will fail in unpredictable ways.
>
> someone's problem, only to discover that a critical linkage wasn't 
> done because he lunk manually in his application instead of using 
> linkage.c.
>
> If you want to remove some drivers, do so in the DRIVERS setting in 
> the Makefile.  DO NOT LINK MANUALLY!!
>