Subject: Building IMAP c-client 4.6 library under Sun OS

From: "Manuel Lemos" <[email-masked]>
Date: 17 Oct 99 06:34:20 +0000

Hello,

I need to build IMAP 4.6 c-client library under SunOS 4.1:

uname -a
SunOS whoopi.adgrafix.com 5.6 Generic_105181-14 sun4u sparc SUNW,Ultra-1

The first problem is that I can't determine the right target to make the
library. What is the recommended target: sun, ssn, gsu, what?

make sun gives me:

/usr/ucb/cc:  language optional software package not installed

So I suppose this compile is not available.

make gsu gives

In file included from osdep.c:38:
osdep.h:37: sys/dir.h: No such file or directory

sys/dir.h is in /usr/ucbinclude (not in /usr/include) so I added -I
/usr/ucbinclude in src/osdep/unix/Makefile flags.

But then it gives a lot of errors like 

In file included from osdep.c:38:
osdep.h:55: conflicting types for `strtoul'
/usr/include/stdlib.h:97: previous declaration of `strtoul'
osdep.h:57: conflicting types for `memmove'
/usr/include/string.h:37: previous declaration of `memmove'
In file included from osdep.c:61:
nl_unix.c:80: parse error before `*'
nl_unix.c: In function `strcrlflen':

What should I do then to build the c-client library in this machine?

Regards,
Manuel Lemos

Web Programming Components using PHP Classes.
Look at: http://phpclasses.UpperDesign.com/?user=[email-masked]
--
E-mail: [email-masked]
URL: http://www.mlemos.e-na.net/
PGP key: http://www.mlemos.e-na.net/ManuelLemos.pgp
--

---

From: Mark Crispin <[email-masked]>
Date: Sun, 17 Oct 1999 10:36:19 -0700 (PDT)

You have Solaris, not SUN-OS.  SUN-OS is Sun's BSD-based system from 10 years
ago.  Once upon a time, these distinctions were obvious, but Sun's marketing
cretins then decided to re-use the SUN-OS name.

Try either "make sol" or "make gso".  Be sure to do "make clean" first.