Subject: imap-4.3 toolkit crashed

From: Lai Yiu Fai <[email-masked]>
Date: Mon, 7 Sep 1998 19:16:49 +0800

Hello all,

I found the imapd-4.3 (v11.240) crashed with following error.

* BYE [ALERT] IMAP4rev1 server crashing: Bad msgno 105 in mail_elt, nmsgs = 104

It happened with Netscape 4.06 sending a command "UID fetch 1:* (FLAGS)".
Also, I noted that if I removed the "FOLDER INTERNAL DATA" message and tried
again.  It worked without any problem.  Actually, I switch the server from
v11.237 to 240 and found this problem.   Does the "internal data" message
differ between 237 ans 240 and cause the crash?

Anyone get the same problem?
=======================================================================
Lai Yiu Fai                       |  Tel.:       (852) 2358-6202
Centre of Computing Services      |  Fax.:       (852) 2358-2737
 & Telecommunications             |  E-mail:     [email-masked]
                                  |
The Hong Kong University of       |  Clear Water Bay,
Science & Technology              |  Kowloon, Hong Kong.

------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: "Andrej Borsenkow" <[email-masked]>
Date: Mon, 7 Sep 1998 15:29:42 +0400

You have to update to the latest imapd-4.4.BETA. imapd-4.3 was removed from UW ftp site. The reason it worked without "folder internal data" is, the server recomputed all UID and UID 1 become valid again.

/Andrej

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Lai Yiu Fai
> Sent: Monday, September 07, 1998 3:17 PM
> To: [email-masked]
> Subject: imap-4.3 toolkit crashed
> 
> 
> Hello all,
>