Subject: How to fetch a substring from the body?

From: [email-masked]
Date: Tue, 26 Jun 2001 15:51:57 +0200

Is there in c-client a possibility to fetch a string from body? I have found

char *mail_fetchbody_full (MAILSTREAM *stream,unsigned long msgno,char *sec,
unsigned long *len,long flags);
but how can I send the command 
fetch <msgno> body[1]<0.8> with this function?
Thanks
Julia
****************************************************************************
************
MATERNA GmbH
Information & Communications

Julia Petkau
Business Unit Communications

Voßkuhle 37
44141 Dortmund
GERMANY

Fon	+49 (231) 55 99 - 8409
Fax	+49 (231) 55 99 - 8688
       	+49 (231) 55 99 - 67 8947
Mail       [email-masked]

-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Tue, 26 Jun 2001 10:32:11 -0700 (PDT)

> fetch <msgno> body[1]<0.8> with this function?

Use mail_partial_body() instead of mail_fetchbody_full().  Note that the data
is returned via a mailgets callback instead of as a char* from the function.