Subject: IMAP2 broken?

From: "Adrian Inman" <[email-masked]>
Date: Mon, 17 Mar 2003 18:05:27 -0000

I have debian and had uw-imapd running just fine.

But having upgraded - apt-get dist-upgrade, it refuses to allow logins unless through imaps on port 993 using ssl.

I'd like to be able to sort this out. I have a funny feeling this is down to me not understanding
the apt-get dist-upgrade process at the time, but everything else is fine now, I just can't fix this.

I've tried apt-get remove and dpkg -P but neither have any effect. I assume this is a security thing, but give that I am using the debian packages, I can't really (and don't want to) recompile it.

The error message is just LOGIN FAILED.

Please help!!!

Thanks. 
 
Adrian Inman
aFinite (www.aFinite.co.uk)
m :: 0776 4499205 

-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Mon, 17 Mar 2003 10:47:10 -0800 (Pacific Standard Time)

On Mon, 17 Mar 2003, Adrian Inman wrote:
> But having upgraded - apt-get dist-upgrade, it refuses to allow logins
> unless through imaps on port 993 using ssl.

This is by design if the software is built with the SSLTYPE=nopwd option.
If you want to allow insecure logins on unprotected sessions (meaning that
anyone can sniff passwords!) you can rebuild the software with
SSLTYPE=unix.

I have no idea how to do this with a Debian package.  But, if you get the
sources directly from UW:
	ftp://ftp.cac.washington.edu/mail/imap.tar.Z
the command to build the software in the way you want is:
	make lnp SSLTYPE=unix

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.

---

From: tomas pospisek <[email-masked]>
Date: Mon, 17 Mar 2003 19:58:34 +0100 (CET)

On Mon, 17 Mar 2003, Mark Crispin wrote:

> I have no idea how to do this with a Debian package.

apt-get build-dep some_package
apt-get source some_package
cd source_dir
edit whererever SSLTYPE=unix gets set
dpkg-buildpackage -rfakeroot

>  But, if you get the

*t

--
Im Gazastreifen, dem laut Uno-Angaben am dichtesten besiedelten Flecken
der Erde, leben unter 1,3 Millionen Palästinensern 5000 Israelis und okkupieren
40 Prozent der Fläche.
        NZZ 8.4.2002