Subject: c-client and ssl

From: Greg Cockburn <[email-masked]>
Date: Fri, 8 Feb 2002 10:06:46 +1300

Hi,

I am having a problem with a little app called mailsync. I see it has popped 
up in this mailing list before, but this is related to ssl and is more to do 
with c-client than mailsync.

The issue I have is that I can't seem to use ssl.
I compile c-client like so:
make slx SSLTYPE=unix SSLDIR=/usr
and I have also tried:
make slx EXTRAAUTHENTICATORS=ssl SSLTYPE=unix SSLDIR=/usr
(but this one doesn't compile)

When I put /ssl into the server line of the config I get the following error:
?Can't open mailbox 
{lambton.sslnz.com/user=gregc/ssl/imap4rev1/readonly/debug}: invalid remote 
specification

any ideas?

Thanks.
- -- 
Greg Cockburn, LCA
Technical Analyst
SSLnz
Wellington
Ph. +64 4 473 4666
Mobile. +64 25 275 6378
-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Thu, 7 Feb 2002 13:14:06 -0800 (PST)

> make slx SSLTYPE=unix SSLDIR=/usr

That should be correct.

> (but this one doesn't compile)

The setting of EXTRAAUTHENTICATORS=ssl is for an older version and is
inappropriate today.

> {lambton.sslnz.com/user=gregc/ssl/imap4rev1/readonly/debug}: invalid remote

This indicates that you are running a binary that was not built with SSL.  Are
you ABSOLUTELY sure that that binary is built with an SSL-enabled c-client?

Have you verified that the mailsync application does a proper
	#include <linkage.c>
early in its main() function?