Subject: FETCH x RFC822 removes separating newline between nntp-header/body

From: Jens Krinke <[email-masked]>
Date: 06 Sep 1999 15:52:28 +0200

Hi,

I try to use the proxying feature via {nntpserver/nntp}.  However I
have problems with my client, as the separating newline between the
nntp-header and the body is lost during FETCH x RFC822:

...
1 SELECT "{nntpserver/nntp}uni-passau.misc"
* OK news.rz.uni-passau.de DNEWS Version 4.2o, S0, posting OK 
...
1 OK [READ-ONLY] SELECT completed
2 FETCH 1 RFC822
* 1 FETCH (RFC822 {2263}
Message-ID: <[email-masked]>
Date: Tue, 06 May 1997 09:38:29 +0200
From: Henrik <[email-masked]>
X-Mailer: Mozilla 3.0 (X11; I; SunOS 4.1.3 sun4c)
MIME-Version: 1.0
Newsgroups: uni-passau.misc,uni-passau.fmi.misc,uni-passau.phil.misc,uni-passau.ktf.misc
Followup-To: uni-passau.misc
Subject: Zimmer in Wien zu vermieten....
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
NNTP-Posting-Host: 132.231.1.26
Lines: 35
Path: news.rz.uni-passau.de!132.231.1.26
Xref: news.rz.uni-passau.de uni-passau.misc:2107 uni-passau.fmi.misc:973 uni-passau.phil.misc:12 uni-passau.ktf.misc:5
na ja, weiss auch nicht ob`s in passau richtig aufgehoben ist, aber dies
geschieht nur auf den wunsch einer freundin von mir....
...

Any suggestions?

Jens Krinke
-- 
______________________________________________________________________
 Jens Krinke                                          [email-masked]
 +49 851 509 3096        http://www.fmi.uni-passau.de/st/staff/krinke
-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Tue, 7 Sep 1999 00:48:30 -0700 (PDT)

> nntp-header and the body is lost during FETCH x RFC822:

This problem is fixed in the latest
	ftp://ftp.cac.washington.edu/mail/imap-4.6.BETA.tar.Z

However, please note that use of "FETCH x RFC822" is the earmark of a poorly
written IMAP client program.  There is almost never a reason to use this
command.  It is very likely that if you are using this command, you are using
IMAP improperly and suboptimally.

Yes, certain well-known vendors have inflicted such poorly-designed IMAP
clients on the world, but we don't have to repeat their mistakes!

Please review your implementation strategy.  It is quite likely that instead
of fetching RFC822, you should be using overviews and/or ENVELOPE and
BODYSTRUCTURE, along with selective body part fetching.