Subject: Compile error(s) on Solaris 9

From: Eric Izenas <[email-masked]>
Date: Sat, 29 Nov 2003 09:00:17 -0800

Hi,

I'm trying to compile imap-2002e on a Solaris 9 box.

When I run 'make gso' the compile starts but exits with the following 
error(s):

`cat CCTYPE` -c `cat CFLAGS` `cat OSCFLAGS` -c osdep.c
`cat CCTYPE` -c `cat CFLAGS` mail.c
`cat CCTYPE` -c `cat CFLAGS` misc.c
`cat CCTYPE` -c `cat CFLAGS` newsrc.c
`cat CCTYPE` -c `cat CFLAGS` smanager.c
`cat CCTYPE` -c `cat CFLAGS` utf8.c
`cat CCTYPE` -c `cat CFLAGS` siglocal.c
`cat CCTYPE` -c `cat CFLAGS` dummy.c
`cat CCTYPE` -c `cat CFLAGS` pseudo.c
`cat CCTYPE` -c `cat CFLAGS` netmsg.c
`cat CCTYPE` -c `cat CFLAGS` flstring.c
`cat CCTYPE` -c `cat CFLAGS` fdstring.c
`cat CCTYPE` -c `cat CFLAGS` rfc822.c
`cat CCTYPE` -c `cat CFLAGS` nntp.c
`cat CCTYPE` -c `cat CFLAGS` smtp.c
`cat CCTYPE` -c `cat CFLAGS` imap4r1.c
`cat CCTYPE` -c `cat CFLAGS` pop3.c
`cat CCTYPE` -c `cat CFLAGS` unix.c
`cat CCTYPE` -c `cat CFLAGS` mbox.c
`cat CCTYPE` -c `cat CFLAGS` mbx.c
`cat CCTYPE` -c `cat CFLAGS` mmdf.c
`cat CCTYPE` -c `cat CFLAGS` tenex.c
`cat CCTYPE` -c `cat CFLAGS` mtx.c
`cat CCTYPE` -c `cat CFLAGS` news.c
`cat CCTYPE` -c `cat CFLAGS` phile.c
`cat CCTYPE` -c `cat CFLAGS` mh.c
`cat CCTYPE` -c `cat CFLAGS` mx.c
sh -c 'rm -rf c-client.a || true'
ar rc c-client.a osdep.o mail.o misc.o newsrc.o smanager.o utf8.o 
siglocal.o dummy.o pseudo.o netmsg.o flstring.o fdstring.o rfc822.o 
nntp.o smtp.o imap4r1.o pop3.o unix.o mbox.o mbx.o mmdf.o tenex.o mtx.o 
news.o phile.o mh.o mx.o;true c-client.a
ARCHIVE: ar: not found
make[3]: Leaving directory `/hd2/SFW/src/imap-2002e/c-client'
make[2]: Leaving directory `/hd2/SFW/src/imap-2002e/c-client'
echo gso > OSTYPE
touch rebuild
sh -c 'rm -rf rebuild || true'
Building bundled tools...
cd mtest;make
make[2]: Entering directory `/hd2/SFW/src/imap-2002e/mtest'
cd ../c-client;make
make[3]: Entering directory `/hd2/SFW/src/imap-2002e/c-client'
make all `cat SPECIALS`
make[4]: Entering directory `/hd2/SFW/src/imap-2002e/c-client'
sh -c 'rm -rf c-client.a || true'
ar rc c-client.a osdep.o mail.o misc.o newsrc.o smanager.o utf8.o 
siglocal.o dummy.o pseudo.o netmsg.o flstring.o fdstring.o rfc822.o 
nntp.o smtp.o imap4r1.o pop3.o unix.o mbox.o mbx.o mmdf.o tenex.o mtx.o 
news.o phile.o mh.o mx.o;true c-client.a
ARCHIVE: ar: not found
make[4]: Leaving directory `/hd2/SFW/src/imap-2002e/c-client'
make[3]: Leaving directory `/hd2/SFW/src/imap-2002e/c-client'
`cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS`   -c -o 
mtest.o mtest.c
`cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS` -o 
mtest mtest.o ../c-client/c-client.a `cat ../c-client/LDFLAGS`
gcc: ../c-client/c-client.a: No such file or directory
make[2]: *** [mtest] Error 1
make[2]: Leaving directory `/hd2/SFW/src/imap-2002e/mtest'
make[1]: *** [bundled] Error 2
make[1]: Leaving directory `/hd2/SFW/src/imap-2002e'
make: *** [gso] Error 2

Can anyone help me here? Any info is appreciated.

Thanks much,

Eric I.

---

From: "Martynas Buozis" <[email-masked]>
Date: Sat, 29 Nov 2003 18:26:42 +0100

ar is located in /usr/ccs/bin . Before make do :
PATH=$PATH:/usr/ccs/bin; export PATH

Martynas
  ----- Original Message ----- 
  From: Eric Izenas 
  To: [email-masked] 
  Sent: Saturday, November 29, 2003 6:00 PM
  Subject: Compile error(s) on Solaris 9

  Hi,

  When I run 'make gso' the compile starts but exits with the following error(s):

  ar rc c-client.a osdep.o mail.o misc.o newsrc.o smanager.o utf8.o siglocal.o dummy.o pseudo.o netmsg.o flstring.o fdstring.o rfc822.o nntp.o smtp.o imap4r1.o pop3.o unix.o mbox.o mbx.o mmdf.o tenex.o mtx.o news.o phile.o mh.o mx.o;true c-client.a
  ar rc c-client.a osdep.o mail.o misc.o newsrc.o smanager.o utf8.o siglocal.o dummy.o pseudo.o netmsg.o flstring.o fdstring.o rfc822.o nntp.o smtp.o imap4r1.o pop3.o unix.o mbox.o mbx.o mmdf.o tenex.o mtx.o news.o phile.o mh.o mx.o;true c-client.a
  `cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS` -c -o mtest.o mtest.c
  `cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS` -o mtest mtest.o ../c-client/c-client.a `cat ../c-client/LDFLAGS`

  Thanks much,

  Eric I.

---

From: [email-masked] (Jim Seymour)
Date: Sat, 29 Nov 2003 12:32:06 -0500 (EST)

> When I run 'make gso' the compile starts but exits with the following 
[snip]
> ARCHIVE: ar: not found
[snip]
> ARCHIVE: ar: not found
[snip]
> Can anyone help me here? Any info is appreciated.

Maybe find out where "ar" lives and make sure said directory is
in your $PATH?

$ uname -a
SunOS jimsun 5.7 Generic_106541-27 sun4u sparc SUNW,UltraSPARC-IIi-Engine
$ whence ar
/usr/ccs/bin/ar

-- 
Jim Seymour                | Spammers sue anti-spammers:
[email-masked]       |     http://www.LinxNet.com/misc/spam/slapp.php
http://jimsun.LinxNet.com  | Please donate to the SpamCon Legal Fund:
                           |     http://www.spamcon.org/legalfund/