Subject: RE: Netscape 4.61 Messager Problems

From: Jeff Breitner <[email-masked]>
Date: Wed, 29 Sep 1999 02:21:40 GMT

> 
> I just upgraded my POP3/IMAP servers on my Irix boxes and suddenly Netscape
> communicator users are unable to retrieve mail via POP3.
> 

It appears that Netscape wants to talk APOP, not POP.

Yippie.

---

From: Jeff Breitner <[email-masked]>
Date: Wed, 29 Sep 1999 09:40:42 GMT

> ipop3d certainly does support the AUTH command.  On systems which have an
> /etc/cram-md5.pwd file set up, APOP is also permitted:
> 	 OK POP3 v7.62 server ready <[email-masked]>
> 	AUTH
> 	 OK Supported authentication mechanisms:
> 	CRAM-MD5
> 	LOGIN
> 	.
> 

Interesting...

> On systems which don't have an /etc/cram-md5.pwd file set up:
> 	 OK POP3 Ikkoku-Kan.Panda.COM v7.62 server ready
> 	auth
> 	 OK Supported authentication mechanisms:
> 	LOGIN
> 	.
> and APOP is not permitted.
> 

This sheds new light on what's happening, because I'm not even getting a response
to the auth command.

> Read imap-4.[xxx]/docs/md5.txt for information about the /etc/cram-md5.pwd
> file and warnings about whether or not you really want to use it.
> 
> There is also the traditional USER/PASS form of authentication.
> 

The traditional user/pass is working.

> 
> I haven't a clue as to why you think that the 3.3 POP server would "accept
> some rudimentary IMAP commands".  POP and IMAP are completely different
> protocols.
> 

That is what was confusing to me.  The previous server POP3 server responded to a
connection with:

 OK oldsrv POP3 3.3(18) w/IMAP2 client (Comments to [email-masked]) at
Wed, 29 Sep 1999 05:45:56 -0400 (EDT)

> 
> Lots of people are using Netscape with ipop3d successfully, so whatever is
> wrong is probably something localized to your site.

That's definetly the case.  I have found several systems that are responding with
what is expected.  Now...to find out what has gone wrong on my end.

---

From: Jeff Breitner <[email-masked]>
Date: Wed, 29 Sep 1999 11:15:48 GMT

After reviewing what I'm "supposed" to be seeing during the exchange of
information between the Netscape client and the server, it was obvious that the server was
hanging on the AUTH command.  As long as that command was not passed to the
server, everything worked as expected.  The IMAP server worked as expected and without
fail.

I compiled a fresh copy of the server from the imap-4.5.beta distribution, which
is the distribution used to create the POP server that I'm having difficulty
using.  Everything worked as expected from a stock install.  Then I made the
modifications to point to the inbox folders within the user's home directory.  On both my
BSD and Linux boxes, everything worked fine.  I compiled again on the Irix machine
and the AUTH command hangs the POP server.

Further investigations revealed that this Irix 6.5 box does not have the native
MipsPro compiler, but is using gcc installed from SGI freeware.  Compiling from
another machine with a native compiler solved the problem.

As a side note, this is not the first mysterious problem I've had with the
freeware compiler.  Programs seem to compile fine, but they fail for strange reasons.

Thanks again for your help.