Subject: Trouble with headers

From: "Fernando Maldonado S." <[email-masked]>
Date: Mon, 11 Aug 2003 16:04:16 -0600

I have  compiled the imap-2002c1 IMAP Toolkit Environment on October 13 
2001 

My operative System is Solaris 8 

I had an older version of IMAP, but worked correctly, when I installed the new 
one with 

./configure gso SSLTYPE=unix 
make 

I copied the binary file result of compilation of imapd 

The problem is when I read my mail on web among IMP my Mailbox freeze and the 
navigator don't answer 

If I configure Outlook like an imap client, it works fine and load evry 
message!!! 
________ 

That's why I think the trouble is in the IMP application 

After analize the mailbox I find the message generating the problem has the 
next 
headers 

============================================================================= 
>From [email-masked]  Mon Jul 14 01:06:02 2003 
[132.248.155.13]) 
        by pumas.iingen.unam.mx (8.x.x/8.x.x) with ESMTP id h6E661M3015742 
        for <[email-masked]>; Mon, 14 Jul 2003 01:06:01 -0500 
(CDT) 
Received: from mail-ale01.alestra.net.mx (mail-ale01.alestra.net.mx 
[207.248.224.149] (may be forged)) 
        by quetzal.iingen.unam.mx (8.12.9/8.12.9) with ESMTP id 
h6E659R3004101 
        for <[email-masked]>; Mon, 14 Jul 2003 01:05:09 -0500 
(CDT) 
Received: from pavilion (148.244.165.198) by mail-ale01.alestra.net.mx 
(5.1.061) 
        id 3F0ACAA5001D9E0F; Mon, 14 Jul 2003 01:04:57 -0500 
Message-ID: <[email-masked]> (added by 
[email-masked]) 
From: "Dexpro" <[email-masked]> 
Subject: DIRECTORIO EMPRESARIAL E INDUSTRIAL 
To: "Mercadotecmia" <[email-masked]> 
Content-Type: multipart/alternative; 
boundary="=_NextPart_2rfkindysadvnqw3nerasdf"; 
MIME-Version: 1.0 
Reply-To: [email-masked] 
Date: Mon, 14 Jul 2003 01:02:11 +0200 
X-Priority: 3 
X-Library: Indy 8.0.22 
X-RAVMilter-Version: 8.4.2(snapshot 20021217) (pumas) 
X-IMAPbase: 1058482789 81 
Status: RO 
X-Status: 
X-Keywords: 
X-UID: 62 

This is a multi-part message in MIME format 

--=_NextPart_2rfkindysadvnqw3nerasdf 
Content-Type: text/plain; charset="iso-8859-1" 
Content-Transfer-Encoding: quoted-printable 

http://www.bdatos.com.mx 

--=_NextPart_2rfkindysadvnqw3nerasdf 
Content-Type: text/html; charset="iso-8859-1" 
Content-Transfer-Encoding: quoted-printable 
Content-Base: "http://www.bdatos.com.mx/" 
Content-Location: "http://www.bdatos.com.mx/" 

============================================================================== 

The header that trigger all the troubble is 

Content-Type: multipart/alternative; 
boundary="=_NextPart_2rfkindysadvnqw3nerasdf"; 

___________________________________________________________________ 

The question is what's happening? The old version worked correctly but when I 
changed to the new one I have the problem 

Is it an IMAP problem??? 
Is PHP??? 

I hope somebody can help me 

Thank you very much!! 

            ***************************************** 
          ***************************************** * 
          *     Instituto de Ingeniería UNAM      * * 
          *  Coordinación de Sistemas de Cómputo  * * 
          *        Área de Servidores Unix        * * 
          *         Tel.56-22-80-92 al 97         * * 
          *                                       * * 
          *Fernando Maldonado                     * * 
          *Tel. 044-55-25-40-86-33                * * 
          *Sky 52-57-79-79                        * * 
          *Pin 1558337930                         * * 
          [email-masked]                  * * 
          *                                       * * 
          *****************************************

---

From: Mark Crispin <[email-masked]>
Date: Mon, 18 Aug 2003 16:30:52 -0700 (Pacific Daylight Time)

> Content-Location: "http://www.bdatos.com.mx/"

These headers are the cause of the problem; they trigger a long-standing
bug in the IMAP client code if (and only if) the IMAP server supports
these headers.

Rebuild IMP using the c-client library from imap-2002d (the current
release version) and the problem will go away.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.