Subject: [Imap-uw] Running imapd/ipop3d as standalone servers:

From: Josh Marquis <[email-masked]>
Date: Fri, 12 Aug 2005 00:16:32 -0700

Evening,

I would like to run imapd as a standalone service rather than through inetd but
couldn't find any information on how to do this.

Thanks for the help and I apologize if this has already been answered...I really
did look :)

Josh

_______________________________________________
Imap-uw mailing list
[email-masked]
https://mailman1.u.washington.edu/mailman/listinfo/imap-uw

---

From: "Dan Mahoney, System Admin" <[email-masked]>
Date: Fri, 12 Aug 2005 03:35:20 -0400 (EDT)

On Fri, 12 Aug 2005, Josh Marquis wrote:

Josh,

I don't actually think it's possible -- as I recall I had a similar issue 
with telnetd under BSD a while back, because I thought firing up inetd for 
a single daemon was silly.

Looking over most of the FAQ, I see no mention of running it standalone, 
which leads me to believe the code *just isn't there* to handle 
connections.

I could of course be wrong, if anyone else would care to correct me?

-Dan

--

"We are basically...'Bandwidth Pimps'...Hrmmm...But that's cool man!  You see these gold chains?  It's all good!"

-Ali Dhoon
03/03/2003, 7PM

--------Dan Mahoney--------
Techie,  Sysadmin,  WebGeek
Gushi on efnet/undernet IRC
ICQ: 13735144   AIM: LarpGM
Site:  http://www.gushi.org
---------------------------

---

From: Mark Crispin <[email-masked]>
Date: Fri, 12 Aug 2005 00:46:54 -0700 (PDT)

> couldn't find any information on how to do this.

You can't.

Nor does it make any sense to change do so.  Each imapd session has to run 
in its own process, since it setuids itself to the user that logs in via 
IMAP.  If imapd ran as a standalone server, it would actually consume an
additional process than the current scheme of running imapd under inetd.

Standalone daemons only make sense if the daemon needs to be continously 
running doing something other than being a server (such as sendmail, which 
must also maintain mail queues and deliver mail), or if the task of the 
daemon is ameniable to being threaded.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.
_______________________________________________
Imap-uw mailing list
[email-masked]
https://mailman1.u.washington.edu/mailman/listinfo/imap-uw

---

From: Mark Crispin <[email-masked]>
Date: Fri, 12 Aug 2005 00:48:31 -0700 (PDT)

On Fri, 12 Aug 2005, Dan Mahoney, System Admin wrote:
> with telnetd under BSD a while back, because I thought firing up inetd for a 
> single daemon was silly.

Why do you think that it is silly?

Do you understand what inetd actually does?  It is actually more efficient 
to use inetd than it is to have standalone network server daemons.

-- Mark --

---

From: "Dan Mahoney, System Admin" <[email-masked]>
Date: Fri, 12 Aug 2005 05:40:18 -0400 (EDT)

> Why do you think that it is silly?

Past tense.  Thought.  Long since educated I have been :)

--

"Be happy.  Try not to hurt each other.  Hope you fall in love."

--Mallory, Family Ties Finale (on the meaning of life)

---

From: Josh Marquis <[email-masked]>
Date: Fri, 12 Aug 2005 08:17:25 -0700

Wow, active community.  Thanks for all the replies everyone.  Answered my
question and did so very quickly!

Thanks again,

Josh

Quoting Mark Crispin <[email-masked]>:

> Nor does it make any sense to change do so.  Each imapd session has 
> to run in its own process, since it setuids itself to the user that 
> logs in via IMAP.  If imapd ran as a standalone server, it would 
> actually consume an
> Standalone daemons only make sense if the daemon needs to be 
> continously running doing something other than being a server (such 
> as sendmail, which must also maintain mail queues and deliver mail), 
> or if the task of the daemon is ameniable to being threaded.
>
> -- Mark --
>