Subject: Subject sorting bug

From: Timo Sirainen <[email-masked]>
Date: Fri, 03 Oct 2003 19:24:43 +0300

Uppercased "FW" wasn't stripped when comparing subjects:

--- mail.c.old  2003-10-03 19:10:38.000000000 +0300
+++ mail.c      2003-10-03 19:10:55.000000000 +0300
@@ -4117,7 +4117,7 @@
        else t = NIL;           /* found subj-middle */
        break;
       case 'f': case 'F':      /* possible "fw" or "fwd" */
-       if (((s[1] == 'w') || (s[1] == 'w')) &&
+       if (((s[1] == 'W') || (s[1] == 'w')) &&
            (((s[2] == 'd') || (s[2] == 'D')) ?
             (t = mail_strip_subject_wsp (s + 3)) :
             (t = mail_strip_subject_wsp (s + 2))) &&

-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Fri, 3 Oct 2003 10:04:30 -0700 (PDT)

Thanks.  Don't know how I missed that one.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.