Subject: [Imap-uw] mh mailboxes

From: "J. A. Landamore" <[email-masked]>
Date: Mon, 17 Oct 2005 13:28:51 +0100 (BST)

I need to convert a lot of mh format mailboxes to mbx.  The FAQ uses the 
old mbxcvt which has been replaced by mailutil.  Before I rebuild imap with 
the mh drivers included can I just check that:

mailutil move \#driver.mh/path/to/folders \#driver.mbx/path/to/new/folder

will work

Thanks

John Landamore

School of Mathematics & Computer Science
University of Leicester
University Road, LEICESTER, LE1 7RH
[email-masked]
Phone: +44 (0)116 2523410       Fax: +44 (0)116 2523604

_______________________________________________
Imap-uw mailing list
[email-masked]
https://mailman1.u.washington.edu/mailman/listinfo/imap-uw

---

From: Mark Crispin <[email-masked]>
Date: Mon, 17 Oct 2005 07:51:05 -0700 (PDT)

> mailutil move \#driver.mh/path/to/folders \#driver.mbx/path/to/new/folder

Like mbxcvt, "mailutil move" only operates on single mailboxes.  To 
convert a hierarchy, you need "mailutil transfer".  Also, the #driver 
syntax is only for creating mailboxes, but you do need #mh for mh files. 
Finally, note that the destination in "mailutil transfer" is a prefix 
applied to the source name, e.g., if you have
 	mailutil transfer foo #driver.mbx/bar/
the destination is written in "bar/foo".

Hence, you need something like:
 	mailutil transfer #mh/path/to/folders #driver.mbx/path/to/new/
Or if your script requires it:
 	mailutil transfer \#mh/path/to/folders \#driver.mbx/path/to/new

Most people use "mailutil copy" and have their script do the wildcarding.

-- Mark --

http://panda.com/mrc
Democracy is two wolves and a sheep deciding what to eat for lunch.
Liberty is a well-armed sheep contesting the vote.
_______________________________________________
Imap-uw mailing list
[email-masked]
https://mailman1.u.washington.edu/mailman/listinfo/imap-uw