Subject: Bogus criteria list in UID SEARCH

From: Friedrich Lobenstock <[email-masked]>
Date: Wed, 28 Mar 2001 16:12:52 +0200

I'm having the a problem with UID SEARCH and German umlauts.
Here's what Netscape-Mail sent to the server(imap-2000c) and
the servers responses:

22 uid SEARCH CHARSET iso-8859-1 UNDELETED BODY "gewünscht"
22 BAD Bogus criteria list in UID SEARCH

now without umlaut(äÄöÖüÜß):
23 uid SEARCH UNDELETED BODY "nscht"
* SEARCH 3 37 44 46 49 50
23 OK UID SEARCH completed   

Does imap-2000c only support 7Bit Ascii searching?
Is this fixed in imap-2001?

TIA for your help.

-- 
MfG / Regards
Friedrich Lobenstock
-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Wed, 28 Mar 2001 12:51:32 -0800 (PST)

On Wed, 28 Mar 2001 16:12:52 +0200, Friedrich Lobenstock wrote:
> 22 uid SEARCH CHARSET iso-8859-1 UNDELETED BODY "gew|nscht"

It's a bug in Netscape mail.  The IMAP specification is quite clear that 8-bit
text must be transmitted using literal syntax instead of quoted strings.

Report it to Netscape.  I don't think that they support that program any more
(there are many other bugs in it which have gone unfixed), so maybe you should
consider using a different client which is less buggy and more supported.

---

From: Friedrich Lobenstock <[email-masked]>
Date: Thu, 29 Mar 2001 01:57:57 +0200 (CEST)

On Wed, 28 Mar 2001, Mark Crispin wrote:
> ... so maybe you should consider using a different client which is less
> buggy and more supported.

Sorry to ask so stupid, but which client(Linux, optional Windows) is
best for use with WU-IMAP server? I've tried Mullbery once but I'm not
very satisfied with it. So what else is out there that you would
recommend?.

-- 
MfG / Regards
Friedrich Lobenstock

---

From: Mark Crispin <[email-masked]>
Date: Wed, 28 Mar 2001 15:59:30 -0800 (PST)

> very satisfied with it. So what else is out there that you would

Pine is an excellent client, although its current support of non-English
characters is somewhat limited.  But it should work alright for German.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.

---

From: Friedrich Lobenstock <[email-masked]>
Date: Thu, 29 Mar 2001 02:04:31 +0200 (CEST)

> characters is somewhat limited.  But it should work alright for German.

Yes, Pine. But that's not really satisfying too - if you know what I'm
talking about. It's best to use via ssh from remote but not on the
desktop of my Athlon.

-- 
MfG / Regards
Friedrich Lobenstock

---

From: Mark Crispin <[email-masked]>
Date: Wed, 28 Mar 2001 16:04:52 -0800 (PST)

> talking about. It's best to use via ssh from remote but not on the

Have you tried PC Pine?

---

From: "Nerijus Baliunas" <[email-masked]>
Date: Thu, 29 Mar 2001 18:08:21 +0200

> very satisfied with it. So what else is out there that you would

http://mahogany.sourceforge.net . It uses c-client, so it really should
work with wu-imapd ;)

---

From: Igor Pruchanskiy <[email-masked]>
Date: Thu, 29 Mar 2001 08:09:28 -0800

"All mail clients suck. This one just sucks less."
It's name is Mutt http://www.mutt.org
It has more features then M$ Outlook.