Subject: IMAP Connection: LOGIN is on two lines

From: Brandon Knitter <[email-masked]>
Date: Sat, 30 Mar 2002 10:11:50 -0800

I recently installed PHP (4.1.2) with IMAP support using UWASH's c-client
library on a Solaris machine without issue.  When I did the same on Linux I
could not login to my IMAP server.  Snooping the connection on the IMAP server
resulted in the following:

#
strings /tmp/snoop.log
snoop
&H);
e* OK binge Cyrus IMAP4 v1.5.19 server ready
Ywv00000000 CAPABILITY
&HTI
* CAPABILITY IMAP4 IMAP4rev1 ACL QUOTA LITERAL+ NAMESPACE UIDPLUS
X-NON-HIERARCHICAL-RENAME NO_ATOMIC_RENAME UNSELECT
00000000 OK Completed
00000001 LOGIN "
" ********
00000001 NO Invalid user
00000002 LOGIN "
" ********
00000002 NO Invalid user
00000003 LOGIN "
" ********
00000003 NO Invalid user
00000004 LOGOUT
* BYE LOGOUT received
00000004 OK Completed
&HRx
# 

(I have replaced my password with "*".

The odd part is that the LOGIN is on two lines.  I have echo'd out the
information send to the imap_open command in the script I'm using and all is
well, as a matter of fact, the username is correct in the script, but as you can
see above, it's blank (replaced by a CR or CRLF).

Any help would be greatly appreciated.

Thanks,

-- 
-bk

---

From: Brandon Knitter <[email-masked]>
Date: Sat, 30 Mar 2002 10:14:09 -0800