Subject: [Imap-uw] ipop3d lock time

From: "Kosty" <[email-masked]>
Date: Thu, 20 Oct 2005 21:11:50 -0300

Hi.
Could you tell me, please, what is the default lock time period of ipop3d process for any mailbox wich was closed without logout?
And another question is, if there is a posibility to change that time after or during the instalation of imap packet?

Thanks.
Constantino

_______________________________________________
Imap-uw mailing list
[email-masked]
https://mailman1.u.washington.edu/mailman/listinfo/imap-uw

---

From: Mark Crispin <[email-masked]>
Date: Thu, 20 Oct 2005 17:15:02 -0700 (Pacific Daylight Time)

On Thu, 20 Oct 2005, Kosty wrote:
> Could you tell me, please, what is the default lock time period of 
> ipop3d process for any mailbox wich was closed without logout? And 
> another question is, if there is a posibility to change that time after 
> or during the instalation of imap packet?

POP3 mailboxes are unlocked and closed after 10 minutes of inactivity. 
This value can not be changed to a lower value without violating the POP3 
specification.

After 5 minutes of inactivity, it is possible to open a new POP3 session 
and force the inactive session to unlock and close.  This value can not be 
changed to a lower value without running the risk that a "check for new 
mail" background task will cause an interrupt and termination of a long 
download.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.
_______________________________________________
Imap-uw mailing list
[email-masked]
https://mailman1.u.washington.edu/mailman/listinfo/imap-uw

---

From: "Kosty" <[email-masked]>
Date: Thu, 20 Oct 2005 21:29:03 -0300

Mark, thnaks a lot for such a fast reply!!!

The fact is that I need to lower that time because of my users that comlaine
to have problem of mailbox locking.
Is it posible to change some part of the sorce code of the IMAP package to
lower the default time of ipop3d locking for 5 minutes and if so what is
this part of the code?

Thak you for your help!
Constantino

----- Original Message ----- 
From: "Mark Crispin" <[email-masked]>
To: "Kosty" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, October 20, 2005 9:15 PM
Subject: Re: [Imap-uw] ipop3d lock time

> -- 
> No virus found in this incoming message.
> Checked by AVG Anti-Virus.
> Version: 7.0.344 / Virus Database: 267.12.4/143 - Release Date: 19/10/2005
>
>

---

From: Mark Crispin <[email-masked]>
Date: Thu, 20 Oct 2005 17:29:31 -0700 (Pacific Daylight Time)

> lower the default time of ipop3d locking for 5 minutes and if so what is

Even if you did that, that would not help your users' problem.  They can 
already get a new session after 5 minutes.

-- Mark --

---

From: "Kosty" <[email-masked]>
Date: Thu, 20 Oct 2005 21:42:22 -0300

Yes, you are right. It is the problem of the connectivity of users but my
boss wants it...

I think I'v found where is the place for changing that time period, tell me
please if I'm mistaken.

The file is imap-2004g/src/ipopd, and constants are KODTIMEOUT and TIEMOUT.
Is that correct?

Thanks again.
Constantino

---

From: Mark Crispin <[email-masked]>
Date: Thu, 20 Oct 2005 17:42:31 -0700 (Pacific Daylight Time)

> The file is imap-2004g/src/ipopd, and constants are KODTIMEOUT and TIEMOUT.

The only one you should change is KODTIMEOUT, not TIMEOUT.

-- Mark --

---

From: "Kosty" <[email-masked]>
Date: Thu, 20 Oct 2005 21:53:22 -0300

OK,
Thanks, Mark.