Subject: Imapd not listening

From: thomas nehaus <[email-masked]>
Date: Fri, 31 May 2002 02:36:59 -0700 (PDT)

Hi,

I build imapd on solaris with gcc (gso in Makefile). the resulting imapd does not listen on any port. I get this when I run imapd:

 ./imapd
* OK [CAPABILITY IMAP4REV1 LOGIN-REFERRALS AUTH=LOGIN] abc.def.edu IMAP4rev1 2001.315 at Fri, 31 May 2002 05:30:19 -0400 (EDT)

Furthermore, if i run it with an & as ./imapd& i get a 'stopped' message on the prompt.

imapd does not start from inetd though I have a valid entries in inetd.conf and /etc/services:

imaps   stream  tcp     nowait  root    /usr/local/bin/imapd    imapd

imap        143/tcp     imap2 

also if i leave it running on the foreground, it auto-logs out in a short while and i see this in syslog:

... [ID 957645 mail.info] Autologout user=??? host=UNKNOWN

I don't know why it says host=UNKNOWN here.

I use shadow passwords and nis.

I have also downloaded the prcompiled binary for solaris and checked with that. I get the exact same results and symptoms.

Can someone help?

--tom

---------------------------------
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup

---

From: Friedrich Lobenstock <[email-masked]>
Date: Fri, 31 May 2002 19:41:46 +0200

> imaps   stream  tcp     nowait  root    /usr/local/bin/imapd    imapd

Try this in /etc/inetd.conf
imap    stream  tcp     nowait.200      root    /usr/sbin/tcpd  imapd

or
imap    stream  tcp     nowait.200      root    /usr/local/bin/imapd  imapd

-- 
MfG / Regards
Friedrich Lobenstock