Subject: error IMAPD with openssl on solaris

From: Calvin Liu <[email-masked]>
Date: Wed, 26 Mar 2003 16:00:34 +0800

Hi,
I downloaded imap.tar.Z from
ftp://ftp.cac.washington.edu/imap/imap.tar.Z and built it with openssl
0.9.6 on my sparc/sol8.

It doesn't work, always reports:
bash-2.03$ telnet hockey 993
ld.so.1: ./imapd: fatal: relocation error: file ./imapd: symbol
__register_frame_info: referenced symbol not found
Killed

While ldd shows all libs are present:
bash-2.03$ ldd imapd
libsocket.so.1 => /usr/lib/libsocket.so.1
libnsl.so.1 => /usr/lib/libnsl.so.1
libgen.so.1 => /usr/lib/libgen.so.1
libssl.so.0.9.6 => /usr/local/lib/libssl.so.0.9.6
libcrypto.so.0.9.6 => /usr/local/lib/libcrypto.so.0.9.6
libc.so.1 => /usr/lib/libc.so.1
libdl.so.1 => /usr/lib/libdl.so.1
libmp.so.2 => /usr/lib/libmp.so.2
/usr/platform/SUNW,Sun-Blade-100/lib/libc_psr.so.1
bash-2.03$

What's wrong?
Thanks!

Calvin

---

From: Calvin Liu <[email-masked]>
Date: 26 Mar 2003 19:30:46 +0800

I think I got the answer. My UWIMAP is built with gcc-2.95.3 while the
OpenSSL is a binary package downloaded from sunfreeware.com so it should
be built with gcc-some-version, other than 2.95.3.

I built a brand new OpenSSL 0.9.7a with UWIMAP and this error is
disappeard. :)

But there is still problem! The SSL negotiation always fail, like this,
-- begin quote --
bash-2.03# telnet hockey 993
Trying 129.158.217.58...
Connected to hockey (129.158.217.58).
Escape character is '^]'.
a login mailer1 mailer1
Connection closed by foreign host.
-- end quote --

While another mail server is successful.
-- begin quote --
bash-2.03# telnet corrida 993
Trying 129.158.217.52...
Connected to corrida (129.158.217.52).
Escape character is '^]'.
a login mailer1 mailer1
* BYE Fatal error: tls_start_servertls() failed
Connection closed by foreign host.
-- end quote --

Any idea? Thanks.

Calvin

---

From: Calvin Liu <[email-masked]>
Date: 26 Mar 2003 19:41:35 +0800

My test approach is incorrect. Should be:
$openssl s_client -host hockey -port 993
That's ok.

But use a mail client such as Evolution, it failed. Why?

Calvin