Subject: Using sendmail with tmail (MBX format)

From: Andrew Daviel <[email-masked]>
Date: Wed, 10 May 2000 14:55:44 -0700 (PDT)

I hear that MBX format mailboxes as supported by UW imapd
are more efficient than Unix mailboxes as directly supported by procmail.
It would be nice to speed up our mail server.

When I try to use "tmail" as a local delievery agent e.g.
Mlocal          P=/usr/sbin/tmail, F=lsDFMAw5:/|@qSPfhn9, S=10/30,
                R=20/40, T=DNS/RFC822/X-Unix,
                A=tmail $u

I get an error "unknown switch" (sendmail 8.9.3)
It seems that sendmail is passing "-f $f" to tmail before
the arguments given in Mlocal. "-f" is unsupported in tmail 4.1(11).

I made things work by copying the lines in tmail.c which handle
"-r", so that tmail generates a "Resent-From" header.
Is this legitimate, should I just drop the -f arguments altogether,
or what ?

Andrew Daviel
TRIUMF

-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Steve Hubert <[email-masked]>
Date: Wed, 10 May 2000 15:13:21 -0700 (PDT)

Yes, drop the 'f' flag out of the F= list.

-- 
Steve Hubert <[email-masked]>
Networks and Distributed Computing, Univ. of Washington, Seattle

---

From: Mark Crispin <[email-masked]>
Date: Wed, 10 May 2000 15:24:55 -0700 (PDT)

> Is this legitimate, should I just drop the -f arguments altogether,

What, precisely, is the meaning of the -f switch?

---

From: Andrew Daviel <[email-masked]>
Date: Wed, 10 May 2000 16:49:32 -0700 (PDT)

> What, precisely, is the meaning of the -f switch?

Thanks to Steve's reply, I have looked in the sendmail docs and found,
that for the M rules (e.g. Mlocal), the F flags include

f - mailer requires an "-f from" flag
r - same as f but use "-r"
P - mailer requires a Return-Path header
etc. etc.

I was using the sendmail.cf that comes with RedHat 6.1, I think,
which had f set in Mlocal as I wrote, and uses procmail.

The procmail manpage says
 -f fromwhom
  Causes procmail to regenerate  the  leading  `From  '
  line  with  fromwhom as the sender (instead of -f one
  could  use  the  alternate  and  obsolete  -r).

regards

Andrew

---

From: Mark Crispin <[email-masked]>
Date: Wed, 10 May 2000 17:26:16 -0700 (PDT)

OK, I will make -f be the same as -r in the next version of tmail and dmail.
Thank you for the information.