Subject: using mtest to understand c-client

From: Andrew Biggs <[email-masked]>
Date: Mon, 6 Dec 2004 08:29:10 -0800 (PST)

I'm just getting started using c-client, and was
trying to use mtest to talk to an IMAP server on
another box.  Looking at the code, it's not real clear
to me how to specify the remote address, username,
password, etc.  I didn't see any readme's, FAQ's, or
howto's specifically related to this.  I have been
looking at the API guide for c-client, which is good,
but I haven't seen where it covers login. Any
suggestions, or pointers to docs I could look at? 

Thanks!

-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: "Tomas Pospisek's Mailing Lists" <[email-masked]>
Date: Mon, 6 Dec 2004 17:41:57 +0100 (CET)

> suggestions, or pointers to docs I could look at?

You can go to mailsync.sf.net, click through to the sourceforge interface, 
there to the webcvs and look into the examples directory. The c-client 
docu gives you the precise syntax.
*t

--
-----------------------------------------------------------
   Tomas Pospisek
   http://sourcepole.com -  Linux & Open Source Solutions
-----------------------------------------------------------

---

From: "Jim" <[email-masked]>
Date: Mon, 6 Dec 2004 17:22:31 -0000

Has anyone yet been able to compile c-client or imap-2004a on Solaris 10
SPARC ?
on a 'make gso' I keep encountering
 osdep.h:64 error: conflicting types for `scandir'
/usr/include/dirent.h:92 error: previous decleration of `scandir'
***Error code 1
make: Fatal error: Command failed for target `osdep.o'

not being a coder in any sense of the word I'm at a loss to sort this one so
any pointers would be appreciated

Thanks
Jim
---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.805 / Virus Database: 547 - Release Date: 03/12/2004

---

From: Mark Crispin <[email-masked]>
Date: Mon, 6 Dec 2004 09:32:52 -0800 (PST)

> Has anyone yet been able to compile c-client or imap-2004a on Solaris 10

It's fixed in the imap-2004b development snapshot.
 	ftp://ftp.cac.washington.edu/mail/imap-2004b.DEV.tar.Z

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.

---

From: "Jim" <[email-masked]>
Date: Mon, 6 Dec 2004 18:35:56 -0000

Just to confirm, that gives me a clean build with no problems I just have to
sort SSL out and rebuild
Thanks very much Mark

Jim

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Mark Crispin
Sent: 06 December 2004 17:33
To: Jim
Cc: [email-masked]
Subject: Re: c-client on Solaris 10 SPARC

-- Mark --

---
Incoming mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.805 / Virus Database: 547 - Release Date: 03/12/2004

---