Subject: Re: Problems with simultaneous IMAP connection

From: "Guillaume Vaillant" <[email-masked]>
Date: Thu, 9 Oct 2003 14:19:07 +0200

Hello,

This problem occurs only on the RedHat Linux 7.3.
I have also the same tools on RedHat Linux 6.2 and it works fine.

Can you tell me which version of c-client should I use for RedHat Linux 7.3
?

Thanks for your help
Guyom

----- Original Message -----
From: "Guillaume Vaillant" <[email-masked]>
To: <[email-masked]>; "Mark Crispin" <[email-masked]>
Sent: Thursday, October 09, 2003 10:06 AM
Subject: Problems with simultaneous IMAP connection

> Hello,
>
> I'm trying to use the c-client library to perform some IMAP requests
> My tools needs to establish simultaneously more than one IMAP connections
to
> the IMAP server.
> To do that I'm calling the MAILSTREAM *mail_open (MAILSTREAM
*oldstream,char
> *name,long options) for each connection.
> The result is strange. I have a big time before the connection answer.
>
> If i make some network traces i can see that this function
>     - connect to the server
>     - request server capabilities
>     - And request login
>
> But the request login step is done after a long time.
> Time 0 ms : My tools connect to server on port 143
> Time + 2 ms : Server reply OK + ready
> Time + 2 ms : My tools request capabilities
> Time + 3 ms : Server return capabilities
> .... During this time other connection to the imap server was done but
each
> connection are blocked after Server return capabilities
> Time + 4000 ms : My tools request login
>
> Why the request login is so long ?
>
> Thanks for your help
> Guyom
>
>
>
> ----- Original Message -----
> From: "Harondel J. Sibble" <[email-masked]>
> To: "Mark Crispin" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Monday, October 06, 2003 10:39 PM
> Subject: Re: problems with large imap folder/file
>
>
> >
> >
> > On 6 Oct 2003 at 13:26, Mark Crispin wrote:
> > > There are no calls to fs_resize() in the mbx driver expunge.
Something
> > > else is going on.  I would like to know what that is.
> >
> > Heh, me too. Something else is going on indeed, just called the client
> back
> > and it's working fine now, while 1 hour ago it wasn't  <shrug> and the
> hour
> > before that it worked fine for me.
> >
> > Actually that concerns me more than it not working at all.
> >
> > > Well, you can tell your client that this "someone they don't know" is
> the
> > > author of the imapd software that your client is giving root-level
> access.
> >
> > I've explained that to them, we are going to leave it and see if it
> continues
> > to work okay. If not, then I'll contact you about remote access.  In
that
> > case can you send me a pgp signed/encrypted email with phone contact
info?
> > That way I can pass you login info directly.
> >
> > --
> > Harondel J. Sibble
> > Sibble Computer Consulting
> > Creating solutions for the small business and home computer user.
> > [email-masked] (use pgp keyid 0x3AD5C11D) http://www.pdscc.com
> > (604) 739-3709 (voice/fax)      (604) 686-2253 (pager)
> >
>

---

From: "Guillaume Vaillant" <[email-masked]>
Date: Thu, 9 Oct 2003 18:59:01 +0200

Hello,

I have found my problem. It comes from the DNS.
The c-client mail_open function try to use the DNS. I should add the entry
in the /etc/hosts and now the request is faster.

Does someone know how to deactivate the dns request ?

Thanks for your help
Guyom
----- Original Message -----
From: "Guillaume Vaillant" <[email-masked]>
To: "Guillaume Vaillant" <[email-masked]>;
<[email-masked]>; "Mark Crispin" <[email-masked]>
Sent: Thursday, October 09, 2003 2:19 PM
Subject: Re: Problems with simultaneous IMAP connection