Subject: Support for UIDPLUS extension?

From: Andrew Biggs <[email-masked]>
Date: Fri, 17 Dec 2004 07:22:50 -0800 (PST)

I have a message server that supports the UIDPLUS
extension, and I'd like to be able to invoke the UID
EXPUNGE command using c-client.  I didn't see anything
in the API doc which looked like it would do this.  Is
this an extension I should develop myself, or did I
just not look hard enough?  

Thanks!
Andrew
-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Fri, 17 Dec 2004 17:38:43 -0800 (Pacific Standard Time)

It would not be very difficult to implement UIDPLUS in the IMAP client 
code, especially just UID EXPUNGE.  However, it is quite difficult to 
implement UIDPLUS in c-client in general -- in particular, for non-IMAP 
mail stores.

UIDPLUS may happen in the future, but I can't predict "when" just now.

> just not look hard enough?

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.