Subject: Fw: PHP with IMAP

From: "Ana Paula Sabelli" <[email-masked]>
Date: Tue, 6 Aug 2002 18:05:38 -0300

Hello, this is my first message to the list. I have a Linux 6.2  with kernel 2.2.14-5.0.
I have installed IMAP-2002.RC2 and PHP 4.2.2
I configured PHP like this:
./configure --with-mysql --with-apxs=/usr/local/apache/bin/apxs --with-gettext --with-xml --with-mcrypt=/usr/local --with-imap --with-kerberos

when I restart the Apache 1.3.26, it doesn´t work.
The error is: " Cannot load /usr/local/apache/libexec/libphp4.so into server:
                    /usr/local/apache/libexec/libphp4.so: undefined symbol: imap_setacl"

Can you help me?

TIA

---

From: "Jeff Breitner" <[email-masked]>
Date: Thu, 8 Aug 2002 11:47:27 -0400

Try this method:
 
http://www.php.net/manual/en/ref.imap.php
 
Pay particular attention to the part about copying the header files both
in the primary documentation and the user comments.  You may find more
relevant information in the user comments, especially the part about
copying *.h from src/c-client into /usr/local/include (or wher ever they
say to put it).
 
Keep in mind that this is *not* a c-client problem, it's a PHP
compilation problem.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Ana Paula Sabelli
Sent: Tuesday, August 06, 2002 5:06 PM
To: [email-masked]
Subject: Fw: PHP with IMAP

Hello, this is my first message to the list. I have a Linux 6.2  with
kernel 2.2.14-5.0.
I have installed IMAP-2002.RC2 and PHP 4.2.2
I configured PHP like this:
./configure --with-mysql --with-apxs=/usr/local/apache/bin/apxs
--with-gettext --with-xml --with-mcrypt=/usr/local --with-imap
--with-kerberos
 
when I restart the Apache 1.3.26, it doesn´t work.
The error is: " Cannot load /usr/local/apache/libexec/libphp4.so into
server:
                    /usr/local/apache/libexec/libphp4.so: undefined
symbol: imap_setacl"

Can you help me?
 
TIA