Subject: OK, port 993 is OK -- but not with xinetd...

From: [email-masked] (Alexy Khrabrov)
Date: Wed, 14 Aug 2002 17:57:17 -0400

OK, seems I've finally found the problem why ports
143 and 993 were behaving the same for me, so I
could telnet to 993 and get text capabilities and
such, just like on 143.  I was running under
xinetd.  Mind you, I don't see any tcp-wrappers
hookups there, that's the default SuSE xinetd.

Instead of that, I downloaded DJB's tcpserver from
http://cr.yp.to/, and run two daemons on
appropriate ports.  Under tcpserver, everything is
fine -- telnetting to 993 shows nothing, fetchmail
--ssl works like a charm, etc.  Even PHP works
with port 993/imap/ssl/novalidate-cert.  Eureka!
Except, tcpserver computes paths relative to the
executable, so I had to make a symlink in
/usr/local/ssl->/usr, and place imapd.pem into
/usr/local/sbin.  Convoluted, but works...

Mark: please make a note in the docs about xinetd,
it took me a few days and a couple of maillists to
get it right.  Thanks to Steve Barber, not getting
any text on 993 was a cluebat.

Cheers,
Alexy
-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Sebastian Hagedorn <[email-masked]>
Date: Thu, 15 Aug 2002 09:33:27 +0200

--On Wednesday, August 14, 2002 17:57:17 -0400 Alexy Khrabrov 
<[email-masked]> wrote:

> get it right.

While it may not be the specific information you mean there's already 
something in the FAQ for 2002.RC2, also available here:

http://www.washington.edu/imap/IMAP-FAQs/index.html

Did you read that?

Greetings, Sebastian
--
Sebastian Hagedorn
Ehrenfeldgürtel 156
50823 Köln
http://www.spinfo.uni-koeln.de/~hgd/

Being just contaminates the void - Robyn Hitchcock