Subject: IMAP and mh : why read only?

From: John Caron <[email-masked]>
Date: Mon, 14 Aug 2000 15:37:34 -0600

It seems that our c-client (4.7c) IMAP server cannot set flags on MH
messages. (I am accessing it through a client built with the JavaMail
1.3 library). 

The messaging looks like:

A0 CAPABILITY
* CAPABILITY IMAP4 IMAP4REV1 NAMESPACE IDLE SCAN SORT MAILBOX-REFERRALS
LOGIN-REFERRALS AUTH=LOGIN THREAD=ORDEREDSUBJECT
A0 OK CAPABILITY completed
A1 AUTHENTICATE LOGIN
<deleted>
A1 OK AUTHENTICATE completed
A2 SELECT #MHINBOX
* 14 EXISTS
* 0 RECENT
* OK [UIDVALIDITY 966280533] UID validity status
* OK [UIDNEXT 25] Predicted next UID
* NO [UIDNOTSTICKY] Non-permanent unique identifiers: #MHINBOX
* FLAGS (\Answered \Flagged \Deleted \Draft \Seen)
* OK [PERMANENTFLAGS ()] Permanent flags
* OK [UNSEEN 7] first unseen message in #MHINBOX
A2 OK [READ-WRITE] SELECT completed
A3 STORE 11 +FLAGS (\Deleted)
* 11 FETCH (FLAGS (\Seen \Deleted))
A3 OK STORE completed
A5 LOGOUT
* BYE laraine.unidata.ucar.edu IMAP4rev1 server terminating connection

1) I conclude that it is an IMAP problem due to the line
	* OK [PERMANENTFLAGS ()] Permanent flags
which I understand means "cant store any flags".

2) if so, is there a trick to getting c-client to set flags on mh
messages? (this works ok when i access mbox type files).
-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Mon, 14 Aug 2000 15:09:55 -0700 (PDT)

The mh format does not support permanent flags.  This is a restriction of the
mh format, which lacks the c-client/IMAP concept of flags.