Subject: Linux, local news, c-client

From: Pavel Zhukoff <[email-masked]>
Date: Sun, 12 Mar 2000 12:20:01 +0400 (KSK)

Hi, all.
Excuse for bad English.

I had problems with interaction of the c-client and local news spool.

My system: Linux, libc-5.3.12, uw_imap-4.7a, pine-4.21.

Pine subscribes for local newsgroups without problem. But at attempt to
open local newsgroup (for example #news.local.talks) by a choise its name
from the list of subscribed groups - Pine crash with message:

              [Opening "local.talks"   ]

Problem detected: "Received abort signal".
Pine exiting.
IOT trap/Abort (core dumped)

Debug file (with -d 5) contains the following lines:

About to open folder "local.talks"    inbox: "INBOX"
Close - saved inbox state: max 0
=== mm_exists(3,#news.local.talks) called ===
end_signals(1)
auger_in_signal()
about to end_tty_driver
end_signals(1)
Pine Panic: Received abort signal

Is similar, if I try to attempt local news (#news.local.talks - valid
group) through imapd, imapd terminated. Pine (and mtest) generate message:

[CLOSED] IMAP connection broken (server response).

During compilation of the c-client there were following error messages:
news.c: In function `news_open':
news.c:345: warning: passing arg 3 of `scandir' from incompatible pointer type
news.c:345: warning: passing arg 4 of `scandir' from incompatible pointer type

And some more:
mh.c: In function `mh_ping':
mh.c:655: warning: passing arg 3 of `scandir' from incompatible pointer type
mh.c:655: warning: passing arg 4 of `scandir' from incompatible pointer type
mh.c: In function `mh_append':
mh.c:920: warning: passing arg 3 of `scandir' from incompatible pointer type
mh.c:920: warning: passing arg 4 of `scandir' from incompatible pointer type
mx.c: In function `mx_ping':
mx.c:589: warning: passing arg 3 of `scandir' from incompatible pointer type
mx.c:589: warning: passing arg 4 of `scandir' from incompatible pointer type

Is there problem with my libc? Somebody collided with similar problems?

Thank for your attention.

-- 
Pavel Zhukoff
[email-masked]
Samara, Russia

-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Sun, 12 Mar 2000 17:59:57 -0800 (PST)

The compiler warning mesasges ("passing arg 3 of `scandir' from incompatible
pointer type") are unimportant.  The pointer types actually are compatible in
this particular instance; but the compiler can't know that (because in other
instances, with the same types, it would not be).  The reason why this happens
is that different operating systems use different types in scandir(); so some
system's compiler will be unhappy.

What is important is the crash.  See if this patch will fix it.

In imap-4.7a/src/osdep/unix/news.c, line 358, change
    s = (void *) &names;	/* stupid language */
to:
    s = (void *) names;		/* stupid language */

Substitute the pine4.21/imap directory tree with the imap-4.7a tree, and
rebuild both Pine and imapd.

You probably should obtain imap-4.7b:
	ftp://ftp.cac.washington.edu/mail/imap.tar.Z
since it has a couple of other fixes over imap-4.7a.  4.7a and 4.7a are patch
releases to 4.7.

---

From: Pavel Zhukoff <[email-masked]>
Date: Mon, 13 Mar 2000 20:21:19 +0400 (KSK)

>     s = (void *) names;	/* stupid language */

Now all works fine. Thanks, Mark.
 
-- 
Pavel Zhukoff
[email-masked]
Samara, Russia