Subject: Malformed To:-Header Problems

From: [email-masked]
Date: Wed, 2 Jul 2003 16:01:08 -0700 (PDT)

Hi!

We use horde/imp as webmail. One of our users received a message with
a malformed To:-Header like this:

------
To: "[email-masked],[email-masked],
     [email-masked],...
     ...
     ...
     ...
     ...
     ...
     ...
     ...
     [email-masked], last.address"@uni-konstanz.de>

--

The result is that the mailbox-overview containing this message cannot
displayed. And the apache process dies with a segmentation fault.

I tracked down this problem to the ""-String which contained more than
1200 characters. Is this a known problem?
-- 
Jörg Friedrich
Wie man sein Kind nicht nennen sollte:
  Alma Nach

---

From: Mark Crispin <[email-masked]>
Date: Wed, 2 Jul 2003 16:06:06 -0700 (Pacific Daylight Time)

Where did you get the segfault?  Was it in c-client, or was it in
horde/imp?

You should be able to use gdb to analyze the core dump and do an "info
stack" command to get a stack trace.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.