Subject: cant login to uw-imap account

From: "andy" <[email-masked]>
Date: Sat, 10 Aug 2002 15:14:18 +0200

Hi there,

I just installed uw-imap and the installation was ok, since everything went fine and I could compile php with imap.

Now I am trying to login to this imap server via a client. Unfortunatelly it always tells me that the account info is wrong.
I tryed a adress like imap.server.com

Also I did include the adress I am comming from in hosts.allow and I am trying to get the email from  user account on the linux machine.

Is there something additional I have to do, configure, to use my new imap server?

Thanx for any hint on that.

Andy

---

From: <[email-masked]>
Date: Sun, 11 Aug 2002 17:13:16 -0400

First things first.

Unless you have a nameserver entry for imap.server.com, it won't work
regardless of whether or not you have a clean compile of PHP.  You need to use
the machine name, or better yet, just use the IP address of the machine since
your nameserver entries could be suspect.

If you really want to be creative, log into the machine and 'telnet localhost
143' and see what you get.  If you see an imap server response, you're in
business and the issue is probably calling the correct host.

If you do not see an imap server prompt, then your target machine does not have
the imap server properly installed.  Depending upon your OS, it's likely you're
going to have to edit /etc/inetd.conf and enable it.  If you're lucky enough to
be running something like Red Hat that uses xinetd, then you'll have to insert
a xinetd config file for imap service (lots of fun).

Good luck, hope this helps.

On 08.10.2002 at 09:09:22, andy <[email-masked]> wrote:

> Now I am trying to login to this imap server via a client. Unfortunatelly
> it always tells me that the account info is wrong.
> Also I did include the adress I am comming from in hosts.allow and I am
> trying to get the email from  user account on the linux machine.
>

---

From: "andy" <[email-masked]>
Date: Mon, 12 Aug 2002 12:07:01 +0200

thank you for the help.

I did a telnet localhost 143 and it did not respond. I am running suse7.2
and did already add this line to /et/inetd.conf:
imap  stream  tcp     nowait  root    /usr/local/imapd/imapd

but still does not work yet. Even worse all my email sent from the server
has now the name of my hosting provider @provider.info
and not my domain name. So I did screw something up!

Do you have an idea on how to proceed from this point?

Thanx in advance.

----- Original Message -----
From: <[email-masked]>
To: "andy" <[email-masked]>; <[email-masked]>
Sent: Sunday, August 11, 2002 11:13 PM
Subject: Re: cant login to uw-imap account

> > I just installed uw-imap and the installation was ok, since everything
went
> > fine and I could compile php with imap.
> >
> > Is there something additional I have to do, configure, to use my new
imap
> > server?

---

From: "Jeff Breitner" <[email-masked]>
Date: Mon, 12 Aug 2002 10:27:54 -0400

> I did a telnet localhost 143 and it did not respond. I am 
> running suse7.2 and did already add this line to /et/inetd.conf:
> but still does not work yet. Even worse all my email sent 
> from the server has now the name of my hosting provider 
> @provider.info and not my domain name. So I did screw something up!
> 

Fix the problem of not being able to see the imap server.  The c-client
IMAP makefile will not copy your imapd into the proper location on your
machine, so make sure you copy it into /usr/local/imapd/imapd.

I suspect that your Suse installation might have some firewalling
installed, but it seems strange that it's denying accesses on localhost.

Check your log files to see if inetd gives an indication why it's not
firing up imapd for you.