Subject: Thread implementation

From: Raul Dias <[email-masked]>
Date: Thu, 29 Nov 2001 06:20:28 -0300

Hi,

I need to know if the thread support in c-client is fully functional in imap-2001a (and
later).  During the latest releases I have seen a lot of change and I am looking for 
the place to correct it (in c-client or not).

Here are the thread result with the same code, same mailbox with different versions
of imap.

This first one is what I am expecting. The brackets indicates where a tree branch starts and
ends.  They are ordered by "reference" and the numbers indicates the uid of the message:

[
1430, 
	[ 
	1432 
	], 
375, 
501, 
1, 
	[ 
	2, 
		[ 
		3 
		] 
	],
4, 
5, 
	[ 
	6, 
		[ 
		7, 
			[ 
			12, 
				[ 
				15 
				] 
			] 
		] 
	],
8, 
	[ 
	9, 
		[ 
		10, 
			[ 
			11 
			] 
		] 
	],
13, 
14, 
	[ 
	16, 
		[ 
		17, 
			[ 
			18, 
				[ 
					19 
				] 
			] 
		] 
	], 
20, 
21,
]

This is what I got when compiled with imap-2001-RELEASE.CANDIDATE-1 :
 [
          26,
          27,
          24,
          25,
          [
            1,
            2,
            3,
            4
          ],
          5,
          6,
          7,
          12,
          15,
          8,
          9,
          10,
          11,
          13,
          14,
          16,
          17,
          18,
          19,
          20,
          21,
          22,
          23
        ]

Here is what I got with imap-2001a-RELEASE_CANDIDATE-2 :
(longer)

[
1430, 
1432, 
	[ 
	1432, 
		[ ] 
	], 
375, 
	[ ], 
501, 
	[ ], 
	[ 
	1, 
	2, 
	3, 
		[ 
		2, 
		3, 
			[ 
			3, 
				[ ] 
			] 
		],
	 4, 
		[ ] 
	], 
5, 
6, 
7, 
12, 
15, 
	[ 
	6, 
	7, 
	12, 
	15, 
		[ 
		7, 
		12, 
		15, 
			[ 
			12, 
			15, 
				[ 
				15, 
					[	] 
				] 
			] 
		] 
	],
 8, 
9, 
10, 
11, 
	[ 
	9, 
	10, 
	11, 
		[ 
		10, 
		11, 
			[ 
			11, 
				[ ] 
			] 
		] 
	],
 13, 
	[ ], 
14, 
16, 
17, 
18, 
19, 
	[ 
	16, 
	17, 
	18, 
	19, 
		[ 
		17, 
		18, 
		19, 
			[ 
			18, 
			19, 
				[ 
				19, 
					[ ] 
				] 
			] 
		] 
	], 
20, 
	[ ], 
21, 
	[ ],
]

Now, with imap-2001a-RC4 and imap-2001a-FINAL this is what I get:

	[
          1430,
          1432,
          375,
          501,
          1,
          2,
          3,
          4,
          5,
          6,
          7,
          15,
          12,
          8,
          10,
          9,
          11,
          13,
          16,
          17,
          18,
          14,
          19,
          20,
          21,
          22,
          23
        ]

As you see no thread generated (at all).

All this thread was generated with the same code, same mailbox.  The mailbox used is huge, 
so just the beggining was tested.
The only thing that has changed on every test is the imap-2001a version used.

I am not saying that the code used to produce this is not buggy.
However before start to hunt down the daemons in it I need a confirmation that the 
thread part of c-client is working perfectly since imap-2001a-final.
(or to know that it isn't).

Regards,
Raul Dias

-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Thu, 29 Nov 2001 11:28:25 -0800 (PST)

Yes, thread support is fully functional.

The data that you sent didn't make much sense though; it shows messages
appearing more than once which can't happen in references.  I think that it
would be better if you did your tests through imapd and reported what imapd
says in IMAP format.

Also, what mailbox format are you using?  Is it one of the standard drivers
provided by c-client?