Subject: examples for c-client

From: "Nedelcho Stanev" <[email-masked]>
Date: Thu, 23 Oct 2003 13:15:09 +0300

Hello ,

Does anybody can give a link to site with examples for c-client
i mean somewhere where i can read easy how to give mime message
to library and how to get content?
also, is there are some C++ wrapper for the library.
sorry for my questions, but i was looked on the web
and didn't find something usefull for beginners with library.
i know that i can look inside pine code but this is similar to openssl  :)
so may be some one can give some short example how
to do this ?

Best wishes,
decho

---

From: Mark Crispin <[email-masked]>
Date: Thu, 23 Oct 2003 07:00:40 -0700 (PDT)

> to library and how to get content?

Look at the mtest and mailutil programs which are bundled with c-client.
They are both relatively simple examples.  More advanced concepts are
found in imapd; then you can work up to looking at Pine... :-)

> also, is there are some C++ wrapper for the library.

The c-client.h file is supposed to be such a wrapper.  If you use gcc, you
may have to use -fno-operator-names in your compile command line.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.