Subject: forwarding a mail using c-clint

From: [email-masked]
Date: Wed, 11 Apr 2001 13:12:09 +0000

Hi!
I am using the c-client library and it is a great
fun to use it.I am having problems in forwarding 
my mails in the Inbox to a specified mail ID
,through my C program.
Can someone tell how to forward the mail with a
attachment using the c-client library.

ashis

Enjoy being an Indyan at http://www.indya.com
-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Wed, 11 Apr 2001 00:46:20 -0700 (PDT)

> attachment using the c-client library.

I recommend that you look at Pine's sending code to see how this is done.
Basically, you have to create a new message envelope and bodystructure, and
include the message being forwarded inside it as a MESSAGE/RFC822 part, with
text data from mail_fetchmessage() of the message you want to forward.