Subject: compile error

From: "Kowal, Michael" <[email-masked]>
Date: Tue, 1 Feb 2005 16:14:36 -0500

I'm trying to compile IMAP and I keep getting the following error:
imap-2004c1]# make slx
.
.
.
ln -s ip4_unix.c ip_unix.c
ln: `ip_unix.c': File exists
make[3]: *** [onceenv] Error 1
make[3]: Leaving directory `/usr/local/imap-2004c1/c-client'
make[2]: *** [slx] Error 2
make[2]: Leaving directory `/usr/local/imap-2004c1/c-client'
make[1]: *** [OSTYPE] Error 2
make[1]: Leaving directory `/usr/local/imap-2004c1'
make: *** [slx] Error 2

I've found that other users compiling this had no problem on fedora
(using the slx as machine type). I'm using fedora 3. I figured dovecot
was maybe conflicting, but I removed the dovecot package and same error
comes up. I try other OS types (lnx, lrh) and still nothing. Any ideas?

Thanks,
mike

---

From: Mark Crispin <[email-masked]>
Date: Tue, 1 Feb 2005 13:37:53 -0800 (Pacific Standard Time)

> ln: `ip_unix.c': File exists

ip_unix.c is a file that is made as part of the build.  It should not 
exist when the build is started.

Try doing a "make clean" and then try the build again.

If you got your copy from a third-party, try getting it directly from the 
UW distribution at:
 	ftp://ftp.cac.washington.edu/mail/imap.tar.Z

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.