Subject: [Imap-uw] imap-2004e compile problems

From: Nick Peters <[email-masked]>
Date: Thu, 04 Aug 2005 16:27:23 -0500

Hey,

I am trying to get php to have imap support (so i can run horde and
imp), so i guess that means that i need to install c-client. I am trying
to install onto a box running slackware 10. When i do a "make slx" i get
the following error:

osdep.c:238: storage size of `ssldriver' isn't known

I have tried a few other ports, like sl5 etc... I haven't been able to
find anything about this error message on google, and the docs that i
have found don't really go into the depth that i need to figure out this
problem. Has anybody ran into this before? Thanks for the help in advance.

-Nick
_______________________________________________
Imap-uw mailing list
[email-masked]
https://mailman1.u.washington.edu/mailman/listinfo/imap-uw

---

From: Mark Crispin <[email-masked]>
Date: Thu, 4 Aug 2005 14:36:11 -0700 (PDT)

> osdep.c:238: storage size of `ssldriver' isn't known

Is this the only error message that you get?

Or are there other error messages prior to this?

Do you have the OpenSSL development environment installed?

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.
_______________________________________________
Imap-uw mailing list
[email-masked]
https://mailman1.u.washington.edu/mailman/listinfo/imap-uw

---

From: Michael Russell <[email-masked]>
Date: Thu, 04 Aug 2005 17:54:35 -0400

I had a similar error (along with many others) using Fedora Core 2 until I
   update "src/osdep/unix/Makefile" like this:

       SSLDIR=/usr/local/ssl
         to:
       SSLDIR=/usr/share/ssl

       SSLINCLUDE=$(SSLDIR)/include
         to:
       SSLINCLUDE=/usr/include

       SSLLIB=$(SSLDIR)/lib
         to:
       SSLLIB=/usr/lib

Presuming you have OpenSSL installed, then your key directories likely don't 
match the Makefile defaults.
                                         Michael Russell
                                         [email-masked]
                                         MTI Film, LLC
                                         Providence, RI  02906  USA

                                         Tel: (401) 831-1315

---

From: Nick Peters <[email-masked]>
Date: Fri, 05 Aug 2005 09:06:57 -0500

I figured out what was going on, it was because uw-imap was looking in
the wrong place for openssl.

i simply did:

#make slx SSLINCLUDE=/usr/include/openssl/

that made it compile :-)

Thanks for the help.

Michael Russell wrote:

> Presuming you have OpenSSL installed, then your key directories likely
> don't match the Makefile defaults.
>                                         Michael Russell
>                                         [email-masked]
>                                         MTI Film, LLC
>                                         Providence, RI  02906  USA
>
>                                         Tel: (401) 831-1315
>
>
> Nick Peters wrote:
>
>> Hey,
>>