Subject: Problem with MBX INBOX

From: "Clive McDowell" <[email-masked]>
Date: Fri, 8 Apr 2005 12:13:52 +0100

Folks,

I have a strange problem with an MBX format INBOX. It contains 6618 messages but only the most recent 33 are being displayed by
PINE or any other clients I've tried. Connecting to the INBOX does not result in any error messages so I don't really have
anything to go on to make a manual repair. There doesn't appear to be a problem with the message immediately prior to the first
one being displayed. Any advice on how to proceed will be gratefully received.

Thanks,

 Clive McDowell

Information Services
The Queen's University of Belfast 

-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: [email-masked]
Date: Fri, 8 Apr 2005 06:31:05 -0500

The mbx file may be corrupt.  This is prevalent in clustered environments, but I
have seen it occasionally in non clustered environments.

Download the mbxuncorrupter at:
http://sourceforge.net/projects/mbxuncorrupter/

If it doesn't fix the problem, maybe it will shed some light on the real
problem.  You can also contact the developer of mbxuncorrupter for more help.

tc

Quoting Clive McDowell <[email-masked]>:

> Folks,
> 
> I have a strange problem with an MBX format INBOX. It contains 6618 messages
> but only the most recent 33 are being displayed by
> PINE or any other clients I've tried. Connecting to the INBOX does not result
> in any error messages so I don't really have
> anything to go on to make a manual repair. There doesn't appear to be a
> problem with the message immediately prior to the first

-------------------------------------------------
Email solutions, MS Exchange alternatives and extrication,
security services, systems integration.  
Contact:    [email-masked]

---

From: Mark Crispin <[email-masked]>
Date: Fri, 8 Apr 2005 10:23:26 -0700

On Fri, 8 Apr 2005, Clive McDowell wrote:
> I have a strange problem with an MBX format INBOX. It contains 6618 
> messages but only the most recent 33 are being displayed by PINE or any 
> other clients I've tried.

That means that the other 6585 messages were deleted and expunged in a 
shared session.  Those messages will be removed (and the space they occupy 
reclaimed) the next time an expunge or checkpoint is done in an exclusive 
session.

The power tool
 	ftp://ftp.cac.washington.edu/mail/powertool/unexpunge.c
can be used to turn off the expunge bits for those messages.  Feed the 
file to its stdin, and get the unexpunged version on stdout.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.

---

From: Clive McDowell <[email-masked]>
Date: Fri, 08 Apr 2005 20:30:19 +0100

Mark Crispin wrote:
>> messages but only the most recent 33 are being displayed by PINE or 
>> any other clients I've tried.
> 
> 
> shared session.  Those messages will be removed (and the space they 
> occupy reclaimed) the next time an expunge or checkpoint is done in an 
> exclusive session.

Mark,

thanks - that was exactly the problem. This user seems to have a habit 
of leaving several sessions open. I guess she hasn't run an exclusive 
session for a while. Once forced to do so the inbox space was recovered.

Clive McDowell