Subject: [Imap-uw] Compile Error on Red Hat

From: "Edward Duhe'" <[email-masked]>
Date: Fri, 16 Dec 2005 14:50:25 -0600

I am trying to compile the imap-2004g on a red hat installation.  I am 
getting the errors below and cannot get any further.  Anyone have any ideas 
what might be wrong?

Thanks,
Edward

...
Standard password authentication
ln -s ckp_psx.c osdepckp.c
Building with SSL
ln -s ssl_unix.c osdepssl.c
echo -I/usr/local/ssl/include -I/usr/local/ssl/include/openssl 
-DSSL_CERT_DIRECTORY=\"/usr/local/ssl/certs\" 
-DSSL_KEY_DIRECTORY=\"/usr/local/ssl/certs\" >> OSCFLAGS
echo "  ssl_onceonlyinit ();" >> linkage.c
echo -L/usr/local/ssl/lib -lssl -lcrypto  >> LDFLAGS
Building with SSL and plaintext passwords disabled unless SSL/TLS
echo "  mail_parameters (NIL,SET_DISABLEPLAINTEXT,(void *) 2);" >> linkage.c
cat osdepbas.c osdepckp.c osdeplog.c osdepssl.c > osdep.c
Building OS-dependent module
If you get No such file error messages for files x509.h, ssl.h,
pem.h, buffer.h, bio.h, and crypto.h, that means that OpenSSL
is not installed on your system. Either install OpenSSL first
or build with command: make slx SSLTYPE=none
`cat CCTYPE` -c `cat CFLAGS` `cat OSCFLAGS` -c osdep.c
/bin/sh: line 1: cc: command not found
make[3]: *** [osdep.o] Error 127
make[3]: Leaving directory `/root/imap-2004g/c-client'
make[2]: *** [slx] Error 2
make[2]: Leaving directory `/root/imap-2004g/c-client'
make[1]: *** [OSTYPE] Error 2
make[1]: Leaving directory `/root/imap-2004g'
make: *** [slx] Error 2

_______________________________________________
Imap-uw mailing list
[email-masked]
https://mailman1.u.washington.edu/mailman/listinfo/imap-uw

---

From: Matt Selsky <[email-masked]>
Date: Fri, 16 Dec 2005 16:23:42 -0500

Do you have the gcc RPMs installed?

-- 
Matt

---

From: Alan Thew <[email-masked]>
Date: Fri, 16 Dec 2005 21:46:52 +0000 (GMT)

On Fri, 16 Dec 2005 14:50 , Edward Duhe' <[email-masked]> said:

> I am trying to compile the imap-2004g on a red hat installation.  I am getting
> the errors below and cannot get any further.  Anyone have any ideas what might
> be wrong?

Apart from gcc issues mentioned by another poster, it's best to use 
build lrh as well.

Alan Thew