Subject: Re: decode Header

From: Raul Dias <[email-masked]>
Date: Mon, 12 Jun 2000 01:24:32 -0300

>On Sun, 11 Jun 2000, Raul Dias wrote:
>> What kind of encode is the following text:
>> =?ISO-8859-1?Q?F=E1bio_Oliv=E9_Leite?=
>
>
>You should read RFC 2047 (MIME Part Three:
>Message Header Extensions for Non-ASCII Text).
>It describes what the header you mentioned is.
>

Ok, 

is rfc822_qprint () suppose to decode it?
It either leave the "=?ISO-8859-1?Q?" part in the message (the middle
is decoded right) or it generates a segmentation fault.

I am using perl's Mail::Cclient, so the core is probably caused by it.

Right now I am using a regex to clean this up.

Thanks for you attention,
Raul Dias

---

From: Mark Crispin <[email-masked]>
Date: Sun, 11 Jun 2000 23:06:10 -0700 (PDT)

> is rfc822_qprint () suppose to decode it?

No.  rfc822_qprint() decodes quoted-printable data.  This is MIME2 data,
which is different.  utf8_mime2() will convert it into UTF-8.

-- Mark --