Subject: Compiling PHP, IMAP, C-Client

From: Matt Middleton <[email-masked]>
Date: Tue, 18 Mar 2003 00:48:37 -0800 (PST)

I've been trying to compile php 4.3.1 with imap and
imap ssl suppport.  I have two imap (c-client
directories) one linked against openssl and one that
is not.  When i try to compile php with either option
individually, it works fine, but with both I get an
error:

In function `zm_startup_imap':
/sources/php/ext/imap/php_imap.c:429: undefined
reference to `ssl_onceonlyinit'
collect2: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1

my configure command is:
./configure --with-imap=/sources/imap-2002b
--with-imap-ssl=/usr/local/ssl

I've also tried:
--with-imap-ssl=/sources/imap-2002bs (compiled with
ssl)

I've tried many other things, I've copied the SSL
c-client libraries and headers to /usr/lib and
/usr/include respectively, I've uninstalled everything
and reinstalled openssl, the imaps, and the php from
scratch, to no avail.  I was able to do this earlier,
but I can't get it to work now.  Does anybody have any
ideas??

__________________________________________________
Do you Yahoo!?
Yahoo! Platinum - Watch CBS' NCAA March Madness, live on your desktop!
http://platinum.yahoo.com
-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Tue, 18 Mar 2003 10:15:23 -0800 (Pacific Standard Time)

> reference to `ssl_onceonlyinit'

This will happen when you link a main program that uses SSL with a
c-client that was built without SSL.  I don't know much about PHP, but
perhaps this information will help you in fixing the problem.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.