Subject: Eudora + SSL problem

From: "Caines, Max" <[email-masked]>
Date: Wed, 31 Mar 2004 13:15:52 +0100

Hi,
 
I'm using imap-2002e with OpenSSL 0.9.7d for SSL support. I've got Outlook Express using that, and it's perfectly happy. However, we have a lot of Eudora users, so I'm trying to get it working with that. I'm using 6.0.3.0, and I've set the connection method to "Required, alternate port". Attempts to connect fail with Eudora saying:
 
MAIN 8:0.11 Dialog: "The IMAP command has failed.\n"
MAIN 8:0.11 Dialog: "\n"
MAIN 8:0.11 Dialog: "Reason: IMAP connection to server "wlv.ac.uk" has been broken.."
MAIN 8:0.12 Dialog: "Dismissed with 1"
25836 16:0.12 Open 134.220.1.46:993
25836 8:0.12 Dialog: "Operation Failed: Operation aborted by the  user."
 
which is amusing but not very informative (I didn't abort anything).

If I run OpenSSL in server emulation mode, I get:
 
/usr/local/ssl/bin/openssl s_server -cert /usr/local/ssl/certs/wlv_ac_uk.pem -accept 993 -state -bugs
Using default temp DH parameters
ACCEPT
SSL_accept:before/accept initialization
SSL_accept:SSLv3 read client hello A
SSL_accept:SSLv3 write server hello A
SSL_accept:SSLv3 write certificate A
SSL_accept:SSLv3 write server done A
SSL_accept:SSLv3 flush data
SSL_accept:failed in SSLv3 read client certificate A
ERROR
shutting down SSL
CONNECTION CLOSED
 
which doesn't tell me much, except that the OpenSSL pseudo-server tries to get a certificate off the client.

I can't work out how to get debugging information out of the server when connecting with Eudora, so I'm not sure how to resolve this. I did consider that this might be the "empty fragment" issue, but IMAPD seems to set the option needed to disable that. There's nothing logged to syslog, by the way.
 
Anyone got any ideas about this?
 
Max Caines
IT Services, University of Wolverhampton
Wolverhampton, West Midlands WV1 1SB
Tel: 01902 322245 Fax: 01902 322699

---

From: Sahil Tandon <[email-masked]>
Date: Wed, 31 Mar 2004 12:29:39 -0500

On Wed, Mar 31, 2004 at 01:15:52PM +0100, Caines, Max wrote:

> However, we have a lot of Eudora users, so I'm trying to get it working with
> that. I'm using 6.0.3.0, and I've set the connection method to "Required,
> alternate port". Attempts to connect fail with Eudora saying: >  

Increase the network buffer size in Eudora to 8192.

-- 
Sahil Tandon <[email-masked]>