Subject: command stream end of file

From: Terry Davis <[email-masked]>
Date: Mon, 02 Jul 2001 16:45:59 -0500

I have seen quite a bit of this lately.

for me, it only seems to occur when the user has emails.  if the user
has an empty inbox the authentication goes through fast and everything
is done quickly.
when there is an email, it takes a long time to receive one email but
eventually gives the command stream end of file error msg.   has anyone
made any progress on a fix for this if there is one?

thank you

-- 
Terry Davis
Systems Administrator
BirdDog Solutions, Inc.
(402) 829-6059
www.birddog.com
-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Mon, 2 Jul 2001 15:44:10 -0700 (PDT)

"Command stream end of file" means that the client disconnected the connection
without giving any prior notification to the server.  The server was in "read
command" wait.

This is generally a client problem and not a server problem.  Since you didn't
say what client you are using, there isn't much more that I can offer to help
you.

---

From: Terry Davis <[email-masked]>
Date: Mon, 02 Jul 2001 17:44:19 -0500

Sorry about that.  It is the bloody M$ Outlook client. ( not express ).
It is not happening to all my outlook clients however.  very weird. 
most are running same 
version of outlook.  It even seems to do it with the gnu-pop3d server as
well.
that server says "socket closed".

thanks for any tips or clues.
Terry

-- 
Terry Davis
Systems Administrator
BirdDog Solutions, Inc.
(402) 829-6059
www.birddog.com

---

From: Friedrich Lobenstock <[email-masked]>
Date: Tue, 3 Jul 2001 01:47:59 +0200 (CEST)

On Mon, 2 Jul 2001, Terry Davis wrote:

> It is the bloody M$ Outlook client. ( not express ).

OK, they don't seam to do any harm - just ignore them is what I do.

-- 
MfG / Regards
Friedrich Lobenstock

---

From: Mark Crispin <[email-masked]>
Date: Mon, 2 Jul 2001 17:05:02 -0700 (PDT)

> that server says "socket closed".

What problems are you seeing?

Or is it just that you see the message?  If it's just that you see the
message, treat it as equivalent to a LOGOUT since that's exactly how the
server treats it.  The difference only matters if there is a problem.

---

From: Terry Davis <[email-masked]>
Date: Mon, 02 Jul 2001 19:09:09 -0500

i agree.  no, I do see a problem.

client initiates session
login is seen in logs
client sees that there are X msgs to download
roughly 1 minute wait time.
client sees timeout on there end 
server logs command stream end of file.

I tried all kinds of goofy things like creating new accounts and
changing passwds. 
But of course, none of that worked.
Thank you.

-- 
Terry Davis
Systems Administrator
BirdDog Solutions, Inc.
(402) 829-6059
www.birddog.com