Subject: Re: Thread implementation

From: Raul Dias <[email-masked]>
Date: Thu, 29 Nov 2001 19:57:37 -0200

>Yes, thread support is fully functional.
>
>The data that you sent didn't make much sense though; it shows messages
>appearing more than once which can't happen in references. 

That's exactly what I was worried about (messages showing up more than once).

the  [ x, x ] represented a node so
1
	[
	2
	3
		[
		4
		]
	]

was supposed to mean a reference tree like this:
1
|->2
|->3
   |->4

where the numbers are the message uid 

> I think that it
>would be better if you did your tests through imapd and reported what imapd
>says in IMAP format.

I will check this.

>
>Also, what mailbox format are you using?  Is it one of the standard drivers
>provided by c-client?
good old mbox driver.

The code I am testing with is the perl interface Mail-Cclient, each variation of the
thread was a different imap that the Mail-Cclient was compiled with.

Raul Dias

---

From: Mark Crispin <[email-masked]>
Date: Thu, 29 Nov 2001 22:52:48 -0800 (PST)

OK, thanks for the update.  Please let me know what you see when using just
imapd, since that will eliminate the Perl Mail-Cclient code from the equation.