Subject: Doubts regarding the c-client Library

From: "Sushmita Roy" <[email-masked]>
Date: Fri, 25 May 2001 10:49:11 +0530

Hi Mark,

 I had a couple of doubts regarding the C-client
Library :

1. I have an application which reads HTTP POST data
which may be in mime format (like multipart form
data, or data encoded in Base64 encoding).
Since this application is reading from the socket
I have a char buffer which contains the data. Can
the C-Client library parse this mime data ?

2. Is the mime related parsing for HTTP different
as compared to that for email ?

3. Does the C-Client Library expect that email
messages have to be read using the C-Library
functions ? Can I have a seperate application that
Pops email but uses the C-Client Library for mime
related parsing for the email ?

I am basically looking for Mime Parsing functionality
from the C-Client Library.

Thanks and Regards
Sushmita

---

From: Mark Crispin <[email-masked]>
Date: Thu, 24 May 2001 22:43:42 -0700 (PDT)

> the C-Client library parse this mime data ?

c-client can parse data from a char buffer.  Whether or not it can parse HTTP
POST data is something that I can not answer.

> as compared to that for email ?

I do not know.

> functions ?

It doesn't expect it, but you have much harder work if you don't.

> Can I have a seperate application that

Yes, you can do that, but it is much harder to do it that way.