Subject: disable syslogging

From: "Scott J. Janz" <[email-masked]>
Date: Tue, 01 Jun 1999 11:16:10 -0400

Is there anyway of disabling login/logout messages to the syslog in the UW
server (4.5rev1) (irix os)?

thanks,

-scott
--------------------

Dr. Scott J.Janz						
Joint Center for Earth Systems Technology/UMBC	[email-masked]
NASA Goddard Space Flight Center			[email-masked]
CODE 916
Greenbelt MD 20771

ph:  301-614-5987
fax: 301-614-5903
-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Tue, 1 Jun 1999 09:47:19 -0700 (PDT)

> server (4.5rev1) (irix os)?

Modify the source code?

This is an unusual request -- usually, folks want more syslogging, not less!

---

From: Andrew Mickish <[email-masked]>
Date: Tue, 01 Jun 1999 13:49:41 -0400

Yes, this is easily configurable with /etc/syslog.conf.

IMAP daemon has calls to the library function syslog() scattered
throughout the code.  Each invocation of syslog() has an associated
priority -- some are informational, some are authentication notices,
some are errors, etc.  All of them are from a 'mail' service.
You can tell syslogd to log these messages to a specific log file,
or ignore them completely.

The following excerpt from an /etc/syslog.conf file tells syslogd to
not log any mail messages to /var/log/messages, and to log *all* mail
messages to /var/log/maillog.

        # Write daemon logs (like named) to a separate file
        daemon.info                                             /var/log/named.log

        # Log everything (except auth, mail, and daemon) of level info or higher.
        # Don't log *any* authentication messages because that's handled later
        # Don't log daemon.info because that's handled in an earlier rule
        # Don't log mail.info because that's handled in a later rule
        *.info;daemon.!=info;mail.!=info;authpriv.!*;security.!=info  /var/log/messages
        
        # The authpriv file has restricted access.
        authpriv.*;security.*                                   /var/log/secure
        
        # Log all the mail messages in one place.
        mail.*                                                  /var/log/maillog

Remember:

  1) The destination files must exist before restarting syslog
     (syslog will not automatically create the log files, though
     it will append to them)

  2) You must restart syslog before the changes take effect, by
     looking at the result of 'ps aux' or 'ps -ef' and doing
     'kill -HUP <syslogPID>'

For more info, see 'man syslog', 'man syslogd', and 'man syslog.conf'.

--Andrew Mickish
  Software Engineer
  SneakerLabs, Inc.