Subject: re: Using SSL support in UW imap-2000.BETA?

From: Mark Crispin <[email-masked]>
Date: Mon, 5 Jun 2000 17:00:36 -0700 (PDT)

On Mon, 05 Jun 2000 17:48:19 -0500, Jason Spangler wrote:
> simap   stream   tcp   nowait   root   /usr/bin/tcpd imapd

Don't use TCP wrappers with the simap port.  I've never seen it work with TCP
wrappers.

Also, make sure that the imapd.pem file has both a RSA PRIVATE KEY and a
CERTIFICATE section.

> Also, does anyone know if imap-2000.BETA's SSL support will work with
> Netscape Messenger 4.72?

It works for us...

---

From: Jason Spangler <[email-masked]>
Date: Mon, 05 Jun 2000 19:11:17 -0500

> Don't use TCP wrappers with the simap port.  I've never seen it work with TCP

The line in inetd.conf now reads:
simap   stream   tcp   nowait   root   /usr/sbin/imapd imapd

I get a "port 993 service init" message in maillog, and Netscape Messenger still
hangs before asking for my password.

And:
$ openssl
OpenSSL> s_client -host localhost -port 993
CONNECTED(00000003)
20357:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown
protocol:s23_clnt.c:458:
OpenSSL>
 
> Also, make sure that the imapd.pem file has both a RSA PRIVATE KEY and a

It does.

> > Also, does anyone know if imap-2000.BETA's SSL support will work with

Cool.

---

From: Mark Crispin <[email-masked]>
Date: Mon, 5 Jun 2000 17:27:45 -0700 (PDT)

On Mon, 05 Jun 2000 19:11:17 -0500, Jason Spangler wrote:
> I get a "port 993 service init" message in maillog

Doh!  [Said ala Homer Simpson...]  Mea culpa.  I should have noticed what you
did wrong the last time.  simap is not the right service name; the correct
service name is imaps (and pop3s for pop3).

Change the service name and all should be well.

Sorry for not catching that.

---

From: Jason Spangler <[email-masked]>
Date: Mon, 05 Jun 2000 19:31:22 -0500

> Change the service name and all should be well.

That did it, works now, thanks!  It might be a good item to add to a
docs/ssl.txt file too.  :-)