Subject: Progressive downloading of message text

From: Colin Burgess <[email-masked]>
Date: Mon, 28 Apr 1997 15:46:49 -0400 (EDT)

Hi there.

Can anyone tell me the best way to implement progressive
display of a message, as it is downloading.

Does c-client support this?

Also, how would one go about cancelling a download?

-- 
[email-masked]

---

From: Mark Crispin <[email-masked]>
Date: Mon, 28 Apr 1997 13:24:00 -0700 (PDT)

> Also, how would one go about cancelling a download?

If the server is IMAP4rev1, you can do partial fetching via the mail_partial_*
functions.  There is no way to stop a transfer once it has started, so if you
want to offer that feature you should do the transfer in chunks and have the
opportunity to stop between chunks.