Subject: Fwd: build a IMAP client only with c-client

From: [email-masked]
Date: Wed, 20 Oct 2004 12:29:53 EDT

Subject: Re: build a IMAP client only with c-client
From: [email-masked]
To: [email-masked]
Date: Wed, 20 Oct 2004 12:24:56 EDT

In a message dated 2004/10/20 11:45:30 Eastern Daylight Time,  
[email-masked] writes:

> Is  there a makefile for using Microsoft Visual Studio.Net (vc   7)?

"make w2k" works just fine, although note from the instructions  that you 
need to have the Microsoft Platform SDK  installed.

I just tried to use vc 7 to do the build, it went through(?) with some  
warnings, seems not complete but without fatal error. It does not complain  about 
Microsoft Platform SDK stuff  though.
 
After it stoped, seems these lines not executed:
"
clean:
$(RD) c-client mtest mailutil ipopd imapd
 
# A monument to a hack of long ago and far away...
love:
@echo  'not war?'
"
Any suggestion?
Has someone build it with VC7 using the current makefile.w2k?
 
Thanks!
 
following is the output of the build:
-----------------------------
C:\imap\c-client_2_vc_7\imap.tar\imap-2004a>nmake -f makefile.w2k
 
Microsoft (R) Program Maintenance Utility Version 7.10.3077
Copyright  (C) Microsoft Corporation.  All rights reserved.
 
        cd  c-client
nmake /nologo /f  makefile.w2k IP=6
cl -c /MT /W3  /Ox /DWIN32 -nologo /I..   os_w2k.c
os_w2k.c
cl -c /MT /W3  /Ox /DWIN32 -nologo /I..   mbxnt.c
mbxnt.c
cl -c /MT /W3  /Ox /DWIN32 -nologo /I..   mtxnt.c
mtxnt.c
cl -c /MT /W3  /Ox /DWIN32 -nologo /I..   tenexnt.c
tenexnt.c
cl -c /MT  /W3 /Ox /DWIN32 -nologo /I..   unixnt.c
unixnt.c
cl -c /MT /W3  /Ox /DWIN32 -nologo /I..   dummynt.c
dummynt.c
cl -c /MT  /W3 /Ox /DWIN32 -nologo /I..   pseudo.c
pseudo.c
if exist  cclient.lib del cclient.lib
LIB  /NOLOGO /OUT:cclient.lib  mail.obj misc.obj fdstring.obj flstring.obj  
netmsg.obj  newsrc.obj rfc
822.obj smanager.obj utf8.obj   imap4r1.obj nntp.obj pop3.obj smtp.obj 
os_w2k.obj  mbxnt.obj mtxnt.obj  tenexn
t.obj unixnt.obj dummynt.obj  pseudo.obj
cd  ..\mtest
nmake /nologo /f  makefile.w2k IP=6
cl -I..\c-client  /MT /W3 /DWIN32 -nologo  /c  mtest.c
mtest.c
LINK /NOLOGO  /DEF:mtest.def mtest.obj ..\c-client\cclient.lib wsock32.lib 
winmm.lib  advapi32.lib sec
ur32.lib crypt32.lib
mtest.def(6) : warning LNK4017:  DESCRIPTION statement not supported for the 
target platform;  ignored
Creating library mtest.lib and object  mtest.exp
cd  ..\mailutil
nmake /nologo /f  makefile.w2k IP=6
cl -I..\c-client  /MT /W3 /DWIN32 -nologo  /c  mailutil.c
mailutil.c
LINK  /NOLOGO /DEF:mailutil.def mailutil.obj ..\c-client\cclient.lib 
wsock32.lib  winmm.lib advapi32.l
ib secur32.lib crypt32.lib
mailutil.def(6) : warning  LNK4017: DESCRIPTION statement not supported for 
the target platform;  ignored
Creating library mailutil.lib and object  mailutil.exp
cd  ..\ipopd
nmake /nologo /f  makefile.w2k IP=6
cl -I..\c-client  /MT /W3 /DWIN32 -nologo  /c  ipop2d.c
ipop2d.c
LINK /NOLOGO  /DEF:ipop2d.def ipop2d.obj ..\c-client\cclient.lib wsock32.lib 
winmm.lib  advapi32.lib s
ecur32.lib crypt32.lib
ipop2d.def(6) : warning LNK4017:  DESCRIPTION statement not supported for the 
target platform;  ignored
Creating library ipop2d.lib and object  ipop2d.exp
cl -I..\c-client /MT  /W3 /DWIN32 -nologo  /c  ipop3d.c
ipop3d.c
LINK /NOLOGO  /DEF:ipop3d.def ipop3d.obj ..\c-client\cclient.lib wsock32.lib 
winmm.lib  advapi32.lib s
ecur32.lib crypt32.lib
ipop3d.def(6) : warning LNK4017:  DESCRIPTION statement not supported for the 
target platform;  ignored
Creating library ipop3d.lib and object  ipop3d.exp
cd  ..\imapd
nmake /nologo /f  makefile.w2k IP=6
cl -I..\c-client  /MT /W3 /DWIN32 -nologo  -DALERTFILE=\"_\\imapd.alert\_ 
(file://\\imapd.alert\) " -DNNTPFILE=\"_\\imapd.nntp\_ (file://\\imapd.nntp\) "
-DUSERALERTFILE=\"alert.txt\"  -DANOFILE=\"_\\anonymous.newsgroups\_ 
(file://\\anonymous.newsgroups\) "  -DSHUTDOWNFILE=\"_\\nologin\_ (file://\\nologin\) 
" /c  imapd.c
imapd.c
LINK /NOLOGO  /DEF:imapd.def imapd.obj ..\c-client\cclient.lib wsock32.lib 
winmm.lib  advapi32.lib sec
ur32.lib crypt32.lib
imapd.def(6) : warning LNK4017:  DESCRIPTION statement not supported for the 
target platform;  ignored
Creating library imapd.lib and object  imapd.exp
cd ..
 
C:\imap\c-client_2_vc_7\imap.tar\imap-2004a>

---

From: Charles Dorner <[email-masked]>
Date: Wed, 20 Oct 2004 10:00:59 -0700

[email-masked] wrote on 10/20/2004 9:29 AM:

> warnings, seems not complete but without fatal error. It does not 
> complain about Microsoft Platform SDK stuff though.

> After it stoped, seems these lines not executed:

Those lines are for other uses of the make command, entering "make 
clean" will execute the lines after "clean:".  The lines after "love:" 
are for fun / an easter egg.

Charles Dorner