Subject: Re: Re: [Imap-uw] Imapd-2004e and Solaris 10

From: "Jozef Rujak" <[email-masked]>
Date: Tue, 30 Aug 2005 12:12:20 +0200

Yes, problem was in openssl 0.9.7d which comes with
Solaris 10.
After compiling new openssl 0.9.8 , imapd works fine.

Thanks,
Jozef

>
>
>On Wed, 17 Aug 2005, Jozef Rujak wrote:
>> sh -c '(strings /lib/libc.a | grep getpassphrase > /dev/null) && ln -s os_soln.h os_sol.h || ln -s os_solo.h os_sol.h'
>> /lib/libc.a: No such file or directory
>
>Don't worry about this.  It is just a check to see whether the C library
>has the getpassphrase() call, and if so that is used when building
>mailutil instead of getpass().
>
>> Aug 17 11:54:13 nstest imapd[1778]: [ID 298158 mail.debug] imaps SSL service init from 193.87.248.75
>> Aug 17 11:54:13 nstest imapd[1778]: [ID 149382 mail.info] Unable to accept SSL connection, host=dodi.intas.sk [193.87.248.75]
>> Aug 17 11:54:13 nstest imapd[1778]: [ID 853321 mail.error] SSL error status: error:1409D08A:SSL routines:SSL3_SETUP_KEY_BLOCK:cipher or hash unavailable
>> Aug 17 11:54:30 nstest imapd[1779]: [ID 298158 mail.debug] imaps SSL service init from 193.87.248.75
>> Aug 17 11:54:42 nstest imapd[1779]: [ID 149382 mail.info] Unable to accept SSL connection, host=dodi.intas.sk [193.87.248.75]
>> Aug 17 11:54:42 nstest imapd[1779]: [ID 853321 mail.error] SSL error status: error:140D308A:SSL routines:TLS1_SETUP_KEY_BLOCK:cipher or hash unavailable
>
>This is the problem that you need to look into.  It's a problem within
>OpenSSL.  It may have been built incorrectly.
>
>-- Mark --
>
>http://staff.washington.edu/mrc
>Science does not emerge from voting, party politics, or public debate.
>Si vis pacem, para bellum.

Aktivujte si aj vy schranku s neobmedzenou kapacitou na ATLAS.SK.
http://mail.atlas.sk

_______________________________________________
Imap-uw mailing list
[email-masked]
https://mailman1.u.washington.edu/mailman/listinfo/imap-uw

---

From: Mark Crispin <[email-masked]>
Date: Tue, 30 Aug 2005 08:31:37 -0700 (PDT)

Thank you for the update.  I'm surprised to hear this, since I've build 
imap-2004e with OpenSSL 0.9.7d numerous times and did not encounter this 
problem.

My guess is that it isn't a problem with that OpenSSL version, but rather 
with how it was built in Solaris 10; perhaps it was pre-built in some 
non-standard way.  When you upgraded to OpenSSL 0.9.8, you built it in the 
standard way.

-- Mark --

http://panda.com/mrc
Democracy is two wolves and a sheep deciding what to eat for lunch.
Liberty is a well-armed sheep contesting the vote.
_______________________________________________
Imap-uw mailing list
[email-masked]
https://mailman1.u.washington.edu/mailman/listinfo/imap-uw

---

From: Chris Ross <[email-masked]>
Date: Tue, 30 Aug 2005 13:55:44 -0400

On Aug 30, 2005, at 11:31, Mark Crispin wrote:

> Thank you for the update.  I'm surprised to hear this, since I've 
> build imap-2004e with OpenSSL 0.9.7d numerous times and did not 
> encounter this problem.
>
> My guess is that it isn't a problem with that OpenSSL version, but 
> rather with how it was built in Solaris 10; perhaps it was pre-built 
> in some non-standard way.  When you upgraded to OpenSSL 0.9.8, you 
> built it in the standard way.

   likely true.  Sun has a habit of shipping libraries but yet not 
enough other
material to compile/link against the libraries correctly.

   Could this issue have been caused by a lack of include files or
prototypes?  I know I've had that problem with solaris many times...

                 - Chris