Subject: Using SSL on w2k

From: "David Carey" <[email-masked]>
Date: Tue, 8 Jan 2002 16:11:31 -0000

Hi all
I'm obviously missing something regarding the SSL implementation on w2k

I've built and run the imap-2001a version on w2k.
It works just fine on the standard port on 143

However I then wanted to use the SSL Version.
It didn't work.  Having then dug into the code, I became mystified because I
couldn't see how the SSL driver gets called

e.g.  PSOUT is always tied to the routine in ssl_none.c
      This routine just pushes the existing data out on stdout

I'm using the inetlisn.exe to tie stdout, to a socket.  Obviously this goes
unencrypted 

There is an equivalent ssl_w2k.c, for specified ssl routines, but it doesn't

have versions of PSOUT as I king of expected, and none of the routines that
are in here seem to get invoked

As I say, I'm obviously missing a point somewhere

Cheers
Dave

>> -----Original Message-----
>> From: Mark Crispin [mailto:[email-masked]]
>> Sent: 06 November 2001 00:50
>> To: Marc MERLIN
>> Cc: [email-masked]
>> Subject: re: forcing SSL/TLS only on imap
>> 
>> 
>> On Mon, 5 Nov 2001 15:46:33 -0800, Marc MERLIN wrote:
>> > Is there a setting or a patch for imapd to accept SSL 
>> connections on 993, or
>> > accept connections on 143 provided that the client switches to TLS?
>> 
>> Perhaps what you want is to build the IMAP toolkit with 
>> SSLTYPE=nopwd instead
>> of SSLTYPE=unix
>> 
>> This is an important new capability of imap-2001; it isn't 
>> in imap-2000.
>> 
>> 
>> 
>> 

--
This message has been content scanned by Tumbleweed Secure Guardian (TSG). 
TSG uses policy enforcement to scan for known viruses, content 
and malicious code. For more information about TSG please contact 
www.tumbleweed.com or call +44 118 9347100

NOTICE:  This email message is for the sole use of the intended recipient(s) 
and may contain confidential and privileged information.  Any unauthorized 
review, use, disclosure or distribution is prohibited.  If you are not the 
intended recipient, please contact the sender by reply email and destroy all 
copies of the original message. 

To contact our email administrator directly, send to
 [email-masked]

-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Tue, 8 Jan 2002 08:22:53 -0800 (PST)

If you are talking about making an SSL IMAP server under Win2K, there is no
code to do that.  I wrote such code, but never had the opportunity to test it
so it isn't included.  The current Win2K code is client only.

One issue is getting a server certificate installed in Win2K.  I don't think
that you can install a self-signed certificate, and I'm not sure that Win2K
Pro lets you install server certificates (I think that's a feature of the more
expensive server version of Win2K).