Subject: Regarding MAILSTREAM data structure

From: Gangadhar Mylapuram <[email-masked]>
Date: Mon, 18 Aug 2003 22:08:55 -0700 (PDT)

Hi everybody,
 
I have some quires reagrding mail.h file in c-client soure.
 
1. How to use mail_xxx APIs and Imap_xxx APIs? 
 
2. Is the MAILSTREAM datastructure object used to store a single folder inforamtion?
 
3. How MAILSTREAM object storing information about mail messages?
 
4. In case of serveral folders (like sent, drafts and thrash), Do we need to create as many number of MAILSTREAM objects?
 
Can any body clear these things.
 
Thanks in advance.
 
Regards
Gangadhar

---------------------------------
Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software

---

From: Mark Crispin <[email-masked]>
Date: Tue, 19 Aug 2003 18:52:45 -0700 (Pacific Daylight Time)

> 1. How to use mail_xxx APIs and Imap_xxx APIs?

There is a documentation file called internal.txt which will help you get
started.  Also look at existing programs, such as mtest and mailutil.

You should not call any c-client imap_xxx routines directly.

> 2. Is the MAILSTREAM datastructure object used to store a single folder

Yes.

> 3. How MAILSTREAM object storing information about mail messages?

It's a C struct with many fields.

> 4. In case of serveral folders (like sent, drafts and thrash), Do we
> need to create as many number of MAILSTREAM objects?

Yes, and this is done with mail_open.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.