Subject: [Fwd: build Pine4.58 under Solaris 9 ( Sun SPARC )]

From: Lyane Plançon <[email-masked]>
Date: Fri, 16 Jan 2004 14:42:28 +0100

Hello, everybody,

I have some problems with building Pine 4.58 ! I send to you the 
attachement file, if you could help me !
Best wishes
Lyane

Subject: build Pine4.58 under Solaris 9 ( Sun SPARC )
From: Lyane Plançon <[email-masked]>
To: [email-masked]
Date: Fri, 16 Jan 2004 14:18:39 +0100

Hello, everybody,

I have some problems whith building Pine 4.58 under Solaris 9 ( Sun 
SPARC ) ; here is, in attachement, the file with the results of  
building ! Thanks if you find an answer to my question !
Best whishes

Lyane

root on antares # ./build so5
make args are CC=cc  so5

Including LDAP functionality
  File /usr/local/ssl/certs/factory.pem is missing
  This might indicate that CA certs did not get properly
  installed.  If you get certificate validation failures
  in Pine, this might be the reason for them.

Including SSL functionality
ln: cannot create c-client: File exists
ln: cannot create mtest: File exists
ln: cannot create mailutil: File exists
ln: cannot create imapd: File exists
ln: cannot create ipopd: File exists
Making c-client library, imapd, and ipopd
eval make CC=cc SSLTYPE=nopwd SPECIALS=SSLDIR=/usr/local/ssl sol
make sslnopwd
`sslnopwd' is up to date.
Applying an process to sources...
tools/an "ln -s" src/c-client c-client
tools/an "ln -s" src/ansilib c-client
tools/an "ln -s" src/charset c-client
tools/an "ln -s" src/osdep/unix c-client
tools/an "ln -s" src/mtest mtest
tools/an "ln -s" src/ipopd ipopd
tools/an "ln -s" src/imapd imapd
tools/an "ln -s" src/mailutil mailutil
tools/an "ln -s" src/mlock mlock
tools/an "ln -s" src/dmail dmail
tools/an "ln -s" src/tmail tmail
ln -s tools/an .
make build EXTRACFLAGS='' EXTRALDFLAGS='' EXTRADRIVERS='mbox' EXTRAAUTHENTICATORS='' PASSWDTYPE=std SSLTYPE=nopwd EXTRASPECIALS='' BUILDTYPE=sol
Building c-client for sol...
echo `cat SPECIALS`  > c-client/SPECIALS
cd c-client;make sol EXTRACFLAGS=''\
 EXTRALDFLAGS=''\
 EXTRADRIVERS='mbox'\
 EXTRAAUTHENTICATORS=''\
 PASSWDTYPE=std SSLTYPE=nopwd\
  
make build EXTRACFLAGS='' EXTRALDFLAGS='' EXTRADRIVERS='mbox' EXTRAAUTHENTICATORS='' PASSWDTYPE=std SSLTYPE=nopwd `cat SPECIALS` OS=sol \
 SIGTYPE=psx CHECKPW=psx CRXTYPE=nfs \
 SPOOLDIR=/var/spool MAILSPOOL=/var/mail \
 ACTIVEFILE=/usr/share/news/active \
 RSHPATH=/usr/bin/rsh \
 BASECFLAGS="-g -O2" \
 BASELDFLAGS="-lsocket -lnsl -lgen" \
 RANLIB=true CC=ucbcc
sh -c 'rm -rf auths.c crexcl.c nfstest.c linkage.[ch] siglocal.c osdep*.[ch] *.o ARCHIVE *FLAGS *TYPE c-client.a || true'
Once-only environment setup...
echo ucbcc > CCTYPE
echo -g -O2 '' > CFLAGS
echo -DCREATEPROTO=unixproto -DEMPTYPROTO=unixproto \
 -DMAILSPOOL=\"/var/mail\" \
 -DANONYMOUSHOME=\"/var/mail/anonymous\" \
 -DACTIVEFILE=\"/usr/share/news/active\" -DNEWSSPOOL=\"/var/spool/news\" \
 -DRSHPATH=\"/usr/bin/rsh\" -DLOCKPGM=\"/etc/mlock\" > OSCFLAGS
echo -lsocket -lnsl -lgen  > LDFLAGS
echo "ar rc c-client.a osdep.o mail.o misc.o newsrc.o smanager.o utf8.o siglocal.o  dummy.o pseudo.o netmsg.o flstring.o fdstring.o  rfc822.o nntp.o smtp.o imap4r1.o pop3.o  unix.o mbox.o mbx.o mmdf.o tenex.o mtx.o news.o phile.o mh.o mx.o;true c-client.a" > ARCHIVE
echo sol > OSTYPE
./drivers mbox imap nntp pop3 mh mx mbx tenex mtx mmdf unix news phile dummy
./mkauths  md5 pla log
echo -DMD5ENABLE=\"/etc/cram-md5.pwd\" >> OSCFLAGS
ln -s os_sol.h osdep.h
ln -s os_sol.c osdepbas.c
ln -s log_std.c osdeplog.c
ln -s sig_psx.c siglocal.c
ln -s crx_nfs.c crexcl.c
sh -c '(test -f /usr/include/sys/statvfs.h -a sol != sc5 -a sol != sco) && ln -s nfstnew.c nfstest.c || ln -s nfstold.c nfstest.c'
Standard password authentication
ln -s ckp_psx.c osdepckp.c
Building with SSL
ln -s ssl_unix.c osdepssl.c
echo -I/usr/local/ssl/include -I/usr/local/ssl/include/openssl -DSSL_CERT_DIRECTORY=\"/usr/local/ssl/certs\" -DSSL_KEY_DIRECTORY=\"/usr/local/ssl/certs\" >> OSCFLAGS
echo "  ssl_onceonlyinit ();" >> linkage.c
echo -L/usr/local/ssl/lib -lssl -lcrypto  >> LDFLAGS
Building with SSL and plaintext passwords disabled unless SSL/TLS
echo "  mail_parameters (NIL,SET_DISABLEPLAINTEXT,(void *) 2);" >> linkage.c
cat osdepbas.c osdepckp.c osdeplog.c osdepssl.c > osdep.c
Building OS-dependent module
If you get No such file error messages for files x509.h, ssl.h,
pem.h, buffer.h, bio.h, and crypto.h, that means that OpenSSL
is not installed on your system. Either install OpenSSL first
or build with command: make sol SSLTYPE=none
`cat CCTYPE` -c `cat CFLAGS` `cat OSCFLAGS` -c osdep.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` mail.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` misc.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` newsrc.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` smanager.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` utf8.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` siglocal.c
cc: Warning: option -2 passed to ld
"siglocal.c", line 39: warning: assignment type mismatch:
        pointer to function() returning void "=" pointer to void
`cat CCTYPE` -c `cat CFLAGS` dummy.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` pseudo.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` netmsg.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` flstring.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` fdstring.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` rfc822.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` nntp.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` smtp.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` imap4r1.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` pop3.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` unix.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` mbox.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` mbx.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` mmdf.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` tenex.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` mtx.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` news.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` phile.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` mh.c
cc: Warning: option -2 passed to ld
`cat CCTYPE` -c `cat CFLAGS` mx.c
cc: Warning: option -2 passed to ld
sh -c 'rm -rf c-client.a || true'
ar rc c-client.a osdep.o mail.o misc.o newsrc.o smanager.o utf8.o siglocal.o  dummy.o pseudo.o netmsg.o flstring.o fdstring.o  rfc822.o nntp.o smtp.o imap4r1.o pop3.o  unix.o mbox.o mbx.o mmdf.o tenex.o mtx.o news.o phile.o mh.o mx.o;true c-client.a
echo sol > OSTYPE
touch rebuild
sh -c 'rm -rf rebuild || true'
Building bundled tools...
cd mtest;make
`cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS`  -c  mtest.c
cc: Warning: option -2 passed to ld
`cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS` -o mtest mtest.o ../c-client/c-client.a `cat ../c-client/LDFLAGS`
cc: Warning: option -2 passed to ld
/usr/ccs/bin/ld: illegal option -- 2
usage: ld [-6:abc:d:e:f:h:il:mo:p:rstu:z:B:CD:F:GI:L:M:N:P:Q:R:S:VY:?] file(s)
        [-64]           enforce a 64-bit link-edit
        [-a]            create an absolute file
        [-b]            do not do special PIC relocations in a.out
        [-B direct]     specify `direct' bindings for executable when run
        [-B dynamic | static]
                        search for shared libraries|archives
        [-B eliminate]  eliminate unqualified global symbols from the
                        symbol table
        [-B group]      relocate object from within group
        [-B local]      reduce unqualified global symbols to local
        [-B reduce]     process symbol reductions
        [-B symbolic]   bind external references to definitions when creating
                        shared objects
        [-c name]       record configuration file `name'
        [-C]            demangle C++ symbol name diagnostics
        [-d y | n]      operate in dynamic|static mode
        [-D token,...]  print diagnostic messages
        [-e epsym]      use `epsym' as entry point address
        [-f name]       specify library for which this file is an auxiliary
                        filter
        [-F name]       specify library for which this file is a filter
        [-G]            create a shared object
        [-h name]       use `name' as internal shared object identifier
        [-i]            ignore LD_LIBRARY_PATH setting
        [-I name]       use `name' as path of interpreter
        [-l x]          search for libx.so or libx.a
        [-L path]       search for libraries in directory `path'
        [-m]            print memory map
        [-M mapfile]    use processing directives contained in `mapfile'
        [-N string]     create a dynamic dependency for `string'
        [-o outfile]    name the output file `outfile'
        [-p auditlib]   identify audit library to accompany this object
        [-P auditlib]   identify audit library for processing the dependencies
                        of this object
        [-Q y | n]      do|do not place version information in output file
        [-r]            create a relocatable object
        [-R path]       specify a library search path to be used at run time
        [-s]            strip any symbol and debugging information
        [-S supportlib]
                        specify a link-edit support library
        [-t]            do not warn of multiply-defined symbols that have
                        different sizes or alignments
        [-u symname]    create an undefined symbol `symname'
        [-V]            print version information
        [-Y P,dirlist]  use `dirlist' as a default path when searching for
                        libraries
        [-z absexec]    when building an executable absolute symbols
                        referenced in dynamic objects are promoted to
                        the executable
        [-z allextract | defaultextract | weakextract]
                        extract all member files, only members that resolve
                        undefined tor tentative symbols, or allow extraction of
                        archive members to resolvetweak references from 
                        archive files
        [-z combreloc]  combine multiple relocation sections
        [-z nocompstrtab]       disable compression of string tables
        [-z defs]       disallow undefined symbol references
        [-z endfiltee]  marks a filtee such that it will terminate a filters
                        search
        [-z finiarray=function]
                        name of function to be appended to the .finiarray
        [-z groupperm | nogroupperm]
                        enable|disable setting of group permissions
                        on dynamic dependencies
        [-z ignore | record]
                        ignore|record unused dynamic dependencies
        [-z initarray=function]
                        name of function to be appended to the .initarray
        [-z initfirst]  mark object to indicate that its .init section should
                        be executed before the .init section of any other
                        objects
        [-z interpose]  dynamic object is to be an `interposer' on direct
                        bindings
        [-z lazyload | nolazyload]
                        enable|disable delayed loading of shared objects
        [-z ld32=arg1,arg2,...]
                        define arguments applicable to the 32-bit class of ld(1)
        [-z ld64=arg1,arg2,...]
                        define arguments applicable to the 64-bit class of ld(1)
        [-z loadfltr]   mark filter as requiring immediate loading of its
                        filtees at runtime
        [-z muldefs]    allow multiply-defined symbols
        [-z nodefs]     allow undefined symbol references
        [-z nodefaultlib]
                        mark object to ignore any default library search path
        [-z nodelete]   mark object as non-deletable
        [-z nodlopen]   mark object as non-dlopen()'able
        [-z nodump]     mark object as non-dldump()'able
        [-z nopartial]  expand any partially initialized symbols
        [-z noversion]  don't record any version sections
        [-z now]        mark object as requiring non-lazy binding
        [-z origin]     mark object as requiring $ORIGIN processing
        [-z preinitarray=function]
                        name of function to be appended to the .preinitarray
        [-z redlocsym]  reduce local syms in .symtab to a minimum
        [-z rescan]     rescan archive list until no further member
                        extraction occurs
        [-z text]       disallow output relocations against text
        [-z textoff]    allow output relocations against text
        [-z textwarn]   warn if there are relocations against text
        [-z verbose]    generate warnings for suspicious processings
*** Error code 1
make: Fatal error: Command failed for target `mtest'
Current working directory /opt/pine4.58/imap/mtest
*** Error code 1
make: Fatal error: Command failed for target `bundled'
Current working directory /opt/pine4.58/imap
*** Error code 1
make: Fatal error: Command failed for target `sol'
+---------------------------------------------+
| Problems building c-client                  |
|                                             |
| Please check the output above for a         |
| possible explanation for this failure       |
+---------------------------------------------+

root on antares #

---

From: Mark Crispin <[email-masked]>
Date: Fri, 16 Jan 2004 10:17:49 -0800 (Pacific Standard Time)

Did you modify the software?  It looks like you have changed the c-client
build to use cc instead of ucbcc.

Because there is no such thing as a consistant "cc" on Solaris, you need
to use either ucbcc or gcc.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.