Subject: [Imap-uw] Authentic

From: "Jose Wilson A. do Nascimento" <[email-masked]>
Date: Fri, 2 Dec 2005 14:47:50 -0200 (EDT)

Hi,

	 I am inexperienced in the list, I am with some problems to use
imap-uw, I installed in the FreeBSD imap-uw to legalize way imap the user
of the database of the LDAP, by means of PAM it.  What this happening is
the following one, I make login with user registered in of the database in
the LDAP imap makes to request for the PAM and the PAM to verify in the
base the user, but not legalizes the user.  everyone had a similar
experience.

 Wilson

_______________________________________________
Imap-uw mailing list
[email-masked]
https://mailman1.u.washington.edu/mailman/listinfo/imap-uw

---

From: Mark Crispin <[email-masked]>
Date: Fri, 2 Dec 2005 13:14:04 -0800 (PST)

> base the user, but not legalizes the user.  everyone had a similar

Did you set up a /etc/pam.d/imap file with the PAM rules that you need?

Does your client use an SSL connection to the IMAP server (port 993), or 
negotiate STARTTLS on port 143?  By default, you can not do password 
authentication in IMAP unless either SSL or TLS encryption is in effect. 
Read imap-200*/docs/SSLBUILD for more information.

-- Mark --

http://panda.com/mrc
Democracy is two wolves and a sheep deciding what to eat for lunch.
Liberty is a well-armed sheep contesting the vote.
_______________________________________________
Imap-uw mailing list
[email-masked]
https://mailman1.u.washington.edu/mailman/listinfo/imap-uw

---

From: "Jose Wilson A. do Nascimento" <[email-masked]>
Date: Tue, 6 Dec 2005 10:36:10 -0200 (EDT)

hi,

	What I am needing is to compile imap-uw with the options
PASSWDTYPE=pam and SSLTYPE=unix, but nao I am obtaining, leaves for error.
My system is the FreeBSD-5.4-STABLE.  Some suggestion

Building bundled tools...
cd mtest;make
`cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS` -c mtest.c
`cat ../c-client/CCTYPE` -I../c-client `cat ../c-client/CFLAGS` -o mtest
mtest.o ../c-client/c-client.a `cat ../c-client/LDFLAGS`
/usr/bin/ld: cannot find -ldl
*** Error code 1

Stop in /usr/local/src/imap-2004f/mtest.
*** Error code 1

Stop in /usr/local/src/imap-2004f.
*** Error code 1

Stop in /usr/local/src/imap-2004f.

---

From: Derlis Zárate <[email-masked]>
Date: Tue, 6 Dec 2005 10:59:27 -0300

Hi, 

To compile the program with this options
"make bsf SSLTYPE=unix PASSWDTYPE=pam"
you can use the FreeBSD ports tree.

There are two alternatives:

---------------
 (a) Option 1:
---------------
In FreeBSD, the cclient and imap-uw ports has the install target, but the way to establish the options differs from the imap-uw documentation.

To do "make bsf SSLTYPE=unix PASSWDTYPE=pam" in the ports I execute 
this commands

1) cclient:
   # cd /usr/ports/mail/cclient
   # vi Makefile
     Add: MAKE_ARGS+= PASSWDTYPE=pam
   # make WITH_SSL_AND_PLAINTEXT=yes install clean

2) imap-uw:
   # cd /usr/ports/mail/imap-uw
   # vi Makefile
     Add: MAKE_ARGS+= PASSWDTYPE=pam
   # make WITH_SSL_AND_PLAINTEXT=yes install clean

---------------
 (a) Option 2:
---------------
1) cclient:
   # cd /usr/ports/mail/cclient
   # vi files/patch-ab and adjust your parameters
   # make WITH_SSL_AND_PLAINTEXT=yes install clean
     Example of the first 13 lines of the file:
--- src/osdep/unix/Makefile.orig        Thu Apr 21 00:48:34 2005
+++ src/osdep/unix/Makefile     Mon May 30 19:08:25 2005
@@ -22,8 +22,8 @@

 EXTRAAUTHENTICATORS=
 EXTRADRIVERS=mbox
-PASSWDTYPE=std
-SSLTYPE=nopwd
+PASSWDTYPE=pam
+SSLTYPE=unix
 IP=4

2) imap-uw:
   # cd /usr/ports/mail/imap-uw
   # vi files/patch-ad and adjust your parameters
   # make WITH_SSL_AND_PLAINTEXT=yes install clean

     Example of the first 8 lines of the file patch-ad:
--- Makefile.orig       Tue Nov  5 01:19:13 2002
+++ Makefile    Thu Nov 28 00:11:51 2002
@@ -148,7 +148,7 @@
# std  system standard (typically passwd file), determined by port
# two  try alternative (defined by CHECKPWALT), then std

-PASSWDTYPE=std
+PASSWDTYPE=pam

-------------------
The first option works fine for me.

Espero haberte ayudado en algo.

Saludos, 
--
Derlis Zárate

On Tue, 6 Dec 2005 10:36:10 -0200 (EDT)

---

From: "Tomas Pospisek's Mailing Lists" <[email-masked]>
Date: Tue, 6 Dec 2005 15:00:31 +0100 (CET)

> /usr/bin/ld: cannot find -ldl

Does this [1] help?
*t

[1] http://www.google.com/search?hl=en&lr=&ie=UTF-8&oe=UTF-8&q=%22%2Fusr%2Fbin%2Fld%3A+cannot+find+-ldl%22&btnG=Search

--
-----------------------------------------------------------
   Tomas Pospisek
   http://sourcepole.com -  Linux & Open Source Solutions
-----------------------------------------------------------
_______________________________________________
Imap-uw mailing list
[email-masked]
https://mailman1.u.washington.edu/mailman/listinfo/imap-uw

---

From: "Jose Wilson A. do Nascimento" <[email-masked]>
Date: Tue, 6 Dec 2005 13:41:11 -0200 (EDT)

Hi Derlis,

	I made these tips and functioned perfectly.
	I am thankful all for the help.
	Thank´s

	Wilson