Subject: Re: Is UW IMAP compatible with HP-UX 11.0 or 11.11

From: Mark Crispin <[email-masked]>
Date: Tue, 10 Feb 2004 16:58:39 -0800 (Pacific Standard Time)

On Tue, 10 Feb 2004, Wingston Barahona wrote:
> We'd like to install the IMAP mail server, but in the file Makefile has 
> only until HP-UX 10.x.

In general, such indications as "for HP-UX 10.x" really mean "for HP-UX 
10.x and later versions".

> We have HP-UX 11.0 and 11.11 in our UNIX Server, and we'd like to know 
> if there are a new version of UW IMAP mail server compatible with this 
> platform, or if we can install the current version without any risks.

I no longer have access to any HP-UX systems, so I can not say with 
certainty.  However, the last time I tried to build on an HP-UX system it 
worked, and I believe that system was HP-UX 11.0.

I recommend that you try building it.  If it builds successfully, then it 
should work.

If it does not build, or if you have problems running it, please send me 
email and I will try to resolve the problem for you.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.

---

From: David B Funk <[email-masked]>
Date: Tue, 10 Feb 2004 19:51:40 -0600 (CST)

> worked, and I believe that system was HP-UX 11.0.
[snip..]

Works fine under HP-UX 11.0 & 11.11.
Currently running it under HP-UX 11.22 on an Itanium ZX6000,
had to tweek a few of the makefile parameters for IA64 platforms.

Dave

-- 
Dave Funk                                  University of Iowa
<dbfunk (at) engineering.uiowa.edu>        College of Engineering
319/335-5751   FAX: 319/384-0549           1256 Seamans Center
Sys_admin/Postmaster/cell_admin            Iowa City, IA 52242-1527
#include <std_disclaimer.h>
Better is not better, 'standard' is better. B{

---

From: Mark Crispin <[email-masked]>
Date: Thu, 12 Feb 2004 15:50:08 -0800 (Pacific Standard Time)

On Thu, 12 Feb 2004, Wingston Barahona wrote:
>      * OK Oracle IMAP4r1 (5.2.0.0.28) server ready
> -->  1 login user1 password
> -->  1 NO LOGIN failed

That is not UW imapd.  That is some other IMAP server implementation.

-- Mark --

---

From: "Wingston Barahona" <[email-masked]>
Date: Thu, 12 Feb 2004 18:55:47 -0600

Yes, It's correct but in this moment I want to login to IMAP Server but it's
imposible for me.

I'm Testing my IMAP4 connection
  =============================
  - do a telnet localhost 143
     Trying 127.0.0.1...
     Connected to localhost.
     Escape character is '^]'.
     * OK Oracle IMAP4r1 (5.2.0.0.28) server ready
-->  1 login user1 password
-->  1 NO LOGIN failed

This user is a valid user of UNIX System

Can you help me with this problem?

Wingston Barahona.

----- Original Message -----
From: "David B Funk" <[email-masked]>
To: "Mark Crispin" <[email-masked]>
Cc: "Wingston Barahona" <[email-masked]>;
<[email-masked]>; "Isaias Correa <drcc>"
<[email-masked]>
Sent: Tuesday, February 10, 2004 7:51 PM
Subject: Re: Is UW IMAP compatible with HP-UX 11.0 or 11.11

---

From: "Wingston Barahona" <[email-masked]>
Date: Thu, 12 Feb 2004 18:56:11 -0600

Wingston Barahona.

----- Original Message -----
From: "Mark Crispin" <[email-masked]>
To: "Wingston Barahona" <[email-masked]>
Cc: <[email-masked]>; "Isaias Correa <drcc>"
<[email-masked]>
Sent: Tuesday, February 10, 2004 6:58 PM
Subject: Re: Is UW IMAP compatible with HP-UX 11.0 or 11.11

---

From: Cliff Green <[email-masked]>
Date: Fri, 13 Feb 2004 09:37:39 -0500

> I'm Testing my IMAP4 connection
             ^^^^^^^^^^^^^^
> This user is a valid user of UNIX System

Maybe your Oracle server isn't looking at the system accounts for credentials.

A naive guess would be that the Oracle imap service is part of an Oracle
collaboration product, and requires the Oracle product to be configured -
perhaps to have the Oracle user db populated?  Just a guess.

c
--
Cliff Green
Academic Computing Services - UMDNJ
Signature under NDA