Subject: Marc v. Mark Syndrome, or Cathedral v. Bazaar

From: [email-masked]
Date: Mon, 19 Aug 2002 17:23:58 -0400

[
  In response to Marc Merlin's complaint that Mark
  Crispin doesn not acknowledge his patches but uses
  something like them with modifications...
 ]

Marc -- apparently, Mark is very much overloaded
by supporting UW imap singlei-handedly for so many
platforms and so many years.  In my brief time
spent searching archives, I see that it's a
one-man operation, and as such it's an amazing
feat as compared to Apache and other huge teams.
Thanks to clever decisions, some of which force me
to type the silly "I accept the risk" header into
/etc/cf-client.cf and ~/.imaprc (after which it's
just fine, contrary to the scary, scary, scary
docs:).  Minimalism is the only way to make it
possible, so you're probably overreacting in your
assessment.  Mark might have also considered
patches like yours before, and forcing people to
explain the wrongs they didn't commit usually are
sent to /dev/null, especially if there's a lot of
real problems and it looks like a non-issue to the
other side.  This is not to say patches should not
be acknowledged, but rather it stems from the
feature of the UW imap project that Mark is
de-facto BDFL, like Linus (Benevolent Dictator For
Life), and you may like it or not, which is your
prerogative, but you will not cause anybody to cry
by announcing your switch to some other imap
implementation.  Except for interesting
comparisons, which is not bad at all.  :)

As a more serious conclusion, I think Mark should
appoint some deputies, like Eric Raymond did with
fetchmail, in case, G-d forbid, something kicks
him out of the net for a while.  If there's a
community of mail administrators crucially
dependent on UW imap and knowing it to the level
of patching, which seems to be the case, the
proper thing to do is to form an Apache like group
for community maintained code, put it onto
Sourceforge, make Mark the only one who can commit
patches at first, and he can gradualy appoint
other established people to do that.  This way,
all patches would be evaluated by the community
and there wouldn't be single points of failure.
Otherwise it will lead to the abovementioned kind
of a problem, which I'd call Marc v. Mark merge
conflict, Marc/k Syndrome for short.  :)

Just my $0.02 (from too much exposure to Wharton:).

-- 
Cheers,
Alexy V. Khrabrov :: www.setup.org :: Age Quod Agis
-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Tue, 20 Aug 2002 13:47:52 -0700 (Pacific Daylight Time)

Thank you for your support.

On Mon, 19 Aug 2002, Alexy Khrabrov wrote:
> him out of the net for a while.

Actually, there are already such individuals: the other members of the UW
Pine team.  We have a division of responsibilities, and the UW IMAP
toolkit (c-client, imapd, etc.) is mine. However, in extraordinary
circumstances any of us could take over as needed.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.