Subject: Errors while decoding MIME-message

From: "Arne Knutsen" <[email-masked]>
Date: Mon, 3 May 1999 13:40:31 +0200

The following is from a MTEST-session trying to read a message with an
attachment:

MTest>b 8
00000004 FETCH 8 (BODYSTRUCTURE FLAGS)
* 8 FETCH (BODYSTRUCTURE (("text" "plain" ("charset" "iso-8859-1") NIL NIL
"7bit
" 170 11 NIL NIL NIL) ("application" "octet-stream" ("name" "PERMBACK.DRW")
NIL
NIL "base64" 480 NIL ("attachment" ("filename" "PERMBACK.DRW")) NIL) "mixed"
("b
oundary" "----=_NextPart_000_0035_01BE9559.DD9351C0") NIL NIL) FLAGS
(\SEEN))
%Not a string: ("application" "octet-stream" ("name" "PERMBACK.DRW") NIL NIL
"ba
se64" 480 NIL ("
%Missing multipart subtype
%Junk at end of multipart body: "application" "octet-stream" ("name"
"PERMBACK.D
RW") NIL NIL "base64" 480 NIL ("
%Unknown message property: "APPLICATION"
%Unknown message property: "OCTET-STREAM"
%Unknown message property: ("NAME"
%Unknown message property: "PERMBACK.DRW"
%Unknown message property: NIL
%Unknown message property: NIL
%Unknown message property: "BASE64"
%Unknown message property: 480
%Unknown message property: NIL
%Unknown message property: ("ATTACHMENT"
%Unknown message property: ("FILENAME"
%Unknown message property: "PERMBACK.DRW"
%Unknown message property: NIL
%Unknown message property: "MIXED"
%Unknown message property: ("BOUNDARY"
%Unknown message property: "----=_NEXTPART_000_0035_01BE9559.DD9351C0"
%Unknown message property: NIL
%Unknown message property: NIL
00000004 OK FETCH completed
 1 TEXT/PLAIN;charset=iso-8859-1 (11 lines)

Here comes the whole message:

MTest>l 8
00000005 FETCH 8 BODY[]
* 8 FETCH (BODY[] {2126}
)
00000005 OK FETCH completed
(8.6.9/8.6.9
) with SMTP id LAA04922 for <[email-masked]>; Mon, 3 May 1999 11:48:41
+020
0
From: "Arne Knutsen" <[email-masked]>
To: <[email-masked]>
Subject: Image
Date: Mon, 3 May 1999 11:41:21 +0200
Importance: Normal
Disposition-Notification-To: "Arne Knutsen" <[email-masked]>
Status: U

This is a multi-part message in MIME format.

------=_NextPart_000_0035_01BE9559.DD9351C0
Content-Type: text/plain;
        charset="iso-8859-1"
Content-Transfer-Encoding: 7bit

See attached image

------=_NextPart_000_0035_01BE9559.DD9351C0
Content-Type: application/octet-stream;
        name="PERMBACK.DRW"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
        filename="PERMBACK.DRW"

Af8CBAMCAAICAiEFAAQB/wP/ADMVBhQAC/8FAJABAFP/BQAit1N3aXNz/xoAMxXWEAAH/wUAvAL/
BAABAgEiU3lzdGVtAGVtRXgAZ2h0AOgAAQD2EFB/FwFTfyYAHgACCgAACA4AAP8C//8EAAIQAAAC
GcgAARgECBoBAAoACgABAAQWAQABAAwbSA0YFZABGAGQAQQBBAUAAAIABAn/BAACHQAAAhEBAFMH
C4DIAMgAvQC9AFcEexf/HQCEA6gWMv8IAP8D/wAUAAAy/wQAFP8EAAsACwALAAv/AwBTBxkA9gHQ
B/YB0Af4AkQOjAr/EgApAv8GABD/DQD/A///BQACAf8RAC0fAQAC/wMABgKHAMgAAf8DAM4H/wcA
ywACAf8EAHQGAgE5AiL/BQAiIgQf/wUAVQYCAVUGHwARAFVTQiBTcGVjaWZpY2F0aW9uECQEAAj/
DQAA/g==

------=_NextPart_000_0035_01BE9559.DD9351C0--

MTest>

Can anyone tell me what's wrong ?.

Arne

--
Arne Knutsen
Nera Satcom AS
Bergerveien 12
N-1375 Billingstad, Norway
Ph: +47 67 24 34 22
Fax: +47 67 24 44 45
URL: http://www.nera.no

---

From: Mark Crispin <[email-masked]>
Date: Mon, 3 May 1999 12:07:59 -0700 (PDT)

Whose IMAP server did you use?  It's definitely not my IMAP server, and I
doubt that it's Cyrus, Esys, or one of Microsoft's.

The IMAP server generated a bad BODYSTRUCTURE; in particular, there's a
spurious space between the two body part structures.  The counts in the first
part are completely bogus as well; they should be 22 octets, 2 lines but your
server says 170 byts, 11 lines.  In the second part, the count shows 480
octets when the correct value is 478 (it apparently spuriously counted the
trailing newline; read the MIME spec carefully to see why you don't do this).

---

From: "Arne Knutsen" <[email-masked]>
Date: Tue, 4 May 1999 08:01:44 +0200

The IMAP Server is: IMail 4.06 (Ipswitch ?)

Outlook 2000 Beta has no problems reading it (the attachments).

Embla (which I think is based on C-client) doesn't see the attachments.

Pine also has the same problems.

So is someone (Micro-Gates and others) making their own standard ?.

Arne

> -----Original Message-----
> From: Mark Crispin [mailto:[email-masked]]On Behalf Of Mark
> Crispin
> Sent: 03 May 1999 21:08
> To: Arne Knutsen
> Cc: C-client mailing list
> Subject: re: Errors while decoding MIME-message
>
>

---

From: Mark Crispin <[email-masked]>
Date: Mon, 3 May 1999 23:42:20 -0700 (PDT)

> The IMAP Server is: IMail 4.06 (Ipswitch ?)

You should report the problem to them.

> Outlook 2000 Beta has no problems reading it (the attachments).

It could be that Outlook is more forgiving of protocol errors.  However, the
underlying problem is with IMail.