Subject: IMAPD performance question?

From: "Kwangyeon Bae" <[email-masked]>
Date: Tue, 28 Mar 2000 12:33:41 +0900 (KST)

Hello!

We are planning to provide Email service by using UW-IMAPD.

We are wonding if UW-IMAPD can satisfy our requirements..

If anyone experiences IMAPD performance, would you please

give us your valuable advice !!

-- Our Service Requirement
 Maximum Users: 100,000
 Concurrent IMAP Sessions: 400
 Average User Connect Time Per Session: 5 minutes
 Average Disk Size per User: 50MB
 Average Disk Usage per Session: 500KB
 The number of Messages fetched per Session: 10
 Maximum Delay to fetch RFC822 header per Session: 3 seconds

-- Our Hardware Specification
 UltraSPARC IIi(Solaris 2.6 installed)
 CPU : 300 MHz
 Memory: 1 GB
 Hard Disk: 1 Fiber channel connected to SunStoreEdge A5100
 Hard Disk Size: 180GB

We hacked IMADP authention part to use User Directory Server..

So, we don't use /etc/passwd Scheme..

At first, We want to know if our hard spec can support the requirement.

and If that's impossible, what should we consider a little more ?

I heard that mbx format is faster than unix format.. It is true?

Any Comments will be appreciated..

Bae

-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: "Kwangyeon Bae" <[email-masked]>
Date: Wed, 29 Mar 2000 12:04:29 +0900 (KST)

Thanks for your valuable advices about IMAPD performance!!

We have anothoer question on using IMAPD..

At first, we worried about file system approach because

It can be broken during File I/O.

We are hacking IMAPD to use Oracle Database when storing Mailbox.

That project is almost finished. But during that project, we 

were concerned about Oracle Database approach is better than 

File system approach in performance and reliability.

If anyone experienced Database approach, would you please give

us your valuable advice !!

Any comments will be appreciated...

Bae