Subject: c-client lib really needs a version function...

From: Vicki Brown <[email-masked]>
Date: Mon, 9 Sep 2002 15:42:27 -0700

PHP has no way of knowing which version of c-client it's built with.
So, it makes a guess about which version it thinks it WILL be 
built with. If it's wrong, there's no way to check.

sigh.
- Vicki

---

From: Mark Crispin <[email-masked]>
Date: Mon, 9 Sep 2002 16:07:17 -0700 (Pacific Daylight Time)

> built with. If it's wrong, there's no way to check.

It shouldn't matter to PHP which version of c-client it was built with.
If PHP cares what version it was built with, it is doing something wrong.

---

From: "Jeff Breitner" <[email-masked]>
Date: Mon, 9 Sep 2002 19:26:13 -0400

What's the effect if it guesses wrong?  I've never had an issue with PHP
linking in the c-client library.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Vicki Brown
Sent: Monday, September 09, 2002 6:42 PM
To: [email-masked]
Subject: c-client lib really needs a version function...

PHP has no way of knowing which version of c-client it's built with.
So, it makes a guess about which version it thinks it WILL be built
with. If it's wrong, there's no way to check.

sigh.
- Vicki