Subject: imap server and S/MIME issues with attachments

From: Noam Bernstein <[email-masked]>
Date: Tue, 21 Sep 2004 13:17:03 -0400

Hi - I'm having problems reading S/MIME signed e-mail with
attachments when I get the mail through the UW imap daemon.
The server is a SuSE 9.0 machine running imap-2002d-55.
The client is a Mac OS 10.3 running Thunderbird 0.8.  By
default I get the ? signature because the MIME parts aren't
downloaded.  When I change the Thunderbird preferences
(undocumented mail.server.default.mime_parts_on_demand
and mail.imap.mime_parts_on_demand, set both to false)
I can get it to download all the MIME parts
automatically, but then I get the broken signature icon
(message content doesn't match signature).  When I do the
same through a different IMAP server (don't know what kind -
whatever speakeasy.net uses) it shows a valid signature.
I.e. I suspect that the UW imap server must be modifying
the message in the process of disentangling the MIME parts.

Has anyone else seen this problem?  Is there a known solution?

					thanks,
					Noam Bernstein

---

From: Jim Riggs <[email-masked]>
Date: Tue, 21 Sep 2004 12:30:18 -0500

On 21 Sep, 2004, at 12:17, Noam Bernstein wrote:

> The client is a Mac OS 10.3 running Thunderbird 0.8.

I have no problems with S/MIME in my setup:

Server: darwin 6.6/imap-2002e
Client: Mac OS X (10.3) Mail

---

From: Niklas Fondberg <[email-masked]>
Date: Tue, 21 Sep 2004 19:43:39 +0200

I've written a small email (imap/pop3/smtp) client daemon on an embedded 
linux system. I want to be able to notify another daemon when new mail 
arrives and therefor I'm planning on having a seperate thread for this.

Q1. Which is the most efficient way to see if there is new mail?

My first idé would be to have a search for messages newer than last 
search because otherwise I would have to rely on flags set on the server 
(right) and I have to leave messages on pop3 servers.

Q2. Does anybody have any ideas?

Greatful for replies

/Niklas Fondberg

---

From: Mark Crispin <[email-masked]>
Date: Tue, 21 Sep 2004 10:46:32 -0700 (Pacific Daylight Time)

On Tue, 21 Sep 2004, Noam Bernstein wrote:
> I suspect that the UW imap server must be modifying

UW imapd does not modify the message in any way.

However, if you use traditional UNIX format, the mail delivery system may 
modify the message by inserting ">" in front of any line that starts with 
"From".

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.

---

From: Mark Crispin <[email-masked]>
Date: Tue, 21 Sep 2004 10:49:10 -0700 (Pacific Daylight Time)

On Tue, 21 Sep 2004, Niklas Fondberg wrote:
> My first idea would be to have a search for messages newer than last search 
> because otherwise I would have to rely on flags set on the server (right) and 
> I have to leave messages on pop3 servers.

If you have an IMAP session open when the new mail is delivered, then you 
will see the new messages in the session without having to do a SEARCH.

Otherwise, recall the UID of the last message in the mailbox, then you can 
use <last UID + 1>:* to reference messages since that time.

-- Mark --