Subject: Folder listing

From: Fouad Kassab <[email-masked]>
Date: Wed, 23 Oct 2002 02:15:32 -0400

hello there,
I would be greatful for any help in this matter.
how do we get the folder listing once we log in to an IMAP 
server? i had supposed it would be select "*" "*" but that 
gives me folders and files as well. im not sure as to how to 
list just folders.
thank you for your help
Fouad

________________________________________________
Get your own "800" number
Voicemail, fax, email, and a lot more
http://www.ureach.com/reg/tag
-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Wed, 23 Oct 2002 06:58:34 -0700 (PDT)

> gives me folders and files as well. im not sure as to how to

If you get non-mailbox "files", that means that it isn't possible to tell the
difference between something that is a mailbox and something that is not.  In
UW imapd, it is possible to select non-mailbox files, so the difference is
essentially meaningless.

If you don't want to see non-mailbox "files", the way to do this is to
organize your data so that mailboxes are in a distinct place, and then only
look in that distinct place.

I eschew the imprecise term "folder" since that implies "directory".