Subject: imapd 2004a crashing frequently

From: Beernd Noordkamp <[email-masked]>
Date: Mon, 30 Aug 2004 09:30:19 +0200

Hi all.

Imapd (UW IMAP 2004a on MacOS 10.3.5) has been crashing a lot on me  
lately: 343 times in eleven days. I'm not exactly sure what is going on  
when this happens, because I hardly notice anything at all in the  
client. In fact, this has been happening this often since I installed  
2004a; before that, I've had this problem only two times. Before 2004a  
I used imap-2004a.DEV.SNAP-0405261606, which hasn't crashed once. The  
crashlogs from crashreporterd look very similar, last time it read:

> Host Name:      iBook.local
> Date/Time:      2004-08-29 14:53:17 +0200
> OS Version:     10.3.5 (Build 7M34)
> Report Version: 2
>
> Command: imapd
> Path:    /usr/local/sbin/imapd
> Version: ??? (???)
> PID:     20385
> Thread:  0
>
> Exception:  EXC_BAD_ACCESS (0x0001)
> Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000
>
> Thread 0 Crashed:
> 0   imapd 	0x00045594 mbx_ping + 0x300 (mbx.c:778)
> 1   imapd 	0x00044c38 mbx_open + 0x294 (mbx.c:525)
> 2   imapd 	0x0001ba0c mail_open + 0x6f0 (mail.c:1206)
> 3   imapd 	0x000047b0 main + 0x2408 (imapd.c:809)
> 4   imapd 	0x00001e98 _start + 0x188 (crt.c:267)
> 5   dyld  	0x8fe1a558 _dyld_start + 0x64
>
> PPC Thread State:
>   srr0: 0x00045594 srr1: 0x0000f030                vrsave: 0x00000000
>     cr: 0x24000422  xer: 0x0000001a   lr: 0x00045468  ctr: 0x90010400
>     r0: 0x00045468   r1: 0xbfffe7d0   r2: 0x00000000   r3: 0x00000000
>     r4: 0x00000000   r5: 0xbfffe1a0   r6: 0x0000002c   r7: 0x00000c03
>     r8: 0x00000000   r9: 0x00000000  r10: 0x018001c8  r11: 0x000b3e08
>    r12: 0x90010400  r13: 0x00000001  r14: 0x000b4c5c  r15: 0x000b23c4
>    r16: 0x00000000  r17: 0x000b4c60  r18: 0x000c4cc0  r19: 0x000b4c70
>    r20: 0xbfffff70  r21: 0x00000000  r22: 0xbfffff30  r23: 0x00000001
>    r24: 0x00000000  r25: 0x00000000  r26: 0xbfffff2c  r27: 0x00000005
>    r28: 0x00000000  r29: 0x00000000  r30: 0x00402270  r31: 0x000452a8
>
> Binary Images Description:
>     0x1000 -    0xb1fff imapd 	imapd
>   0x19f000 -   0x19ffff pam_securityserver.so  
> 	/usr/lib/pam/pam_securityserver.so
>   0x1a2000 -   0x1a2fff pam_unix.so 	/usr/lib/pam/pam_unix.so
>   0x1a5000 -   0x1a5fff pam_deny.so 	/usr/lib/pam/pam_deny.so
>   0x1ad000 -   0x1affff pam_netinfo.so 	/usr/lib/pam/pam_netinfo.so
> 0x8fe00000 - 0x8fe4ffff dyld 	/usr/lib/dyld
> 0x90000000 - 0x90122fff libSystem.B.dylib 	/usr/lib/libSystem.B.dylib
> 0x90190000 - 0x9023dfff com.apple.CoreFoundation 6.3.4  
> (299.31)	/System/Library/Frameworks/CoreFoundation.framework/Versions/ 
> A/CoreFoundation
> 0x90280000 - 0x904f9fff com.apple.CoreServices.CarbonCore  
> 10.3.5	/System/Library/Frameworks/CoreServices.framework/Versions/A/ 
> Frameworks/CarbonCore.framework/Versions/A/CarbonCore
> 0x90570000 - 0x905dffff com.apple.framework.IOKit 1.3.5  
> (???)	/System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
> 0x907f0000 - 0x907f9fff com.apple.DiskArbitration  
> 2.0.3	/System/Library/PrivateFrameworks/DiskArbitration.framework/ 
> Versions/A/DiskArbitration
> 0x90d00000 - 0x90d1bfff com.apple.SystemConfiguration 1.7.1  
> (???)	/System/Library/Frameworks/SystemConfiguration.framework/ 
> Versions/A/SystemConfiguration
> 0x910b0000 - 0x91101fff com.apple.bom 1.2.5  
> (63.2)	/System/Library/PrivateFrameworks/Bom.framework/Versions/A/Bom
> 0x920c0000 - 0x922a7fff com.apple.security 2.4  
> (177)	/System/Library/Frameworks/Security.framework/Versions/A/ 
> Security
> 0x939d0000 - 0x939d4fff libmathCommon.A.dylib  
> 	/usr/lib/system/libmathCommon.A.dylib
> 0x945b0000 - 0x945b9fff libz.1.dylib 	/usr/lib/libz.1.dylib
> 0x968d0000 - 0x969b2fff libicucore.A.dylib 	/usr/lib/libicucore.A.dylib
> 0x96a20000 - 0x96ae2fff libcrypto.0.9.7.dylib  
> 	/usr/lib/libcrypto.0.9.7.dylib
> 0x96b40000 - 0x96b6efff libssl.0.9.7.dylib 	/usr/lib/libssl.0.9.7.dylib
> 0x96dc0000 - 0x96dd3fff libpam.1.dylib 	/usr/lib/libpam.1.dylib

(Sorry about the large amount of data, I thought all of this might be  
relevant.)
I use mbx-mailboxes and compiled using make oxp SSLTYPE=unix. I made a  
few small changes to the source code:
• in src/osdep/unix/Makefile I changed
> CREATEPROTO=unixproto
to
> CREATEPROTO=mbxproto
• in src/osdep/unix/env_unix.c, I used the following alteration of  
mymailboxdir():
> static char *mymailboxdir ()
> {
>   unsigned long flags;
>   char *user = myusername_full (&flags);
>                                 /* initialize if first time and logged  
> in */
>   if (!myMailboxDir && !(flags & MU_NOTLOGGEDIN)) {
>       char tmp[MAILTMPLEN];
>     sprintf (tmp,"/var/imap/%s",myusername ());
>     myMailboxDir = cpystr (tmp);/* use subdirectory of /var/imap */
>   }
>   return myMailboxDir ? myMailboxDir : "";
> }
• in the same rc/osdep/unix/env_unix.c, I changed
> static short hideDotFiles = NIL;/* hide files whose names start with .  
> */
to
> static short hideDotFiles = T;/* hide files whose names start with . */

I've used these changes for two years or so, and they've always worked  
just fine.
Should I provide any more information?

Any ideas on what might be going wrong?

Thanks a lot.

	Beernd Noordkamp
-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Mon, 30 Aug 2004 01:18:51 -0700 (PDT)

This is a known problem, and is fixed in the imap-2004b development 
snapshot.

If it makes you feel any better, this crash only happens with a session 
which is already in the process of terminating; it doesn't affect an 
active session.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.