Subject: More: NEWBIE: Looking for web-based, IMAPS compatible e-mail product

From: "John Pritchard" <[email-masked]>
Date: Mon, 9 Jun 2003 10:42:32 -0500

Maybe I am approaching this from the wrong perspective.  The webmail and
imap are on the same system.  When I compile IMAP the default 'make'
forces it to be secure with no clear text password capability.  If I am
following Erik and Josko correctly, I may need to do one of the
following
    a) compile imap with certain options (I could use some help with
knowing which) so that IMAP does not require secure communication from
the webmail product
    b) use stunnel (which, again, I might need some help understanding
what I need where)
 
Thanks a bunch.
 
John Pritchard
Catalyst Solutions
 
-------------------------------
 
Original Post...
 
I recently installed a RedHat Linux 7.2 system.  I have all the latest
updates (up2date) and have loaded uw-imap.  I have been successful in
connecting to the e-mail to get POP and IMAP working via SSL.  I would
like to provide Web-Based e-mail access to the system.  I intended to
use SqirrelMail, but read in the notes that it does not work with IMAPS.
Does anyone have another suggestion or has someone found how to get
SqirrelMail to work without enabling plain text passwords?
 
John Pritchard
Catalyst Solutions

---

From: "Nick Hodulik" <[email-masked]>
Date: Mon, 9 Jun 2003 08:50:49 -0700

I have squirrelmail running with SSL-enabled imapd on the same box, and I had to do absolutely no special configuration for either. I compiled imapd with SSLTYPE=unix rather than the default SSLTYPE=nopwd, which may be why it works so easily for me. You could conceivably do the same thing, then do some sort of firewalling or hosts.deny to disallow any connections to port 143, the standard IMAP port, from any machine other than localhost.

n
  ----- Original Message ----- 
  From: John Pritchard 
  To: [email-masked] 
  Sent: Monday, June 09, 2003 8:42 AM
  Subject: More: NEWBIE: Looking for web-based, IMAPS compatible e-mail product

  Maybe I am approaching this from the wrong perspective.  The webmail and imap are on the same system.  When I compile IMAP the default 'make' forces it to be secure with no clear text password capability.  If I am following Erik and Josko correctly, I may need to do one of the following
      a) compile imap with certain options (I could use some help with knowing which) so that IMAP does not require secure communication from the webmail product
      b) use stunnel (which, again, I might need some help understanding what I need where)

  Thanks a bunch.

  John Pritchard
  Catalyst Solutions

  Original Post...

  I recently installed a RedHat Linux 7.2 system.  I have all the latest updates (up2date) and have loaded uw-imap.  I have been successful in connecting to the e-mail to get POP and IMAP working via SSL.  I would like to provide Web-Based e-mail access to the system.  I intended to use SqirrelMail, but read in the notes that it does not work with IMAPS.  Does anyone have another suggestion or has someone found how to get SqirrelMail to work without enabling plain text passwords?

  John Pritchard
  Catalyst Solutions

---

From: "Oliver Schulze L." <[email-masked]>
Date: Mon, 09 Jun 2003 12:47:44 -0400

You have RH7.2 and imaps is already included in RH7.2
Just enabled it in xinetd or via ntsysv.
No need to recompile wu-imap

Oliver

John Pritchard wrote:

> Maybe I am approaching this from the wrong perspective.  The webmail 
> and imap are on the same system.  When I compile IMAP the default 
> 'make' forces it to be secure with no clear text password capability.  
> If I am following Erik and Josko correctly, I may need to do one of 
> the following
> use SqirrelMail, but read in the notes that it does not work with 
> IMAPS.  Does anyone have another suggestion or has someone found how 
> to get SqirrelMail to work without enabling plain text passwords?
>  
> John Pritchard
> Catalyst Solutions

-- 
Oliver Schulze L.
<[email-masked]>