Subject: WU imapd-2002 authentication problem on solaris 8

From: Allen Lu <[email-masked]>
Date: Wed, 30 Jul 2003 14:30:49 -0700 (PDT)

> Hello sirs,
> 
> I'm trying out your imapd, ultimately wanting to use it with SquirrelMail. I
> narrowed my authentication problems to imapd.
> 
> $ telnet localhost 143
> Trying 127.0.0.1...
> Connected to localhost.
> Escape character is '^]'.
> * OK [CAPABILITY IMAP4REV1 LOGIN-REFERRALS STARTTLS LOGINDISABLED] localhost
> IMAP4rev1 2003.338 at Wed, 30 Jul 2003 14:06:45 -0700 (PDT)
> a login alu allen123
> a NO LOGIN failed
> a logout
> * BYE ultra IMAP4rev1 server terminating connection
> a OK LOGOUT completed
> Connection closed by foreign host.
> $ cat /etc/passwd
> .
> .
> alu:x:1000:1::/homes/alu:/bin/sh
> 
> Is there a reason why authentication is failing? I am using openssl and it is
> installed under /usr/local/ssl.

__________________________________
Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software
http://sitebuilder.yahoo.com
-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Dirk Jahnke <[email-masked]>
Date: Thu, 31 Jul 2003 09:01:36 +0200

Hi Allen,

>> Is there a reason why authentication is failing? I am using openssl and
>> it is installed under /usr/local/ssl.

You mention Solaris 8 in the subject.  Did you alter the /etc/pam.conf
appropriately, so there is a service "imap" (also an imaps for SSL)
or at least the "other" service catches the login-like request
according to your Solaris installation?

Could be a starting point for further investigations.

Best regards,

--
Dirk Jahnke                            IT Systems / Bldg. 2b / Room 221
DESY Hamburg                           Deutsches Elektronen-Synchrotron
D-22603 Hamburg                        Notkestrasse 85  / 22607 Hamburg
Tel: +49-40-899.8.1760    Fax: +49-40-899.4.1760    [email-masked]

---

From: Allen Lu <[email-masked]>
Date: Thu, 31 Jul 2003 08:25:24 -0700 (PDT)

Thanks Dirk,

This was it. I hadn't read the docs carefully in the SSLBUILD. Tried
SSLTYPE=unix and now it works. Next step..make it secured! :)

Thanks

Allen