Subject: mtest with rockliffe's Mail Site.

From: "scpark" <[email-masked]>
Date: Mon, 24 Aug 1998 12:30:59 +0900

Help me.
I've installed MailSite (mail server for Windows NT of Rockliffe) and
found mtest didn't work properly. I don't know about IMAP. So, I list
mtest messages bottom. Please, someone check it and let me know what is
problem.

------------------------ message of mtest

MTest -- C client test program
Debug protocol (y/n)?y
Mailbox ('?' for help): {scpark.infoweb.co.kr}INBOX
%rsh to IMAP server timed out
[Trying IP address [210.105.42.121]]
* OK scpark.infoweb.co.kr MailSite IMAP4 Server 2.1.5 ready
[scpark.infoweb.co.kr MailSite IMAP4 Server 2.1.5 ready]
00000000 CAPABILITY
* CAPABILITY IMAP4rev1 ACL AUTH=CRAM-MD5
00000000 OK CAPABILITY completed
{[210.105.42.121]/imap} username: ljhwang
Password:
00000003 LOGIN ljhwang "********"
00000003 OK LOGIN completed
00000004 SELECT INBOX
* FLAGS (\Answered \Flagged \Deleted \Seen \Draft \*)
* 1 EXISTS
* 0 RECENT
* OK [PERMANENTFLAGS (\Answered \Flagged \Deleted \Seen \Draft \*)]
* OK [UNSEEN 0]
[[UNSEEN 0]]
* OK [UIDVALIDITY 276399903] UIDs are valid
00000004 OK [READ-WRITE] opened INBOX
Mon, 24 Aug 1998 11:53:23 +0900 (KST)
 imap mailbox: {scpark.infoweb.co.kr:143/imap/user=ljhwang}INBOX, 1
messages, 0 recent
MTest>b 1
00000005 FETCH 1 (ENVELOPE BODY.PEEK[HEADER.FIELDS (Path Message-ID
Newsgroups Followup-To References)] B
ODYSTRUCTURE UID INTERNALDATE RFC822.SIZE FLAGS)
* 1 FETCH (ENVELOPE ("Fri, 07 Aug 1998 11:47:29 +0900" "test"
(("Sungchul Park " NIL "scpark" "infoweb.co
.kr")) (("Sungchul Park " NIL "scpark" "infoweb.co.kr")) (("Sungchul
Park " NIL "scpark" "infoweb.co.kr")
) ((NIL NIL "ljhwang" "scpark.infoweb.co.kr")) NIL NIL NIL
"<[email-masked]>") BODY[HEADE
R.FIELDS ("References" "Followup-To" "Newsgroups" "Message-ID" "Path")]
{46}
 BODYSTRUCTURE (("TEXT" "plain" ("CHARSET" "us-ascii") NIL NIL "7BIT" 6
1 NIL NIL NIL) ("TEXT" "x-vcard"
("CHARSET" "us-ascii" "NAME" "vcard.vcf") NIL "Card for Sungchul Park"
"7BIT" 475 15 NIL ("attachment" ("
filename" "vcard.vcf")) NIL)  "mixed" ("BOUNDARY"
"------------3431FFE1FCD97ED23985B03A")) UID 276399903
INTERNALDATE " 7-Aug-1998 02:47:29 +0000" RFC822.SIZE 1511 FLAGS
(\Seen))
%Not a string: ("TEXT" "x-vcard" ("CHARSET" "us-ascii" "NAME"
"vcard.vcf") NIL "Card for Sungchu
%Missing multipart subtype
%Junk at end of multipart body: "TEXT" "x-vcard" ("CHARSET" "us-ascii"
"NAME" "vcard.vcf") NIL "Card for
Sungchu
%Unknown message property: "TEXT"
%Unknown message property: "X-VCARD"
%Unknown message property: ("CHARSET"
%Unknown message property: "US-ASCII"
%Unknown message property: "NAME"
%Unknown message property: "VCARD.VCF"
%Unknown message property: NIL
%Unknown message property: "CARD
%Unknown message property: FOR
%Unknown message property: SUNGCHUL
%Unknown message property: PARK"
%Unknown message property: "7BIT"
%Unknown message property: 475
%Unknown message property: 15
%Unknown message property: NIL
%Unknown message property: ("ATTACHMENT"
%Unknown message property: ("FILENAME"
%Unknown message property: "VCARD.VCF"
%Unknown message property: NIL
%Unknown message property: "MIXED"
%Unknown message property: ("BOUNDARY"
%Unknown message property: "------------3431FFE1FCD97ED23985B03A"
00000005 OK FETCH completed
 1 TEXT/PLAIN;CHARSET=us-ascii (1 lines)
MTest>q
00000006 LOGOUT
* BYE IMAP4 Server logging out
00000006 OK LOGOUT completed

---

From: Mark Crispin <[email-masked]>
Date: Mon, 24 Aug 1998 08:30:43 -0700 (PDT)

The problem is a bug in the IMAP server.  I didn't look at it in detail,
but it looks like the server writes spurious spaces between bodystructure
elements.  Contact the server vendor.