Subject: [Imap-uw] Imapd-2004e and Solaris 10

From: "Jozef Rujak" <[email-masked]>
Date: Wed, 17 Aug 2005 13:06:05 +0200

Hi,

does anybody managed to compile and run imapd2004e under Solaris 10?
It seems me that imapd needs libc.a which is not available for Solaris 10.

During compilation i see line:

sh -c '(strings /lib/libc.a | grep getpassphrase > /dev/null) && ln -s os_soln.h os_sol.h || ln -s os_solo.h os_sol.h'
/lib/libc.a: No such file or directory

And when i used impad and want to connect to server with thunderbird 
in syslog i have messages:

Aug 17 11:54:30 nstest imapd[1779]: [ID 298158 mail.debug] imaps SSL service init from 193.87.248.75
Aug 17 11:54:42 nstest imapd[1779]: [ID 149382 mail.info] Unable to accept SSL connection, host=dodi.intas.sk [193.87.248.75]Aug 17 11:54:42 nstest imapd[1779]: [ID 853321 mail.error] SSL error status: error:140D308A:SSL routines:TLS1_SETUP_KEY_BLOCK:cipher or hash unavailable

Aug 17 11:54:13 nstest imapd[1778]: [ID 298158 mail.debug] imaps SSL service init from 193.87.248.75
Aug 17 11:54:13 nstest imapd[1778]: [ID 149382 mail.info] Unable to accept SSL connection, host=dodi.intas.sk [193.87.248.75]Aug 17 11:54:13 nstest imapd[1778]: [ID 853321 mail.error] SSL error status: error:1409D08A:SSL routines:SSL3_SETUP_KEY_BLOCK:cipher or hash unavailable

Does anybody know how to solve this problem ?

Jozef

Aktivujte si aj vy schranku s neobmedzenou kapacitou na ATLAS.SK.
http://mail.atlas.sk

_______________________________________________
Imap-uw mailing list
[email-masked]
https://mailman1.u.washington.edu/mailman/listinfo/imap-uw

---

From: Mark Crispin <[email-masked]>
Date: Wed, 17 Aug 2005 08:39:23 -0700 (PDT)

> /lib/libc.a: No such file or directory

Don't worry about this.  It is just a check to see whether the C library 
has the getpassphrase() call, and if so that is used when building 
mailutil instead of getpass().

> Aug 17 11:54:13 nstest imapd[1778]: [ID 149382 mail.info] Unable to accept SSL connection, host=dodi.intas.sk [193.87.248.75]
> Aug 17 11:54:13 nstest imapd[1778]: [ID 853321 mail.error] SSL error status: error:1409D08A:SSL routines:SSL3_SETUP_KEY_BLOCK:cipher or hash unavailable
> Aug 17 11:54:42 nstest imapd[1779]: [ID 149382 mail.info] Unable to accept SSL connection, host=dodi.intas.sk [193.87.248.75]
> Aug 17 11:54:42 nstest imapd[1779]: [ID 853321 mail.error] SSL error status: error:140D308A:SSL routines:TLS1_SETUP_KEY_BLOCK:cipher or hash unavailable

This is the problem that you need to look into.  It's a problem within 
OpenSSL.  It may have been built incorrectly.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.
_______________________________________________
Imap-uw mailing list
[email-masked]
https://mailman1.u.washington.edu/mailman/listinfo/imap-uw

---

From: Chris Ross <[email-masked]>
Date: Wed, 17 Aug 2005 14:15:46 -0400

On Aug 17, 2005, at 11:39, Mark Crispin wrote:
>> sh -c '(strings /lib/libc.a | grep getpassphrase > /dev/null) && ln 
>> -s os_soln.h os_sol.h || ln -s os_solo.h os_sol.h'
> Don't worry about this.  It is just a check to see whether the C 
> library has the getpassphrase() call, and if so that is used when 
> building mailutil instead of getpass().

   Still of some issue, tho.  Isn't getpassphrase preferred and/or 
better?  It seems like
another mechanism should be found to test for it is /lib/libc.a has 
gone away
in Solaris 10...

                        - Chris

---

From: Mark Crispin <[email-masked]>
Date: Wed, 17 Aug 2005 11:53:30 -0700 (PDT)

On Wed, 17 Aug 2005, Chris Ross wrote:
> Isn't getpassphrase preferred and/or better?

It's "preferred" in that it permits longer passwords than the legacy 
getpass().  On most other systems they just increased the length that 
getpass() returns.

If you don't need passwords longer than 8 characters in the mailutil 
program, it doesn't matter either way.  It is not an imapd issue in any 
way.

> It seems like another mechanism should be found to test for it is 
> /lib/libc.a has gone away in Solaris 10...

I agree, but getting the necessary information out of Sun is like pulling 
teeth.  This is not the first time that something like this has happened. 
Past experience makes me reluctant to waste much more time with Sun, 
especially since this particular question only affects mailutil.

In general, SVR4 based systems (such as Solaris, HP-UX, and AIX) are not 
recommended platforms for an IMAP server.  These systems are expensive and 
the SVR4 kernel has severe deficiencies which render it particularly 
unsuitable for IMAP usage.

BSD and Linux are technically far superior to SVR4 for IMAP service, cost 
much less, and run on much less expensive hardware.

-- Mark --

---

From: Chris Ross <[email-masked]>
Date: Wed, 17 Aug 2005 15:59:21 -0400

On Aug 17, 2005, at 14:53, Mark Crispin wrote:
> program, it doesn't matter either way.  It is not an imapd issue in 
> any way.
>
> I agree, but getting the necessary information out of Sun is like 
> pulling teeth.  This is not the first time that something like this 
> has happened. Past experience makes me reluctant to waste much more 
> time with Sun, especially since this particular question only affects 
> mailutil.
>
> In general, SVR4 based systems (such as Solaris, HP-UX, and AIX) are 
> not recommended platforms for an IMAP server.  These systems are 
> expensive and the SVR4 kernel has severe deficiencies which render it 
> particularly unsuitable for IMAP usage.
>
> BSD and Linux are technically far superior to SVR4 for IMAP service, 
> cost much less, and run on much less expensive hardware.

   This is clearly an opinion issue.  Your cost issues are not relevant, 
now
that Solaris 10 is free, and runs on the same x86/amd64 hardware your
BSD and Linux versions do.

   I am one who prefers BSD systems myself, but you shouldn't make
such pronouncements about Solaris, or SysV in general.

   Why don't you solve this the same way autoconf does?  Ship a little
5 line program that you try to link.  If it links, you know there's a
getpassphrase.  If not, you can presume there's not.  I know it's
not the cleanest way, but it does do the job and is easier than
pulling teeth.

                                         - Chris

---

From: Mark Crispin <[email-masked]>
Date: Wed, 17 Aug 2005 13:20:46 -0700

> such pronouncements about Solaris, or SysV in general.

Solaris, like all other SVR4 type systems, has serious technical 
deficiences in its kernel which render it unsuitable for use with an IMAP 
server.

This is my opinion, but it is strongly rooted in verifiable fact.

-- Mark --