Subject: uw-imapd doesn't see INBOX

From: Csigas <[email-masked]>
Date: Mon, 2 Jun 2003 20:36:42 +0200 (CEST)

Hi!

I have a relatively clean Debian woody Linux:
apt-get install uw-imapd-ssl

I try different mail client (mutt, pine, outlook), and with all i have the
same problem. I can't see my INBOX, that lies at /var/spool/mail.
I can use any other mailbox-files in the user's home directory.

Nothing interesting is in the log, except "Command stream end of file,
while reading line... " - which is considered normal.

I try with and without SSL.

I'm on a private LAN(192.168.1.x), which connects to internet with NAT.

I have no idea what the problem is.
Any idea? Is there a good docomentation on manual IMAP commands (except
the RFC)?

Thanks!

Nandor Toth

PS.
.muttrc:
set folder="{backup.vogelburda.private}"
set spoolfile="{backup.vogelburda.private}inbox"
.pinerc:
incoming-folders={backup}inbox
inbox-path={backup.vogelburda.private}inbox

PS2. A little weird thing:
When i try pine, this is printed on the monitor:
The authenticity of host 'backup.vogelburda.private (192.168.1.5)' can't
be established.RSA key fingerprint is
47:bf:57:ec:45:18:b8:c4:e5:3f:5c:e3:0b:dc:51:88.
Exactly the same thing, when i try ssh [email-masked]
-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Mon, 2 Jun 2003 18:17:27 -0700 (Pacific Daylight Time)

> I can use any other mailbox-files in the user's home directory.

Log in to the shell on the IMAP server system, and run the mtest program
that is included with the IMAP package.  To the "Mailbox" prompt, answer
	INBOX
What is the exact text of the response that comes back?

Also, try a copy of UW imapd direct from UW, on:
	ftp://ftp.cac.washington.edu/mail/imap.tar.Z

I don't know if Debian has made any modifications which may have broken
the copy that they distribute.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.

---

From: Csigas <[email-masked]>
Date: Tue, 3 Jun 2003 22:34:39 +0200 (CEST)

Hi!

> What is the exact text of the response that comes back?

Success! But i have to wait ~10 minutes... :( that's not good. any idea?
(i suppose the mail clients gived up earlier than 10 minutes)

Thanks!!!

nug@backup:/root$ mtest
MTest -- C client test program
Personal name: nug
Debug protocol (y/n)?y
Mailbox ('?' for help): INBOX
%Mailbox vulnerable - directory /var/mail must have 1777 protection
Tue, 3 Jun 2003 21:24:44 +0200 (CEST)
 unix mailbox: /var/mail/nug, 2 messages, 0 recent

If i choose {backup}inbox

backup:~# su nug
nug@backup:/root$ mtest
MTest -- C client test program
Personal name: nug
Debug protocol (y/n)?y
Mailbox ('?' for help): {backup}inbox
[email-masked]'s password:
[Trying IP address [192.168.1.5]]
* OK [CAPABILITY IMAP4REV1 X-NETSCAPE LOGIN-REFERRALS AUTH=LOGIN]
backup.vogelburda.private IMAP4rev1 2001.315 at Tue, 3 Jun 2003 20:09:38
+0200 (CEST)
00000000 AUTHENTICATE LOGIN
+ VXNlciBOYW1lAA==
{backup.vogelburda.private/imap} username: [email-masked]'s
password:
[email-masked]'s password:
asd123
Password:
<suppressed>
+ UGFzc3dvcmQA
<suppressed>
00000000 NO AUTHENTICATE LOGIN failed
%Retrying LOGIN authentication after AUTHENTICATE LOGIN failed
00000001 AUTHENTICATE LOGIN
+ VXNlciBOYW1lAA==
{backup.vogelburda.private/imap} username: nug
Password:
<suppressed>
+ UGFzc3dvcmQA
<suppressed>
00000001 OK [CAPABILITY IMAP4REV1 X-NETSCAPE NAMESPACE MAILBOX-REFERRALS
SCAN SORT THREAD=REFERENCES THREAD=ORDEREDSUBJECT MULTIAPPEND] User nug
authenticated
00000002 SELECT inbox
* 2 EXISTS
* NO Mailbox vulnerable - directory /var/mail must have 1777 protection
%Mailbox vulnerable - directory /var/mail must have 1777 protection
* 0 RECENT
* OK [UIDVALIDITY 1054221903] UID validity status
* OK [UIDNEXT 3] Predicted next UID
* FLAGS (\Answered \Flagged \Deleted \Draft \Seen)
* OK [PERMANENTFLAGS (\* \Answered \Flagged \Deleted \Draft \Seen)]
Permanent flags
* OK [UNSEEN 1] first unseen message in /var/mail/nug
[[UNSEEN 1] first unseen message in /var/mail/nug]
00000002 OK [READ-WRITE] SELECT completed
Tue, 3 Jun 2003 20:23:30 +0200 (CEST)
 imap mailbox: {backup.vogelburda.private:143/imap/user="nug"}inbox, 2
messages, 0 recent

---

From: Mark Crispin <[email-masked]>
Date: Tue, 3 Jun 2003 13:39:19 -0700 (Pacific Daylight Time)

> %Mailbox vulnerable - directory /var/mail must have 1777 protection

Change the protection of directory /var/mail to 1777 protection as this
message says, and I suspect that the problem will go away.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.

---

From: Mark Crispin <[email-masked]>
Date: Tue, 3 Jun 2003 13:40:18 -0700 (Pacific Daylight Time)

Also, be sure to try unmodified UW imapd from:
	ftp://ftp.cac.washington.edu/mail/imap.tar.Z
instead of the possibly-hacked imapd that you have.

-- Mark --

---

From: Csigas <[email-masked]>
Date: Tue, 3 Jun 2003 23:37:41 +0200 (CEST)

Hi!

> message says, and I suspect that the problem will go away.

Thanks.... that was the problem, now everyting is ok...
I did not realise it was that important. (I read something that uw-imapd
needs to put some lock files there...)

 Udv,

  Csigas
"Megerint a vagy, ha faj az emlek,
Tested melyen res, az uj vilagert..."