Subject: IMAP connection broken (fwd)

From: Vadim Zeitlin <[email-masked]>
Date: Tue, 29 May 2001 16:19:44 +0200 (MET DST)

Hello,

 does anyone have any idea why can the UW IMAP server (yes, I know it's an
old version...) just break the connection like shown in the log below after
AUTHENTIFICATE LOGIN? Is there any way to work around this?

 Thanks!
VZ

---------- Forwarded message ----------
From: Guenter Milde <[email-masked]>
Date: Tue, 29 May 2001 10:37:48 +0200 (CEST)
To: [email-masked]
Subject: Re: Re: [M-User] IMAP connection broken
X-Mailer: Mahogany, 0.62 'Mars', für Linux 2.2.12-20smp i686

Here it comes: 

This is an attempt that failed:

10:21:37: Mail debug: * OK ptprs1.phy.tu-dresden.de IMAP4rev1 v10.190 server ready
10:21:37: Mailbox 'Physik-INBOX' : ptprs1.phy.tu-dresden.de IMAP4rev1 v10.190 server ready
10:21:37: Mail debug: 00000000 CAPABILITY
10:21:37: Mail debug: * CAPABILITY IMAP4 IMAP4REV1 SCAN SORT AUTH=LOGIN
10:21:37: Mail debug: 00000000 OK CAPABILITY completed
10:21:37: Mail debug: 00000001 AUTHENTICATE LOGIN
10:21:37: Mail debug: + VXNlciBOYW1lAA==
10:21:37: Mail debug: Z3VlbnRlcg==
10:21:37: Mail debug: + UGFzc3dvcmQA
10:21:37: Mail debug: YXR0aTN0dQ==
10:21:40: Status: Mailbox 'Physik-INBOX' : IMAP connection broken (authenticate)
10:21:40: Mail debug: 00000001 NO [CLOSED] IMAP connection broken (authenticate)
10:21:40: Mailbox-Log:Trying IP address [141.30.17.64]
10:21:43: Status: Mailbox 'Physik-INBOX' : IMAP connection broken (authenticate)
10:21:43: Fehler: Mailbox-Log:Can not authenticate to IMAP server: [CLOSED] IMAP connection broken (authenticate)
10:21:43: Mailbox-Log:Trying IP address [141.30.17.64]
10:21:43: Mail debug: * OK ptprs1.phy.tu-dresden.de IMAP4rev1 v10.190 server ready
10:21:43: Mailbox 'Physik-INBOX' : ptprs1.phy.tu-dresden.de IMAP4rev1 v10.190 server ready
10:21:44: Mail debug: 00000000 CAPABILITY
10:21:44: Mail debug: * CAPABILITY IMAP4 IMAP4REV1 SCAN SORT AUTH=LOGIN
10:21:44: Mail debug: 00000000 OK CAPABILITY completed
10:21:44: Mail debug: 00000001 AUTHENTICATE LOGIN
10:21:44: Mail debug: + VXNlciBOYW1lAA==
10:21:44: Mail debug: Z3VlbnRlcg==
10:21:44: Mail debug: + UGFzc3dvcmQA
10:21:44: Mail debug: YXR0aTN0dQ==
10:21:45: Mail debug: 00000001 OK AUTHENTICATE completed
10:21:45: Mail debug: 00000002 CAPABILITY
10:21:45: Mail debug: * CAPABILITY IMAP4 IMAP4REV1 SCAN SORT AUTH=LOGIN
10:21:45: Mail debug: 00000002 OK CAPABILITY completed
10:21:45: Mail debug: 00000003 SELECT INBOX
10:21:45: Mail debug: * 0 EXISTS
10:21:45: Mail debug: * OK [UIDVALIDITY 974704174] UID validity status
10:21:45: Mail debug: * OK [UIDNEXT 8033] Predicted next UID
10:21:45: Mail debug: * FLAGS (\Answered \Flagged \Deleted \Draft \Seen)
10:21:45: Mail debug: * OK [PERMANENTFLAGS (\* \Answered \Flagged \Deleted \Draft \Seen)] Permanent flags
10:21:45: Mail debug: * 0 RECENT
10:21:45: Mail debug: 00000003 OK [READ-WRITE] SELECT completed
10:21:45: Mailbox-Log:Mailbox is empty
10:21:45: Mail debug: 00000004 CHECK
10:21:46: Mail debug: 00000004 OK Check completed
10:21:46: Mailbox-Log:Check completed

And this is a successfull attempt

10:30:18: Mail debug: * OK ptprs1.phy.tu-dresden.de IMAP4rev1 v10.190 server ready
10:30:18: Mailbox 'Physik-INBOX' : ptprs1.phy.tu-dresden.de IMAP4rev1 v10.190 server ready
10:30:18: Mail debug: 00000000 CAPABILITY
10:30:18: Mail debug: * CAPABILITY IMAP4 IMAP4REV1 SCAN SORT AUTH=LOGIN
10:30:18: Mail debug: 00000000 OK CAPABILITY completed
10:30:18: Mail debug: 00000001 AUTHENTICATE LOGIN
10:30:18: Mail debug: + VXNlciBOYW1lAA==
10:30:18: Mail debug: Z3VlbnRlcg==
10:30:18: Mail debug: + UGFzc3dvcmQA
10:30:18: Mail debug: YXR0aTN0dQ==
10:30:18: Mail debug: 00000001 OK AUTHENTICATE completed
10:30:18: Mail debug: 00000002 CAPABILITY
10:30:19: Mail debug: * CAPABILITY IMAP4 IMAP4REV1 SCAN SORT AUTH=LOGIN
10:30:19: Mail debug: 00000002 OK CAPABILITY completed
10:30:19: Mail debug: 00000003 SELECT INBOX
10:30:21: Mail debug: * 0 EXISTS
10:30:21: Mail debug: * OK [UIDVALIDITY 974704174] UID validity status
10:30:21: Mail debug: * OK [UIDNEXT 8033] Predicted next UID
10:30:21: Mail debug: * FLAGS (\Answered \Flagged \Deleted \Draft \Seen)
10:30:21: Mail debug: * OK [PERMANENTFLAGS (\* \Answered \Flagged \Deleted \Draft \Seen)] Permanent flags
10:30:21: Mail debug: * 0 RECENT
10:30:21: Mail debug: 00000003 OK [READ-WRITE] SELECT completed
10:30:21: Mail debug: 00000004 CHECK
10:30:21: Mail debug: 00000004 OK Check completed
10:30:21: Mailbox-Log:Check completed

---

From: Mark Crispin <[email-masked]>
Date: Tue, 29 May 2001 12:17:21 -0700 (PDT)

> AUTHENTIFICATE LOGIN? Is there any way to work around this?

A server that just breaks the connection is probably crashing.  It's a very
old version, and it's probably hacked in some unknown way.  There isn't
anything reasonable that a client can do about it.  If the site is
complaining, tell them to upgrade to a modern, unhacked, version.