Subject: Re: Second patch for imapd under Panther

From: Chris Bunch <[email-masked]>
Date: Fri, 21 Nov 2003 10:54:34 +0000

This builds fine omm under Mac OSX 10.3 Panther with "make oxp 
PASSWDTYPE=pam SSLTYPE=unix SSLDIR=/usr"

(SSLTYPE=unix because I need both standard port 143 access locally and SSL 
for remote access: this is working fine on MacOS X 10.2 Jaguar))

I can connect fine via 143 but it doesn't authenticate login:

[theodora:~] cb% telnet 192.168.1.8 143
Trying 192.168.1.8...
Connected to 192.168.1.8.
Escape character is '^]'.
* OK [CAPABILITY IMAP4REV1 LITERAL+ SASL-IR LOGIN-REFERRALS STARTTLS 
AUTH=LOGIN] athalia IMAP4rev1 2003.343 at Fri, 21 Nov 2003 10:37:04 +0000 
(GMT)
. login cb pwd
. NO LOGIN failed

My mail client also gets an invalid account ID or password rejection when 
trying with SSL.

I must be missing something...?

C
___________________________

--On Thursday, October 30, 2003 7:04 pm -0800 Mark Crispin 
<[email-masked]> wrote:

> Hi Tom -
>
> I've already done something similar in the latest imap-2003 development
> tarball.  Could you make sure that
> 	ftp://ftp.cac.washington.edu/mail/imap-2003.DEV.tar.Z
> builds properly for you using the new "oxp" port ("OSX with PAM")?
>
> The reason why I spawned a new port is that I am concerned that the PAM
> version might not build under the previous version.
>
> Thanks,
>
> -- Mark --
>
> http://staff.washington.edu/mrc
> Science does not emerge from voting, party politics, or public debate.
> Si vis pacem, para bellum.

---

From: Mark Crispin <[email-masked]>
Date: Fri, 21 Nov 2003 08:30:53 -0800 (PST)

> PASSWDTYPE=pam SSLTYPE=unix SSLDIR=/usr"

If you use "make oxp" you do not need "PASSWDTYPE=pam".

Why do you think you need SSLDIR=/usr ?

> for remote access: this is working fine on MacOS X 10.2 Jaguar))

If you use a good quality IMAP client, it will negotiate TLS on port 143
and you would not need SSLTYPE=unix.  SSLTYPE=unix is unsafe since if
anyone installs a sniffer on your network they can steal passwords.

> I can connect fine via 143 but it doesn't authenticate login:

Did you set up PAM for IMAP?  You need an /etc/pam.d/imap (or whatever
MacOS uses).

Note that I am not a MacOS expert.

-- Mark --

---

From: Chris Bunch <[email-masked]>
Date: Sun, 23 Nov 2003 14:23:14 +0000

--On Friday, November 21, 2003 12:10 pm +0100 Beernd Noordkamp 
<[email-masked]> wrote:

>> (SSLTYPE=unix because I need both standard port 143 access locally and
>> SSL for remote access: this is working fine on MacOS X 10.2 Jaguar))
>>
> (...)
> Did you do a
> 	sudo cp /etc/pam.d/login /etc/pam.d/imap
> ?
>
> If not, PAM won't accept logins for imap. You need a copy called pop if
> you need that service, too.
>
> Hope this helps.
> Best regards,
>
> 	Beernd

Many thanks Beernd: spot on! I had a file in /etc/pam.d/imap but it had the 
wrong things in it.

Chris
________________________________