Subject: Announcing: University of Washington IMAP toolkit Release Candidate 4

From: Mark Crispin <[email-masked]>
Date: Tue, 8 Aug 2000 16:49:20 -0700 (PDT)

A new release candidate for imap-2000 is now available as:
	ftp://ftp.cac.washington.edu/mail/imap-2000.BETA.tar.Z

RC4 consists primarily of bugfixes to RC3.  It incorporates fixes to all known
problems which were reported since the distribution of RC3.  I hope that this
will be the last one!  :-)

-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Lai Yiu Fai <[email-masked]>
Date: Mon, 14 Aug 2000 12:40:23 +0800

There is minor bugs in RC4. In src/osdep/unix/Makefile.ssl, it miss a '/' 
at the end of what defined in the SSL_CERT_DIRECTORY.  Also, it found that 
RC4 enforces strong ciphers in SSL negotiation which deny connections from
those old export-grade versions of Netscape and Outlook Express.

Rgds,
Ken

---

From: Mark Crispin <[email-masked]>
Date: Sun, 13 Aug 2000 22:14:35 -0700 (PDT)

> those old export-grade versions of Netscape and Outlook Express.

Thank you for reporting these problems.  I will make sure that it is fixed in
the release distribution.

For your convenience, here are the patches to file
	imap-2000/src/osdep/unix/auth_ssl.c
necessary to fix both problems:

13c13
<  * Last Edited:       3 August 2000
---
>  * Last Edited:       13 August 2000
55c55
< #define SSLCIPHERLIST "ALL:!LOW:!EXP"
---
> #define SSLCIPHERLIST "ALL:!LOW"
693c693
<   sprintf (tmp,"%s%s-%s.pem",SSL_CERT_DIRECTORY,server,
---
>   sprintf (tmp,"%s/%s-%s.pem",SSL_CERT_DIRECTORY,server,
696c696
<   if (stat (tmp,&sbuf)) sprintf (tmp,"%s%s.pem",SSL_CERT_DIRECTORY,server);
---
>   if (stat (tmp,&sbuf)) sprintf (tmp,"%s/%s.pem",SSL_CERT_DIRECTORY,server);