Subject: rc7 fails to build out of the box on osx

From: ber <[email-masked]>
Date: Sun, 13 Oct 2002 15:33:17 -0400

RC6 built okay on this machine but RC7 fails.
Am running 10.2.x, with the aug dev tools update.

Thanks,

	brian redman

[late:~/Desktop/imap-2002.RC7] ber% make osx
make sslnopwd
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
+ Building in full compliance with IESG security requirements:
++ TLS/SSL encryption is supported
++ Unencrypted plaintext passwords are prohibited
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Building with SSL and plaintext passwords disabled unless SSL/TLS
echo "  mail_parameters (NIL,SET_DISABLEPLAINTEXT,(void *) 2);" >> 
linkage.c
cat osdepbas.c osdepckp.c osdeplog.c osdepssl.c > osdep.c
`cat CCTYPE` -c `cat CFLAGS` mail.c
`cat CCTYPE` -c `cat CFLAGS` misc.c
`cat CCTYPE` -c `cat CFLAGS` newsrc.c
`cat CCTYPE` -c `cat CFLAGS` smanager.c
`cat CCTYPE` -c `cat CFLAGS` `cat OSCFLAGS` -c osdep.c
osdep.c:137: header file 'x509.h' not found
osdep.c:138: header file 'ssl.h' not found
osdep.c:140: header file 'pem.h' not found
osdep.c:141: header file 'buffer.h' not found
osdep.c:142: header file 'bio.h' not found
osdep.c:143: header file 'crypto.h' not found
osdep.c:144: header file 'rand.h' not found
osdep.c:155: undefined type, found `SSL_CTX'
osdep.c:156: undefined type, found `SSL'
osdep.c:168: undefined type, found `X509_STORE_CTX'
osdep.c:172: undefined type, found `RSA'
osdep.c:172: undefined type, found `SSL'
osdep.c:318: undefined type, found `BIO'
osdep.c:319: undefined type, found `X509'
osdep.c:337: illegal expression, found `)'
osdep.c:337: illegal expression, found `)'
osdep.c:374: undefined type, found `X509_STORE_CTX'
osdep.c:770: undefined type, found `RSA'
osdep.c:770: undefined type, found `SSL'
osdep.c:773: undefined type, found `RSA'
cpp-precomp: warning: errors during smart preprocessing, retrying in 
basic mode
make[3]: *** [osdep.o] Error 1
make[2]: *** [osx] Error 2
make[1]: *** [OSTYPE] Error 2
make: *** [osx] Error 2

-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Sun, 13 Oct 2002 13:39:40 -0700 (PDT)

Did you read the release notes?

Those build errors occurred are because you don't have OpenSSL installed.

Subsequent to RC7, an additional set of text messages are output warning you
prior to the osdep.o build:

	Building OS-dependent module
	If you get No such file error messages for files x509.h, ssl.h,
	pem.h, buffer.h, bio.h, and crypto.h, that means that OpenSSL
	is not installed on your system.  Either install OpenSSL first
	or build with command: make osx SSLTYPE=none

---

From: ber <[email-masked]>
Date: Sun, 13 Oct 2002 16:46:11 -0400

No, I didn't.  I did read the README.  1/2 a point?

Thanks,

	brian