Subject: ipop3d POP_PROXY mode poblem

From: 최성훈 <[email-masked]>
Date: Mon, 6 Sep 2004 21:04:25 +0900 (KST)

After ipop3d in POP_PROXY mode is run, 
there is a problem of ipop3d not responding with a ERR message towards cient's RETR command but with a repeated OK response 
when a concurrent connection occurs from two clients 
while in communication with imapd which uses Unix format mailbox.

Thanks.

========== temporary patch ==========

*** ipop3d.c.orig	Tue Jun 22 09:58:07 2004
--- ipop3d.c	Mon Sep  6 17:59:09 2004
***************
*** 879,884 ****
--- 879,898 ----
    case NIL:			/* information message */
    case PARSE:			/* parse glitch */
      break;			/* too many of these to log */
+ #ifndef DISABLE_POP_PROXY
+   case BYE:                     /* BYE */
+         if (host != NIL) {
+           alarm (0);                    /* disable all interrupts */
+           server_init (NIL,NIL,NIL,SIG_IGN,SIG_IGN,SIG_IGN,SIG_IGN);
+           syslog (LOG_INFO,"Killed (lost mailbox lock) user=%.80s host=%.80s",
+                           user ? user : "???",tcp_clienthost ());
+                                 /* do logout hook if needed */
+       if (lgoh = (logouthook_t) mail_parameters (NIL,GET_LOGOUTHOOK,NIL))
+         (*lgoh) (mail_parameters (NIL,GET_LOGOUTDATA,NIL));
+       _exit (1);                /* die die die */
+         }
+     break;
+ #endif
    case WARN:			/* warning */
      syslog (LOG_DEBUG,"%s",string);
      break;

Choi, Sung-hoon 

DreamWiz Inc. - Development Team/Manager 

Major : Mail/Web/Network/System/Security 
Phone : +82-2-3434-3541 
MSN   : [email-masked] 
WWW   : http://my.dreamwiz.com/shoon/ 
E-mail: [email-masked]

-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Tue, 7 Sep 2004 16:38:37 -0700 (Pacific Daylight Time)

Thank you very much for your suggestion.

A similar change to the one that you propose will be in the next version 
of c-client.

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.