Subject: IMAP over SSL using port 993?

From: Andrew Biggs <[email-masked]>
Date: Tue, 11 Jan 2005 15:49:44 -0800 (PST)

Hello,

I've run into a bit of difficulty getting a secure
connection established between c-client and Exchange,
and was wondering if folks on this list may have had
experience dealing with this particular problem.  

Specifically, I am finding that although Exchange
doesn't appear to support the STARTTLS capability (if
you know how to turn this on please let me know!), it
does apparently listen to port 993 for connections
that begin with a TLS negotiation, followed by IMAP. 
I suspect this is considered pretty non-standard, and
out of scope for c-client.  Nonetheless, its a problem
I need to solve.

I was hoping for suggestions on how I might go about
making this work.  My first inclination would be to
write my own code to establish the connection, using
OpenSSL to secure it, and then perhaps hand the
established socket in to c-client.  Any thoughts or
suggestions would be most appreciated.

Thanks,
Andrew
-- 
------------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/imap/c-client-list.html
------------------------------------------------------------------

---

From: Mark Crispin <[email-masked]>
Date: Tue, 11 Jan 2005 15:58:16 -0800 (Pacific Standard Time)

> that begin with a TLS negotiation, followed by IMAP.

SSL negotiation, not TLS negotiation.  Specifically, the SSLv23 method, as 
opposed to the TLSv1 method.

> out of scope for c-client.  Nonetheless, its a problem

It's standard, but an older standard; and it is supported by c-client.

> making this work.

The work is already done for you.

Just add "/ssl" after the host name in the mailbox specification, e.g.
 	{imap.example.com/ssl}INBOX

-- Mark --

http://staff.washington.edu/mrc
Science does not emerge from voting, party politics, or public debate.
Si vis pacem, para bellum.