Subject: Re: Client connection resets

From: Clive McDowell <[email-masked]>
Date: Mon, 21 May 2001 10:15:58 +0100

[coninued from imap list]

Mark,

one of our network people has looked at what is happening on an 
affected client machine with an analyser and it appears that the 
following occurs -

1. client and server communicating OK
2. client issues a tcp packet with FIN and ACK flags set (no FIN sent
by server)
3. server issues a tcp packet with ACK flag set
4. client issues a tcp packet with RESET flag set

As I said before this only appears to affect some W2000 and NT PCs 
and is independent of email client software. As far as I'm aware, no 
mac or unix clients are affected.

Regards,

Clive McDowell

Information Services
The Queen's University of Belfast

On Fri, 18 May 2001 10:26:25 -0700 (PDT) Mark Crispin 
<[email-masked]> wrote:

> I don't know the answer to your question, but it's something that has come
> up from time to time, so please be sure to let the list know of anything
> that you learn.
> 
> Also, the discussion should probably be moved to the c-client list.
> 
> -- Mark --
> 
> http://staff.washington.edu/mrc
> Science does not emerge from voting, party politics, or public debate.
>

---

From: Mark Crispin <[email-masked]>
Date: Mon, 21 May 2001 12:56:24 -0700 (PDT)

> 4. client issues a tcp packet with RESET flag set

Hmm.  I doubt that this is anything that c-client can cause; it's a TCP
interoperability problem.

It's been too long since I last looked at the TCP specification for me to
figure out which is at fault, the client or server.  The client is clearly
sending the RESET in retaliation for an ACK on a session that the client
thinks no longer exists.  But it doesn't look like the session termination had
a chance to happen either.

---

From: Clive McDowell <[email-masked]>
Date: Tue, 22 May 2001 08:52:11 +0100

Mark,

I believe that the client should only transmit a tcp packet with FIN 
and ACK flags set in response to a tcp packet from the server with 
the FIN flag set. The server did not transmit such a packet under 
our observations. I'm not sure how correct the ensuing behaviour is -
maybe the server should ignore the FIN ACK? Our server is a Solaris 
2.5.1 platform patched to the latest level. Has anyone else noticed 
this with other server platforms?

Clive

---

From: Mark Crispin <[email-masked]>
Date: Tue, 22 May 2001 00:51:15 -0700 (PDT)

On Tue, 22 May 2001 08:52:11 +0100, Clive McDowell wrote:
> Has anyone else noticed

TCP-level interoperability problems between PC clients and UNIX servers have
been an ongoing problem for many years.  The problem has been in convincing
the operating system people that this is their problem and not a problem in
the application protocols/implementations.