Subject: PINE 4.21 core dumps

From: Dave Horsfall <[email-masked]>
Date: Fri, 19 Nov 1999 10:01:30 +1100 (EST)

Just installed 4.21 for Slowaris 2.5 (self-compiled - GS5), and it's dumping
core all the time.  Anyone else seen this?

Below is example from doing ";" from index:

fgh:~ [3]% adb /usr/local/bin/pine core
core file = core -- program ``pine'' on platform SUNW,SPARCstation-10
SIGBUS: Bus Error
$c
_smalloc(?) + 98
_malloc_unlocked(0x18,0x2,0xef6d5434,0x39e02c,0x8,0x72726f6e)
malloc(?) + 1c
utf8_csvalid(0x18,0x39d4dc,0x39d2df,0x0,0xefffd758,0xefffd758) + 17010
new_color_pair(0x0,0x0,0x1e5e98,0x1e5c00,0x39d2df,0x39d2d8) + 10
pico_get_cur_color(0x4,0x5,0x8000000,0x0,0x0,0xf604f668) + 14
pico_set_colors(0x3ac560,0x3ac570,0x5,0x1,0xefffdd20,0xefffd890) + 2c
blank_keymenu(0x2f,0x0,0x31,0xef6d14d0,0x8,0xefffd894) + b4
end_screen(0x0,0x1,0x1,0xef677da0,0xfc1fdc64,0xa) + d0
panic(0x30da18,0x30d800,0xf026b49c,0x0,0x0,0x0) + c
auger_in_signal(0xa,0x0,0xefffdb00,0xf025cd48,0x0,0x10000) + 74
sigacthandler(?) + 28
_smalloc(0xa,0x0,0xefffdb00,0x72726f6e,0x0,0xef6d54c4) + c
_smalloc(?) + 4
_malloc_unlocked(0x18,0x2,0xef6d5434,0x5d7598,0x8,0x72726f6e)
malloc(?) + 1c
utf8_csvalid(0x18,0x0,0x0,0xef6d5444,0x0,0x0) + 17010
fs_get(0x18,0xd8908,0xd8800,0x39d628,0x39d72a,0x0) + 34
mail_newaddr(0x0,0x0,0x0,0x30303000,0x54,0xff00) + 4
rfc822_cpy_adr(0x5e0668,0x5e0de8,0x3a000000,0x5e0de8,0x4f,0x43) + 14
rfc822_parse_msg_full(0x5def48,0x1,0x3b3302,0x1,0x0,0x3164a8) + 804
mail_fetch_structure(0x3aed88,0x68b,0x0,0x0,0x9af,0xffffffff) + 278
mail_search_msg(0x3aed88,0x68b,0x0,0x4c80e8,0xffee2000,0xf5b32ac0) + 5cc
mail_search_default(0x3aed88,0x68b,0x4c80e8,0x6,0x0,0xff00) + 184
mail_search_full(0x3aed88,0x301878,0x990,0x6,0x81010100,0xff00) + a4
select_text(0x3aed88,0x3a5070,0x976,0x0,0x78,0x0) + 14d8
aggregate_select(0x3a4778,0x3a5070,0xfffffffd,0x1,0x0,0x4c8111) + 850
process_cmd(0x3a4778,0x3aed88,0x3a5070,0x2d0,0x1,0xeffff3f8) + 29e4
index_lister(0x3a4778,0x3adcf8,0x3a47fd,0x3aed88,0x3a5070,0xeffff406) + 18c4
mail_index_screen(0x3a4778,0x109be8,0x109800,0xfdfffc00,0xf7fffc00,0x0) + f8
main(0x2,0xeffffa24,0xeffffa30,0x39d610,0x1,0x0) + 1e90

-- 
Dave Horsfall VK2KFU  [email-masked]  Ph: +61 2 9978-7493 Fx: +61 2 9978-7422
Geac Computers P/L (FGH Division) 2/57 Christie St, St Leonards 2065, Australia

-- 
-----------------------------------------------------------------
 For information about this mailing list, and its archives, see: 
 http://www.washington.edu/pine/pine-info/
-----------------------------------------------------------------

---

From: [email-masked]
Date: Thu, 18 Nov 1999 15:31:12 -0800

I compiled it on 2.5.1 (gs5) on an ultra-1 and it works ok, except that when
using pop3 it inserts a lot of garbage characters which I need to delete
before I enter the username.  Also I do not get color.  I just use the
precompiled version.

---

From: Dave Horsfall <[email-masked]>
Date: Fri, 19 Nov 1999 11:41:22 +1100 (EST)

> before I enter the username.  Also I do not get color.  I just use the

Hmmm...  I might try recompiling then, and see if it goes away (I did run
out of disk space, which I thought I fixed up).  As for colour, I never
use it anyway (and there's no way I'll use a precompiled binary on any of
my systems).

---

From: Dave Horsfall <[email-masked]>
Date: Fri, 19 Nov 1999 16:24:04 +1100 (EST)

> use it anyway (and there's no way I'll use a precompiled binary on any of

Following recompilation, it now seems OK...