Subject: Re: your mail

From: "Kelly Cunningham (Random Deviate)" <[email-masked]>
Date: Thu, 8 Apr 1993 12:25:08 -0600 (GMT-0600)

How do you guys keep the NeXT Mailer from robbing /usr/spool/mail/whatever?

I could have cron cat /usr/spool/mail/deviate into a Pine inbox and a NeXT
spool directory.  Would links from the ~/Mailboxes/Something.mbox/mbox to a
Pine mail folder work?

Am I over-complicating this? (not uncommon...)

--
Randomly, Kelly Cunningham
<[email-masked]><[email-masked]><[email-masked]>
 NeXTMail (favored) MIME (ok)     VMS Mail (tolerated)          MIME (ok)
"There is no reason for any individual to have a computer in their home."
               -- Ken Olson, President and visionary, Digital Equipment, 1977

---

From: Virtual Dave Lankes <[email-masked]>
Date: Thu, 8 Apr 1993 14:38:48 -0400 (EDT)

> Am I over-complicating this? (not uncommon...)

We have set up something in just this manner for the AskERIC project. We
use both Pine and NeXTMail at the same time (one from the consol, and one
from a vt100 terminal out of the serial port).

For the inbox we created a hard link from the mbox in the active.mbox
(mailboxes are just directories with special extensions) to a file in the
mail directory where pine keeps its "folders" (we call the linked mbox
NeXTMail to prevent confusion). You can do this with more than one
mbox/folder. Presently we share about 20 different NeXT mailboxes with
Pine, so both archive to the smae file, and the messages are accessable
from both places.

the command from the home directory:
ln Mailbox/<nameOfMailbox>/mbox mail/<nameOfFolder

so to create our NeXTMail directory we:

ln Mailboxes/Active.mbox/mbox mail/NeXTMail

it is that easy.

The only problem we have found, is that when NeXTMail accesses a directory
in use by Pine (i.e., at the same time), Pine freezes UNTIL NeXTMail stops
using that directory (i.e., NeXTMail wins).

This system is great for working the two systems together So you NeXTMail
at work, and Pine at home. It is really easy too (I hope I haven't made
this too confusing or rambling).

Let me know if you have any problems.

.........................................
: R.David Lankes (a.k.a."Virtual Dave") :
: Technical Consultant AskERIC Project  :
:   Coordinator Oliver/AEGIS Project    :
:         Syracuse University           :
:     School of Information Studies     : 
:       [email-masked]         :
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

---

From: Mark Crispin <[email-masked]>
Date: Thu, 8 Apr 1993 12:15:21 -0700 (PDT)

Kelly -

     The strategy most of us use to avoid NeXTmail's behavior is not to use
NeXTmail at all.  NeXTmail is, after all, unsupported and doesn't handle MIME,
and (at least in the past) has had security bugs you could drive a truck
through.

     You can use something like our mail-dup utility (included below) to have
all copies of your mail go to two different places, and read your Pine mail
from the copy.  But that won't keep NeXTmail from stealing the /usr/spool/mail
file on the NeXT; you'd either have to run Pine on some other machine or use a
different inbox path in Pine besides /usr/spool/mail.

-- Mark --

#! /bin/sh
: '
: This filter when used in a .forward file causes mail to be
: forwarded to the BACKUP host if and only if it hasnt already been
: forwarded.  If that delivery fails, the failure message comes
: to the owner of the .forward file, not the original sender.
:
: The following line is a sample of the expected .forward file:
:	\corey, "|this-filter user@host"
:
: Corey Satten, [email-masked]   and
: Steve Hubert, [email-masked]  89/04/28
: '

PATH=/bin:/usr/ucb:/usr/bin; export PATH
TMP=/usr/tmp/mfil$$
HUMANSTAMP="Received: by Mail Duplicator - Do not forward."
NOFORWARD="X-Status: - - - - - - - - - -"
MAILER=/usr/lib/sendmail
RETURN=75		# (this is EX_TEMPFAIL from /usr/include/sysexits.h)
trap 'rm -f $TMP; exit $RETURN' 0 1 2 13 15

for i in $*; do
    case "$1" in
	-p)	MAILER="cat"; BACKUP=" ";;	# don't mail, just format
	-s)	SUBJFLAG="++";;			# flag subject with ++
	-h)	HOSTNAME=`hostname`;;		# put hostname in message
	*)	BACKUP=${BACKUP-$1};;		# backup destination
    esac
    shift
done
case "$BACKUP" in '')
    echo $0: missing argument: user@host 1>&2; exit 1;;
esac

if cat > $TMP ;then : ;else exit ;fi		# fail if /tmp full

if sed '/^$/,$d' $TMP|grep -s "^$NOFORWARD" ;then
    RETURN=0; exit				# never re-forward
fi

sed '
    s/^\.$/& /
    s/^\(Subject:\) \(.*\)/\1 '$SUBJFLAG'\2'$SUBJFLAG'/
    1,/^Received:/ {
	/^Received:/i\'"
$HUMANSTAMP\\
$NOFORWARD${HOSTNAME+ ($HOSTNAME)}
	}
    1 {
	/^From /d
	}
    " $TMP |
	$MAILER $BACKUP

case $? in
    0) RETURN=0;;				# MAILER delivered ok
esac